Results 1 to 7 of 7
Like Tree2Likes
  • 1 Post By Grabber5.0
  • 1 Post By Aressel
  1.    #1  
    I'm making this thread to clarify what problems there are with the app gallery so we can request a fix.
    From a user perspective, the Gallery is searchable, but an attempt to download an app seems to require a login - even if I am already logged in. I think this happened in the past, but the code on the link to do this appears broken.
    This is possibly because the gallery is part of rather than When navigating to the former, it seems I'm not logged in and clicking the link to do so results in a white page that just says, "Link expired".

    So can we access the apps via Preware? I did a quick check on a fairly recent app:
    In Preware, I see version 1.3.3 from 2015. The app gallery lists version 1.4.0 from 2016. So assuming this app was only posted in the gallery, it seems an update is not available. It also seems that preware is struggling to install it, so maybe the feed is not updated or completely broken. Can someone more technical offer a more definitive answer?

    The next thing to do is ask app developers about their experiences:
    • Can you log in to your developer account? (It seems the answer is yes)
    • Can you post a new app?
    • Can you update an existing app? (App description can be updated)
    • Anything else to report?

    I suppose at some point I should see if it's possible to create a new developer account, but I guess that requires human approval.
    Last edited by Preemptive; 03/07/2018 at 04:08 PM.
  2. #2  
    I thought it was documented pretty well in another thread. The last time I tried to update something was some time ago, and the update process wasn't working, and login at one time. I reported that and it was fixed, I updated an app, but something was broken between the gallery and the webOS internals process that updates the Preware feed, so updating apps at that point didn't matter. I think that's where the issue still stands.
    Preemptive likes this.
  3.    #3  
    Thanks. I'm not sure about a thread. I know I've seen comments before and have probably already posted some of my remarks above before. I'll do a thorough search in a while. Someone's looking at the patch portal, but it's more complicated than first thought. Perhaps the app gallery feed has a similar issue. I suppose that as long as apps can either be accessed here directly or via Preware, then that's good enough, though both would be better. As with the patch portal, if there is an issue with Preware, then there are user group members who can at least look into it.

    I think the gallery pre-dates Preware (not sure) and that update problems would begin here, though it's perfectly possible that more than one link in the chain is broken.

    So I think you're saying that developer login is OK, as is submitting a new app, but updating is somehow broken. We know that gallery search seems OK, but user access is broken, either due to broken links, or a deeper problem.

    It will be good to get more responses. I may tweet this thread over the weekend. webOS Nation is obviously a low priority to Mobile Nations, but if we can make a comprehensive description of the problem, it may help in getting a fix.
    Last edited by Preemptive; 03/07/2018 at 04:09 PM.
  4.    #4  
    OK, a summary of postings about the app gallery taken from the old thread:
    Quote Originally Posted by Nafetz View Post
    Uploading an app in the app gallery isn't possible anymore - at least when trying to make an update. The error message is:

    An HTTP error 0 occurred. <br />/filefield/ahah/app/field_installer/0

    Besides it is hard to find the app gallery if you are new to this forum, because there is no link to it any more on the main forums page.
    Quote Originally Posted by HelloNNNewman View Post
    Is this working yet? We've had a tech fixing issues on the site and I need to know if we are still having issues with the App Gallery that I can have his address while I've got his attention.
    Quote Originally Posted by Grabber5.0 View Post
    I tried to test, but the main site login seems to be broken. It hasn't shared session with the forums in some time, so I always have to log in on the main site, but today I'm getting "Link has expired" when I click the login button on the main site, regardless of browser. Also I noticed webOS Nation does not show up under the Passport community accounts section. Is our third class Mobile Nation citizen status causing us issues?
    Quote Originally Posted by Nafetz View Post
    I'm sorry. Still getting the same error as before and can't upload an update of my app.
    I'm getting a "Link has expired" message too in the app gallery. But when returning to the app gallery I see that the login was successfull.
    Quote Originally Posted by Grabber5.0 View Post
    I was finally able to log in, but still can't delete my GlobalSign Root Cert Updater app. I was, however, able to update the description, so not all is lost. I may try to update the IPK as a test before thinking about finishing up some in-progress updates to Forums and trying to publish it.
    Quote Originally Posted by Grabber5.0 View Post
    The app description hasn't updated in Preware, so it seems the update process isn't working, or changing the description isn't enough to get picked up, but I'm pretty sure it should.
    Quote Originally Posted by Grabber5.0 View Post
    Now that the login issue is resolved, I have confirmed that this is still not working. This time I had the debugger open and was able to determine that the ipk upload is getting the same security error reported earlier when trying to delete an app. It displays a cryptic message because the upload is using a webservice call not loading a new page.
    Quote Originally Posted by Preemptive View Post
    I'm reporting an apparent problem with the app gallery.
    Reference: Calculator App ( - webOS Nation Forums
    First up, the link bar that appears on webOS Nation | webOS Forums, News, Reviews, Apps and Help does not appear on the forum pages - which is where most activity is taking place I suspect.
    If I go to to App Gallery | webOS Nation and click on an app, to download I'm invited to register or log in (I'm already logged in, but I recall this situation occurring before - maybe to do with the passport thing)
    Both links are
    and result in a 'page not found' message from the site.
    I expect many regulars here have the apps they want or use preware to access them, but there is still the occasional new app posted and there are still a few new people showing up, so a fully functional site would be nice, though I realise webOS Nation is low priority.
    Quote Originally Posted by Nafetz View Post
    I'm really sorry - I forget to tell something...
    Tom Kaminski from mobilenations sent me a mail on August 21th, that he made some changes in cloudflare settings. I tested in changing one word in the description of one of my apps and it worked again. I don't have a real update of one of my apps at the moment. But it may be possible to upload updates again in the app gallery!
    Quote Originally Posted by Grabber5.0 View Post
    Cool, I'll give it a try with one of mine. Does anyone remember the status of the Preware feed? The last I remember it was not being updated.
  5.    #5  
    The last post above was from 09/23/2017.

    So it seems:
    • Users attempting to download an app from the gallery are required to log in again, but the link is broken or expires and so it is not possible. It may simply be that logging in on the site is broken or it may be a deeper issue.
    • It IS possible for a developer to log in.
    • It IS possible for a developer to update an app description.
    • It is NOT CLEAR if it is possible to upload an IPK or update one.
    • It is NOT CLEAR if it is possible to create a new developer account (maybe I should try..?) Presumably, some human approval is required.
    • It seems that updates are not causing the Preware feed to update. I can ask if anyone at Internals / Ports can check if the problem is at their end.
    • More testing is required to establish if app gallery apps can be downloaded - either old or updated versions - via Preware.

    'Good enough' solution:
    • Existing dev accounts can update old & upload new apps.
    • Apps can be accessed either directly from the gallery or via Preware.

    Better is as above and...
    • New dev accounts can be made.
    • Downloading from the gallery AND Preware both work.

    Can anyone confirm / contradict or add to the above?
    Last edited by Preemptive; 02/25/2018 at 12:47 PM.
  6. #6  
    It may be a little late to reply here, but I can confirm that I can upload a new ipk for an existing app.
    Developer of FeedSpider - The best webOS newsreader, supporting AOL Reader, BazQux Reader, Feedly, InoReader, OwnCloud News, Tiny Tiny RSS, and The Old Reader, with more to come.
    Preemptive likes this.
  7.    #7  
    To add for today's meeting (only 6 months+ later!):
    Is it possible the things work on the 'dev' side (but not the forum user side)?
    Is it possible that the lost php code for Preware means that downloads via would work if we manually update the feed data?


    OK. I tested on the Feedspider 2 app just via a desktop browser.

    "login or register to download this app". I clicked the link and it fails as per the first post of this thread.
    I clicked the back button, then clicked the login link at the top right of the page (it seems being logged into the forum is not the same as being logged into webosnation)
    No password required, the page simply reloaded, now there is a download link on the app page and even text of the link I can copy.

    I vaguely recall finding a way to download in the past by 'guessing' the link and I wonder if someone has updated / fixed and included the text code as 'belt & braces'.

    Anyhow, it seems to work. I'll have a quick look via the pivotCE feed, then Preware.

    pivotCE: Feedspider 2 does not appear in the chart, but a search brings it up. It is version 2.0.6 from 2015, not the 2.1.0 release from this year. As the pivotCE catalogue is basically a frontend to the Preware feed, this suggests an update problem there...

    Preware: Searching on the TP version of Preware shows only Feedspider, not Feedspider2... odd. I don't really understand that!
    Last edited by Preemptive; 12/13/2020 at 10:33 AM.

Similar Threads

  1. put my app on lg samsung app store
    By streamkings in forum LG webOS TV
    Replies: 1
    Last Post: 02/21/2018, 02:02 PM
  2. Replies: 0
    Last Post: 02/03/2018, 05:58 PM
  3. Is it possible to purge an App data?
    By Exnor in forum LG webOS TV
    Replies: 5
    Last Post: 01/24/2018, 10:17 PM
  4. Mvix Releases webOS App for LG SoC Signage Screens
    By akitayo in forum LG webOS TV
    Replies: 0
    Last Post: 01/11/2018, 08:46 PM
  5. Replies: 0
    Last Post: 01/11/2018, 08:45 PM

Posting Permissions