Results 1 to 12 of 12
Like Tree3Likes
  • 1 Post By Grabber5.0
  • 1 Post By petbull
  • 1 Post By Carren Smrstik
  1.    #1  
    Not sure if this is the forum for help and support, but I am going to try...

    On Tuesday my veer was running slowly, so I did a restart to hopefully help it run quicker. Something happened and the USB screen appeared. The screen that is all black except for the white USB symbol.

    After searching this site and all the forums, I was able to determine that I can run webos doctor to help.

    LUCKILY, I had a version of webos doctor already downloaded from April 2014 (have since learned that doctor has been recently removed).

    Tried running webos doctor and it gets to the "Connect device" and doesn't recognize the device.

    I have some hope that I can recover my Veer because when I connect to the computer, it is recognized by the computer but as a Palm device. Kind of like the little black box after a plane wreck, I have hope there is still life.

    I have searched through old forums and posts and have tried all the suggestions to get webos doctor to work, but not successful. Most suggest a battery removal which is obviously not possible with the veer.

    I have downloaded an old version of Java because that has been helpful in past troubleshooting with webos install. Still no luck.

    Any ideas that are more current than posts from 2011?

    Another question, do I take this as a sign that it might be time to break up with my Veer? (Please say, "no." I'm not ready to start a relationship with a new device.)

    Any guidance or direction to helpful posts is appreciated.
  2. #2  
    Yes, battery removal is possible. I recall seeing a "how-to" on battery removal in Rod Whitby's Veer teardown photoset on Flickr. However I'm on my phone and falling asleep so I can't promise it now.

    The main idea is to pop off the back cover without ripping it off, where the Touchstone coil's ribbon cable would still tether the back to the phone's body. There's enough room to get the battery out and back in
  3. #3  
    Open wosqi and open Linux commandline in the tools menu. Type reboot and hit enter.

    You might also try holding down the power button on your veer and toggling the mute switch on and off 3 times. Should force a reboot.

    Good luck.
    Follow me on Twitter
    For the latest webOS news check out pivotCE
  4. #4  
    Quote Originally Posted by Alan Morford View Post
    Open wosqi and open Linux commandline in the tools menu. Type reboot and hit enter.

    You might also try holding down the power button on your veer and toggling the mute switch on and off 3 times. Should force a reboot.

    Good luck.

    Yes start with the hard reset Alan mentioned if you dont have wosqi on a pc handy. The other method is 2ndshift (white square )+ sym + R.

    When you do the doctor again, i believe u need it in recovery mode. Thats usually requiring a battery pull which u cannot do easily.

    HOW IS IT DONE WITH VEERS, ANYONE? Maybe google this
    Sporting my 13th Pre device, a NOS unlocked ROW Pre3!
  5. #5  
    Recovery mode on any the Veer and Preł (it might also work on the Pre˛) can be accessed by pressing Opt+Sym+R, and holding the R key down while it reboots, until the USB symbol shows on the screen.
    TJs11thPre likes this.
  6. #6  
    for what it is worth, the battery on the Veer is easily removed. Just pry your fingernail around the edge of the back and gently remove it. The battery is in a metal frame which you can pry up and slide the battery out. I bought several replacement batteries for my Veers.
    Remy X likes this.
  7. #7  
    I should probably buy another spare battery..

    Did you ever get the doctor to work?
  8.    #8  
    Thanks for all the ideas but I am still stuck.

    Is there a way to tell if I have a webos doctor file that is compatible? I downloaded it 4/22/14.

    I have tried all the hard reboots mentioned here. Still have the USB screen.

    I will attempt to remove the back cover and try to get the battery out.

    I know my phone is in recovery mode, so I think webosDoctor is my best hope. It is Doctor that I can't get to run.

    New status: Prior to today, when I attached the phone to the computer, it was recognizing it as a Palm device so I had hope. Now, when I attach it, it does not recognize it at all.

    While trying to repair this phone, I resurrected an old Veer with a cracked screen and have gotten that up and running for now (having trouble installing the Google patches even after I downloaded the updated one, but that is a minor problem in comparison).

    My newer device was not unrecognizable by my computer AFTER I was running webosQI for my old phone. Is this any significance?

    I appreciate any and ALL help!
  9.    #9  
    Holy S***! Webos Doctor started to run and recognize the device! Ran a complete check. I don't think it is good news, though. Still stuck in recovery mode even AFTER doctor ran. I got a picture of a microchip and an arrow during the Doctor. I've tried rebooting it and still seems to be stuck. Will try removing battery next.

    I have NO idea what finally worked. I have rebooted device and computer more times than I can count over the last week and it suddenly decided to work. Maybe there was a perfect combination of "plug into computer, plug into device, start program" that I did unbeknownst to me.
    Preemptive likes this.
  10. #10  
    There's two possibilities... one, the volume-up key is stuck, and two, something died inside of the newer Veer.

    The USB "fork" screen and the "microchip", aka "" screens are both part of the bootloader, which is a small program that controls the loading and start-up of an operating system. There's usually something like three parts to a bootloader, each progressively more complex and functional, until it finally hands off the control of the phone to webOS' Linux kernel.

    Sounds like this hand-off isn't happening, and if you get the "ROM" screen after doctoring, perhaps the flash memory (persistent storage) is starting to fail, and an important file was written to a damaged section of the memory chip. The fact that your Veer was slow as molasses may be a sign that this is what happened.

    Sometimes, if you fill a flash drive more than half way (4GB in case of the Veer), and have written more than 8GB (full capacity) over its lifetime, the flash memory can lock up and become read-only, and then die completely when the controller chip becomes "confused" as to how to manage wear-leveling inside the flash memory, which itself can suffer from "burn-in" like an old TV screen. It doesn't happen very often, but not everyone is lucky, so it's a real possibility

    What you might be able to do is to use Novaterm (a command line tool) to "talk" to the bootloader and run some diagnostics. This is not my forte, but someone here should be able to help you out

    Here, in the blue pane you'll find a link for Novaterm: Portal:Accessing Linux - WebOS Internals

    Here's a bit of an intro on "bootie", the bootloader: Bootie - WebOS Internals
  11. #11  
    Do you know what happens if you try to format the drive with windows explorer and then run the doctor? Is that possible?
    Sporting my 13th Pre device, a NOS unlocked ROW Pre3!
  12. #12  
    Quote Originally Posted by TJs11thPre View Post
    Do you know what happens if you try to format the drive with windows explorer and then run the doctor? Is that possible?
    I like your thinking, but...The Windows format utility is designed for mechanical (spinning disc) drives, and can cause unnecessary wear to flash memory. And what's more, the only part of the SSD/flash that Windows sees a a USB drive, is the "/media/internal" partition that has photos you take, etc, but not system files. So if she wants to, she may be able try and mount the whole SSD as a drive under Ubuntu, and see what files are even present. But that's really a job for an expert, because it looks like hardware is already failing and she might be better off transferring the good screen digitizer to the old Veer and using that instead. The Veer has a beautiful, solid feel to it, better than the Pre+, but the grade of microchips used in building it and the Pre3, is, well... cast-offs, not grade A, so those devices are not expected to really last past the two year carrier contract. HP has done that with computers too, some of which have failed just outside of warranty or barely inside it. "Working defectives" are a painful thing to deal with when you become attached to a device with "time bomb" quality hardware. At least the Veer is only $100 unlocked.

    But anyway, there are some flash memory format utilities that can be run under Linux once you mount the whole SSD as a drive

    There may be a chance for her to do that under Ubuntu, and check if anything survived on the "USB drive", then low-level erase and repartition the SSD before doctoring. It might help or it might not. It's always worth trying.

    I don't mean to be the bearer of the bad news. I love the Veer, but HP didn't love it enough to give it the "bullet-proof" hardware that the Pre+ and Pre2 had underneath their flimsy plastic shells.

    [Edit].... Hmm... she hasn't pulled the battery yet, as of her last reply. Fingers crossed, maybe we'll see improvement or a complete recovery
    Last edited by Remy X; 11/11/2014 at 02:07 AM.

Similar Threads

  1. Veer running webos 2.1.1 ?
    By nexotron in forum HP Veer
    Replies: 16
    Last Post: 07/13/2011, 01:58 PM
  2. WebOS stuck in 1.3.1 after running WebOS Doctor
    By John745577 in forum Palm Pre and Pre Plus
    Replies: 6
    Last Post: 01/24/2010, 04:38 PM
  3. Will running the WebOS Doctor help with this situation?
    By texasfemale9569 in forum webOS Discussion Lounge
    Replies: 4
    Last Post: 01/20/2010, 12:09 AM
  4. First time running webos doctor.. So excited! Lol
    By SISGO in forum Palm Pre and Pre Plus
    Replies: 6
    Last Post: 11/22/2009, 11:05 PM
  5. Activation issue after running webos doctor
    By Akaihiryuu in forum Palm Pre and Pre Plus
    Replies: 9
    Last Post: 11/20/2009, 04:18 PM

Posting Permissions