Results 1 to 15 of 15
Like Tree1Likes
  • 1 Post By RCorner
  1.    #1  
    I have a Verizon HP Palm Pre2. worked for a week. As of yesterday, Fastmail stopped receiving and sending emails. Error message: "Requested encryption not supported by server."

    I didn't change any settings. The encryption is SSL. If I change the incoming and outgoing server settings to no encryption, error message: can't connect to server.
  2. #2  
    I have the same problem. It is related to an update Fastmail did on their server yesterday.

    Here is the response from Fastmail support about this problem:


    We recently made an SSL update:

    All SSL certificates updated | FastMail Weblog

    Some old clients would need their root certificate updated.

    All you need is to install the new root certificate on your client. You can find the download links here:


    I installed the new certificte as Fastmail suggested but it doesn't change anything.

    Any idea how we can fix this?
  3. #3  
    if you look at the certificate of on your PC browser you see that the chain contains two CA Certs:

    Try downloading both:

    DigiCert Global Root CA:
    Valid until: 10/Nov/2031
    Serial #: 0C:E7:E0:E5:17:D8:46:FE:8F:E5:60:FC:1B:F0:30:39
    Thumbprint: 0563B8630D62D75ABBC8AB1E4BDFB5A899B24D43
    Test my browser for this root certificate

    DigiCert SHA2 Secure Server CA:
    Valid until: 08/Mar/2023
    Serial #: 01:FD:A3:EB:6E:CA:75:C8:88:43:8B:72:4B:CF:BC:91
    Thumbprint: 1FB86B1168EC743154062E8C9CC5B171A4B7CCB4
  4. #4  
    I downloaded and installed the two certificates but I stil get the same error.

    Is is possible that the mail application still try to use the old certificates?
  5. #5  
    perhaps a device reboot could do.
    "Requested encryption not supported by server."
    Or it is really a different (newer) encryption protocol (version) that is needed (e.g. TLS1.2) and the phones openssl lib can not deliver it.
  6. #6  
    "Requested encryption not supported by server" means it's trying to use STARTTLS but the server doesn't support it. The error is not related to certificates.

    Double check to sure that both your incoming and outgoing servers are using "Encryption: SSL" not "Encryption: TLS". If that doesn't work, try removing the account and readding using manual setup with the server settings listed at
  7.    #7  
    Thank you Gizmo21 for identifying the two required certificates. Thank you jl85.

    After following the instructions including deleting my account and setting it up again, I receive the same error message: "Requested encryption not supported by server."

    I requested help from fastmail on their forum.
    "Requested encryption not supported by server" - Page 2 -

    I will continue to look for an email client that still works.
  8.    #8  
    Great news! I discovered an IMAP email client on that still works on HP Palm Pre2! uses open software, is not in PRISM, based in France, respects privacy, strips IP address from header of email, encrypts send messages and offers option to disable HTML. I will be making a donation after computing US $ to euros.
  9. #9  
    besides the DigiCert Global Root CA and the DigiCert SHA2 Secure Server CA
    you will also need the * certificate as provided in the attached zip-file.
    Attached Files Attached Files
  10. #10  
    Fastmail access works again on my Pre3! I deleted the Digicert certificates from the cert manager and it still can reach the fastmail server (manual setup)...
  11. #11  
    Quote Originally Posted by phiop View Post
    besides the DigiCert Global Root CA and the DigiCert SHA2 Secure Server CA
    you will also need the * certificate as provided in the attached zip-file.
    I added the * certificate and now email works as before.
  12. #12  
    Just wanted to tack onto this thread that the above message may be seen when accessing a server which implements (perhaps after an upgrade TLS extensions which are not supported by the older SSL implementation on Palm/HP webOS devices (I can't speak to such support under Open webOS or LG webOS).

    Quick example:

    I upgraded my mail server from CommuniGate Pro 5.2.18 to 5.4.10 this afternoon. Immediately, my Pre3 and TouchPad complained that they couldn't connect to the server (configured for IMAP on port 143 with TLS). I use a self-signed cert on the server, and this did not change. Nevertheless, I deleted the cert from both devices and added it back. Still, I got the above, with the details provided as:

    Unable to sign in; unable to validate incoming mail server settings. Check the settings and try again.; Requested encryption not supported by server. Error code 9820: Non-specific SSL protocol error -- src/network/SocketConnection.cpp:168
    In the browser, attempting to connect to webmail or the admin interface, the TouchPad just threw (an unhelpful) "Unable to connect to server" popup.

    CommuniGate's support knowledgebase came to the rescue with a startup parameter for the server, explained as:

    --TLSServerHelloExtensions NO

    This one has been added as the workaround for problems accepting TLS connection requests from clients that used older versions og OpenSSL libraries and advertize support for some TLS extensions which are not really supported. Examples of this are financial institutions unable to send mail to your CGP server. Connection is made but TLS fails to negotiate. More on what the TLS Extensions are (and in turn what is disabled when you use the above parameter) can be found here:
    Sure enough, once I added this and restarted the daemon on the server, I was able to establish TLS and SSL connections, and the web interfaces came right up.

    So, the point is that sometimes it may be something on the server side. Obviously, I'm in a better position than most in this regard, as I run my own mail and web servers and can troubleshoot from both sides, but the moral here is that should something like this just come about all of a sudden, it might be worth at least asking the provider if there has been a change to the security protocols (not just the certs!) on the server.

    Cheers. HTH
  13. #13  
    I know this is old, but I just started going through the same thing, and Fastmail supports helped me out, so figured I'd pass it on...
    If you're getting, 'server's security certificate is invalid', after installing the certificates listed above, you can gain pop/IMAP access with a different server, Just change the server name in settings, and trust this certificate in device mgr., (

    -- Sent from my Palm Veer using Forums
  14. #14  
    I started getting the message: "Requested encryption not supported by server" on my Pre3 and Touchpad on 25th February 2015 with my Ntlworld account. It has been working well for years.
    After reading around the subject in these forums, and not quite understanding how to get these certificates from somewhere and then installing them, I thought I would try removing the Ntlworld account from the Pre3 and then creating the account again. It has worked!
    I have removed the Ntlworld account on the Touchpad and recreated it similarly and it works again. Phew!
    The only difference I have made is that previously, I had as the incoming server name, now VirginMedia say it should be using the settings on the website.

    I hope this might help someone else!
    I love webOS

    Richard Corner
    Nokia 6310i, Palm Treo 600, Palm Pre, HP Pre3
    Preemptive likes this.

Similar Threads

  1. Replies: 13
    Last Post: 07/28/2013, 01:11 AM
  2. Replies: 1
    Last Post: 09/05/2010, 12:50 AM
  3. Problems with Pre Help app - "failed to load the requested page"
    By flamand in forum webOS Discussion Lounge
    Replies: 5
    Last Post: 11/28/2009, 10:31 AM
  4. Blazer on Centro: "Cannot find requested page"
    By urban75 in forum Palm OS Devices & Apps
    Replies: 3
    Last Post: 06/24/2008, 06:17 PM
  5. VERSAMAIL: "Get" vs. "Sync Server Folders" ???
    By tmekjian in forum Palm OS Devices & Apps
    Replies: 0
    Last Post: 07/20/2005, 08:21 PM

Posting Permissions