Results 1 to 17 of 17
  1. swolf76's Avatar
    10 Posts
    Global Posts
    23 Global Posts
    I have owned my Palm Pre since September 2009. Lately, I have noticed that the battery has been draining very quickly, i.e barely making it six hours on a single charge. I decided to buy a new battery. However, I noticed the exact same behavior with the new battery. I even did a little expirement. Last night I put my phone in airplane mode at 10 PM fully charged. At 5:30 AM this morning the phone was down to 40%. What am I doing wrong?

    Before you answer, I have tried to optimize battery life by doing the following:

    - GPS is always off
    - I am connected to the Wifi network at home
    - I keep IM and Gmail chat off
    - I keep the screen very dim.

    These measures used to be effective in conserving power, but even with my new battery, I am still experiencing the same problems. Please help! Thanks.
  2. J bird's Avatar
    11 Posts
    Global Posts
    13 Global Posts
    I am having the same issues, and thought that some of my patches may be 'leaking'. So, I DR'd my device and am running pretty pure right now, and still not having much luck. I am not sure what else to do... I am making it about the same, 5-6 hours.
  3. #3  
    Quote Originally Posted by swolf76 View Post
    These measures used to be effective in conserving power, but even with my new battery, I am still experiencing the same problems. Please help! Thanks.
    Could the new battery be bad? Do you have any friends with a Pre that you can swap batteries with?

    You might try running Dr. Battery to verify both of your batteries health scores. I suspect that's not the problem but I wanted to toss it out as an option.

    If you use homebrew you might try listing out the patches you have installed and any long running apps.

    Last but not least - you could remove all patches or doctor and see if this resolves anything. I realize this did not work for another person on the thread but perhaps their situation is different.
  4. dizzwave's Avatar
    98 Posts
    Global Posts
    109 Global Posts
    Hmm, I came to the forums today for just this issue. I put my phone in a data-off mode at night to conserve power, and I usually only lose 10% or so (through the whole night). But, the past couple of nights, I've been losing 50%. With data off!!

    This could be due to the following new things I recently installed/updated:
    -the latest UberKernel from the testing feed (usually I wait til it's out of test, but I really wanted the latest one with the fat-finger-prevention-disabler)
    -the latest Govnah from the testing feed (again, usually I wait til it's out of test, but I was feeling adventurous)
    -KeyBoss (for the fat-finger thingie)

    I think that's all. Does any of this match what you other folks with the recent battery drain have?


    : I just checked the FreeTether sticky thread, and it looks like other folks who have installed this are experiencing battery drain, even with tethering turned off. Any of you guys using FreeTether by any chance?
    Last edited by dizzwave; 01/07/2011 at 11:17 AM.
  5. #5  
    If it's not the battery, it's the butler!
  6. #6  
    I found the same with my Pre since two or three weeks, but not with my Pixi, where I disabled the Palm's update demon months ago (chmod). Pixi is for work (including Classic), Pre for development (I need to know when next WebOS update arrives.

    Maybe someone could try to do the same on its Pre.
  7. santos's Avatar
    578 Posts
    Global Posts
    626 Global Posts
    I too am having severe battery drain issues. I have my phone just sitting there and 30 min later, my battery drops from 50% to 20%!

    I also bought a new Palm branded battery which didn't help.

    I have the latest UberKernal that supports the fat finger switch and keyboss. Could these two be the culprit? I'm going to remove both and see how my battery fares tomorrow.
  8. #8  
    My original pre's battery has been dying for the past two weeks. I start out with 100% at 7 am and by 10am I have no more than 40%. And that's not with more than 3-4 calls and 3-4 emails. I was about to purchase a new battery, but on second thoughts perhaps not.
  9. #9  
    Replacement batteries can be gotten very cheap on Ebay.

    Posted from my eVo!
    Sent from my favorite gadget!
  10. santos's Avatar
    578 Posts
    Global Posts
    626 Global Posts
    Alright.. I did some testing. I removed UberKernel v 1.45-138 and KeyBoss this morning, starting with about a 94% charge on my Pre's battery. After going about 12 hours today without a charge with medium usage, my battery is now at 30%. With UK 1.45-138 and Govnah set to a conservative governor, I was lucky if I could go 5-6 hours when I used to get 9-12 prior to 1.45-138.

    I'll reinstall UK 1.45-138 to see if the battery dies faster again. Perhaps it's something that was added to this specific version of UK (like uinput) affects battery usage?

    Can anyone else confirm?
  11. #11  
    Member arrasmith has the same problem on one pre and we deeply debugged the issue.
    His problem has to do with the pre not entering the deep sleep state.
    He came up with an interesting workaround:

    EDIT: He also posted a way to find out, if this is your problem.
  12. #12  
    I have had this problem too, and i have all along thought it was a kernel problem.
    But after switching kernels, no improvement.

    No reading this post I realise it was
    AFTER installing KEYBOSS.

    I uninstalled keyboss, now battery life is back.

    even turning off keyboss won't do, uninstall was nessesary.

    I love keyboss! Hope to see a fix soon!

    Last edited by chrislo; 01/09/2011 at 03:56 AM.
  13. santos's Avatar
    578 Posts
    Global Posts
    626 Global Posts
    Update number 2. After another day of testing with UberKernal 1.45-138 and no Keyboss installed, I'm back to my normal battery life.

    Definitely seems like something is up with Keyboss. Perhaps we should post our findings in the Keyboss thread?
  14. swolf76's Avatar
    10 Posts
    Global Posts
    23 Global Posts
    Thanks to everyone for your help. I tried installing Nodoze, but that did not seem to have any positive effect on battery life. I did, however uninstall keyboss and I already notice a difference. I that think that keyboss was the problem.
  15. #15  
    Oh, wow, so this thread explains it entirely. Good detective work. I was really getting frustrated at being unable to find the root cause of my 12%+ battery drain while idle (normal for me is 1-2%, I know!).

    Keyboss, what's up with you preventing our phones from entering deep sleep? Uninstalled for now.
  16. #16  
    chrislo, thanks so much for figuring out what was wrong. Been pulling my hair out for several weeks. Tried out every experimental kernel out there, including different voltage settings and nothing helped. Even different batteries. 15% plus an hour drain went down to 2-3%.
    Commodore Pet, Commodore 64&128, Amiga 4000, PC-7, Ubuntu, Treo 650. Treo 755p,Sprint Palm Pre Plus 2.2.4,2 Sprint Pre2 2.2.4, TouchPad 32gig.
  17. yitzchok3's Avatar
    2 Posts
    Global Posts
    6 Global Posts
    but I have the same problem and done remember installing keyboss!

Posting Permissions