Hi, first let me say I'm a complete noob on any sort of phone os hacking so please forgive what are probably completely easy questions to most people here. Essential info - I have webos on a Sprint US palm Pre and an imac running 10.5.8 Mac OsX

I wanted to try and setup my pre for bluetooth tethering and since there appear to be many comments on the Mytether app that it no longer seems to work with webos I thought I'd try the 'hard' way instead.
I found this set of instructions in the forums under the thread :-

and have tried to follow them but I'm already having a problem with the enabling ssh part of the prerequisites.

I followed the instructions to access linux from this webos-internals wiki link:-

and that all worked perfectly.
I then went on to the next webos-internals wikipage called NextSteps and all of this was ok but I don't understand the 'Finishing' section so I could do with some help.

so the main problem is - it says ssh to that ip address on port 222 - so I don't actually know the correct syntax for this but a quick check seemed to indicate it should be 'ssh <user>@<ipaddress> port 222' (I've tried the ip address from checkmyip.com and from the whatismyip homebrew app)
This command initially refused the connection and mentioned port 22 not 222 so I found another forum thread on the port 22

and I followed the instructions for changing the config file to port 222 instead - the final cp seemed initially not to work - I think because I was still in the attempted ssh that was refused so I exited that terminal session and started a new one and typed novaterm again to access the pre. i then ran the cp command again which seemed to work. However when I ran the final command to restart ssh the command returned this :-
root@palm-webos-device:/# sudo /opt/etc/init.d/S40sshd restart
/opt/sbin/sshd: no process killed

So i figured ok what the heck and continued anyway and tried to ssh again - this time it came back with
ssh: connect to host <ipaddress> port 22: Connection timed out
I also tried to connect to port 22 rather than 222 since it seemed to have ignored the 222 change in the config file but this had the same timeout.

I noticed the reference to using avahi instead and so looked at installing it but encountered a problem immediately with this command :-
sudo mount -o remount,rw /

It asked for a password - and it isn't the password for the user I just created so now I have 1 failed attempt and I have no idea what password I'm supposed to be using.

So I'm stuck at this point now and have no idea what to do - all help much appreciated (any explanation on the sudo thing would be much appreciated as well as where I've gone wrong with the whole process).