Page 21 of 23 FirstFirst ... 111617181920212223 LastLast
Results 401 to 420 of 451
Like Tree4Likes
  1. #401  
    My theory: dirt is a prime suspect. Every time I've had the dreaded "Stuck in the Headset" issue, cleaning the headset hole has solved the problem. That being said, I suppose it is possible that cleaning the headset hole with rubbing alcohol or WD-40 has somehow removed the electrical charge you referenced above.

  2. gharkay's Avatar
    226 Posts
    Global Posts
    244 Global Posts
    You cannot build up electrical charge in the headset jack or anywhere else in the phone that isn't a battery or capacitor. And even if you could, that wouldn't make your phone think it's in headset mode. What DOES confuse your phone is that the small metal strip that is pushed against the side of the headset jack by an inserted plug gets stuck in that position. When that metal strip touches the metal exterior of the jack, an electrical circuit is completed. The phone senses that and thinks it's in headset mode. Loosening up that metal strip through the method of your choice will clear up your phone's confusion.

    Anything sticky that gets in the hole has the potential to cause the metal strip to get stuck, hence the success with cleaning and lubricating the jack.

    -- Sent from my Palm Pre using Forums Beta
    Palm IIIxe => Handspring Visor Prism => Palm Treo 650 => Palm Treo 755p => Palm Pre Plus => Palm Pre 2 + TouchPad
  3. #403  
    Tried all these, unfortunately still wouldn't fix it, I had to call ATT and get mine replaced. Thankfully, they did it under warranty and replacement is like new.
    I listen to my pre almost every morning while using the elliptical. Love the podcasts and music player!
  4. AMD
    AMD is offline
    AMD's Avatar
    1 Posts
    I had this problem for the first time recently. My Pixi is about a 2 months old. I can insert and remove the headset to duplicate the problem easily. The device info app tests confirm that the phone does not recognize removal of the headset.

    I inserted and removed the headset several times in order to get it back out of headset mode. I was then playing music from the media player out the external speaker and it appeared to skip but the seconds counter was still running. I flipped over to the phone app and quickly dialed voicemail. I was watching the speakerphone icon toggle back and forth between a picture of a headset and a phone handset on its own accompanied by speaker popping noises. Not a good sign.

    After a bit it settled into phone mode and so I decided to shake the phone and see what happened. After vigorous shaking without inserting or removing the headset it started to toggle between headset and speaker mode again on its own.

    Now as I type it is laying on my desk in a fitful slumber. Every 30 seconds or so screen will turn on and the speaker will click as it thinks I just removed/inserted the headset.

    This phone is broken or just a piece of junk or both. My treo 750 was solid, this phone barely lasted a month.

    The phone is unlocked originally from AT&T now on t-mobile. Has anyone tried fixing the jack themselves?
  5. #405  
    I love my Pre don't get me wrong but it is the most flimsy problem-filled phone I have ever owned. I get the headphone/speaker/microphone issue ALOT (if I close the music app with my headphones in before I pause/stop the song) and had to write myself the following step by step guide to remind myself how to fix it, but it works every single time!

    Step 1: Plug in Headphones
    Step 2: Open music app and play a song
    Step 3: While song is playing, remove the headphones and the music app will pause the song.
    Step 4: With the headphones removed, un-pause the song and it should now play through the speakers (and allow you to make calls)

    If the steps do not work first time, restart the phone and try again. This works EVERY time for me and hopefully will for you guys too. I think its just the way the phone is made and a replacement will probably give the same issues eventually.

    P.S. I also had the clicking speaker and phone lighting up with a sqeeze issue and it too seems to relate to the headphone socket - I fixed it by selotaping a wedge of paper inside the back cover near the headphone socket - no more clicking or random lighting up!

    Hope it helps, thanks
  6. #406  
    Today, after getting the headphones/speaker problem while away from
    home, and trying several of the non-invasive voodoo methods, I came
    home and cleaned the jack with rubbing alcohol and a cotton swab
    (removing enough cotton to allow it to fit). This time, this worked
    first time.

    It seems that different remedies worked in my different cases in the
    past. Once I came to suspect it was a software problem. I don't know
    what to think now.

    As before, I noticed that during the problem, the phone got into the
    wrong state: when I plugged the headphone in while playing an MP3, the
    music player went to Stop, and it is supposed to go to Stop when I
    unplug the headphones.

    - John
  7. #407  
    didn't make any difference with me except that im off palm for good
  8. #408  
    Ok so over the last week or so my pre has been acting weird. When the phone is in the closed position the speaker nor the ear speaker work, they either go in and out or do not work at all, also while it is closed you can hear an electrical popping noise coming form the speaker. I also think while i have earphones plugged in it shocked my ear a few times (but that may have been static built up due to the dry air we have been experiencing). Once i slide open the phone all speakers act normally. Has anyone else experienced this? Is there a fix or is my phone just shot? By the way, when my wife's pre was stuck in headset mode the ghastly headset app worked perfectly!!!!!!
  9. #409  
    Thanks Siphon, the first post in this thread worked for me.

    I had the problem of the lost handset speaker when I used a FM transmitter for a long drive over the holidays to listen to audio books.

    It was driving me nuts.
  10. droberts84's Avatar
    2 Posts
    Global Posts
    13 Global Posts
    Has anyone else experienced the problem of the earpiece not working even when it is NOT in headset mode? If so, did you find a fix?

    The problem started with the earpiece audio going in/out mid phone calls. Now it does not work at all. If I play music, it plays out of the speakerphone, indicating the pre knows the headset is unplugged. I also confirmed this using the interactive tests.

    Is there any hope, or should I just get a new phone? (I'm out of warranty I believe.)

    Appreciate the help!
  11. #411  
    Has anyone tried removing the actual headphone jack? I'm considering trying it. My Pre is out of warranty, and I haven't been able to make a call on it for about 3 months. I've tried all the steps here with no success, including inserting and removing the headset (which I have gotten in the habit of doing each time I need to make a call).

    One interesting side effect of the problem for me, which I did not notice: the entire time I have had this problem, inserting or removing the headset/headphones during a call will hang up the phone. It seems to respond to it the same way as pressing the button that is included on the headset. It's pretty frustrating, since it means that I can't stick headphones in when someone calls me; instead I have to use speakerphone or call them back.
  12. #412  
    Before doing anything to the actual hardware, I stumbled upon homebrew software called The Ghastly Headset. It fixed my problem! It's the only thing so far, and now, three months later, I can use my phone like a phone again! Hope this helps somebody out there...
  13. #413  
    was your replacement free or did it cost?
  14. jp22382's Avatar
    355 Posts
    Global Posts
    418 Global Posts
    Dont know if this info has been posted in this thread already, but I can confirm that this hardware issue is the cause of my particular 'stuck in headset mode' problem and the screen turning on randomly.

    I could literally watch the phone mode switch from headset to speaker and back again while in ghastly headset.

    Quote Originally Posted by theXfactor2011 View Post
    I just wanted to post this just because I think it may help some of you. So this looks like a hardware problem. We all know that there are a lot of things on the pre that can be fixed with paper. Well I think i have another for you.

    1. Pop off the battery back aka back cover.
    2. You see the headphone at the top. If you wiggle it the screen with come on
    3. If you stop that wiggle you stop the random screen on and off issue
    4. what Ive read was take a tiny piece of paper and wedge it down there
    (I took a coffee stir and cut it into a half circle and then cut a tiny part of that and wiggled it in.)
    5. It doesnt take much. not a lot of room but just enough to be a pain. by stopping the wiggle I havent had screen issues.

    Sorry for the bad pic but I hope it helps a little bit. Also remember to leave something sticking out so it doesnt fall into the phone and you can remove it.

    I take no responsibility for anyone trying this.


    EDIT: borrowed a picture from ifixit to help illustrate

    Last edited by jp22382; 03/02/2011 at 05:29 PM.
    Sprint Pre- | 2.1.0 | UberKernel
  15. jp22382's Avatar
    355 Posts
    Global Posts
    418 Global Posts
    Been a couple days now and no 'stuck in headset' issues at all! Also haven't had any problems with the screen turning on by itself. So this looks to be a legit (MacGyver) fix for both problems.
    Sprint Pre- | 2.1.0 | UberKernel
  16. #416  
    I don't know if this has been suggested, but I used to have this problem.

    The way I fixed it is by simply blowing into the headset jack.
  17. #417  
    I got my audio jack replaced for free. It didn't work. Still gets stuck in headset mode.
  18. #418  
    Quote Originally Posted by prenode View Post
    I got my audio jack replaced for free. It didn't work. Still gets stuck in headset mode.
    Have you tried using Ghastly Headset? It works but it's not as easy as having the phone work correctly.
  19. #419  
    Quote Originally Posted by Unclevanya View Post
    Have you tried using Ghastly Headset? It works but it's not as easy as having the phone work correctly.
    No I haven't. I simply won't use the headset any more . But thanks.
  20. edhkim's Avatar
    41 Posts
    Global Posts
    42 Global Posts
    In my case, I know the cause was pulling out my headphones while TuneMeIn was playing. Tried inserting/removing headphones, and battery pull. The last two things I tried was running audio tests from Device Info (during which I never heard the sound, only a click), then tried jabou's tip and after that my pre- started working again.

    Which was a relief because it's my fourth. The others had screen/power button problems.

    Oh yes, Ghastly Headset worked just fine, but the setting wouldn't stick (is it supposed to?). After every call I had to use the program again. I hadn't even tested receiving a call by the time I fixed it, so I don't know if it would've required using the program again after receiving a call.
    Last edited by edhkim; 04/21/2011 at 11:29 PM. Reason: Ghastly Headset feedback

Tags for this Thread

Posting Permissions