Page 2 of 3 FirstFirst 123 LastLast
Results 21 to 40 of 59
Like Tree1Likes
  1. brettkola's Avatar
    9 Posts
    Global Posts
    14 Global Posts
    I think the trouble is with how any device can detect if an inactive circuit (silent headphones) is shorted (plugged in) or open (unplugged). I think the change is easier to detect if the headphones are playing something when the headphones are removed, that's how I got mine to work. Of course, if anything liquid or metallic is shorting the circuit, that won't help either. A q-tip with nearly all the cotton pulled off and wetted with rubbing alcohol usually produces good results.
  2. #22  
    Quote Originally Posted by brettkola View Post
    ...I think the change is easier to detect if the headphones are playing something when the headphones are removed, that's how I got mine to work.
    This seems to be the key. It happened once with mine and hasn't happened again. The fix was to plug and unplug headphones while something was playing or while on a call.
  3. #23  
    Quote Originally Posted by eightball0 View Post
    try blowing really hard into your headset jack and see if that fixes it. it worked for me.
    Funny.. The blowing hard thing did the trick.. Wait, did that sound funny?

    But thanks!!
  4. brettkola's Avatar
    9 Posts
    Global Posts
    14 Global Posts
    You know what, I take it back. The problem when its stuck in headphone mode is a shorted out headphone jack. Headphone detect circuits operate continuously, consuming a miniscule amount of power. The less power the circuit uses the less of a drain on the battery life it is, but the easier it is to get fooled by a relatively high resistance short circuit (on the order of k-ohms). This can be caused by many things, but I'm guessing in a lot of cases its metal dust and shavings from the contacts scraping on the headphones as they are inserted. Oftentimes inserting the headphone can clear out the dust its made, but sometimes it will require some cleaning. Q-tips and rubbing alcohol work well, and in some cases so can blowing on the headjack. Think NES cartridges: you can blow and reinsert all day or save time and just do a real cleaning now and then.
  5. #25  
    Quote Originally Posted by TheCIArr View Post
    I already posted this in a different thread but:
    - open the music player
    - plug in headphones [EDIT: 5 times]
    - close music player
    - unplug headphones

    I hope this works for everyone.
    You may have to plug in and remove the plug 5 times or so.

    - Craig
  6. #26  
    Just wanted to add to this, that i had a launch phone and just yesterday I started to experience this issue, that my phone was stuck in HeadPhones mode. I seriously didn't want to take it back, because this phone happens to be the lucky ones that had a quality build.

    Anyhow... what I did to get mine to work was to put music on and put the head phones into the jack. The funny thing was that the music would pause and skip to a new track...very odd. I fooled around with it a few more minutes and found the point where the headphones were detected, so I didn't have to put the headphones in all the way. Once I found that sensor contact, I continuously fluttered the port (pretty much doing the nasty on the head phone port) until I re-fooled the pre. It takes a few tries in order for it to get back to how it was.

    I was reading the other posts, and it's possible that there were metal shavings on it, enough to fool the sensor, and perhaps doing the nasty to the jack cleaned off sensor so to speak.

    Hope this helps people. So the jist is, to keep trying, one try will not fix it. I always made sure the music was playing when I inserted the headphones partially enough to make contact to the sensor. Once I made contact, I pulled out, played music again, rinse and repeat.
  7. brettkola's Avatar
    9 Posts
    Global Posts
    14 Global Posts
    Yeah, just treat it like an NES cartridge. Blow/Reinsert if that's all you have, if that doesn't work use a Q-tip and rubbing alcohol or contact cleaner. It doesn't matter if anythings playing or not, it just makes it easier to tell if you've got it or not. Had it get stuck for hours at least twice, but the Q-tip worked every time.
  8. #28  
    I tried every trick suggested here with no success. Finally, I opened pandora, began playing (silence) put in the headphones, and pulled them out. Pandora PAUSED! It had detected the remove. Hit play, beautiful music from internal speaker. Problem SOLVED! Calls worked fine after this.

    I can reliably duplicate this result. Any time pandora crashes out or exits with the headphones in, the PRE stays stuck in headphone mode until I start pandora again and do the in and out.

    I submitted the bug at pandora. Everyone who can duplicate this result should do the same.

    Hope this helps some.
  9. #29  
    That sounds right to me. The only time mine ever got stuck was right after the only time I used Pandora.
  10. #30  
    Thanks to Brettkola on precentral forum. This was almost the final nail in the Pre coffin for me. I'm sure the other things work sometimes, but this was direct and quick:

    "The Pre sometimes has trouble detecting headphone removal if the headphones aren't playing anything. Try playing something and then removing, if that doesn't work clean with rubbing alcohol and a q-tip with almost all the lint removed. "
  11. #31  
    I was totally frustrated and what worked for me was plugging in the headphones opening up pandora then pulling it out while pandora was palying then closing pandora before trying to make a call....this actually is a serious problem I hope its a fix that can be remedied through updates and not having to return the pre!!!!
  12. #32  
    happened to me also... exchanged my phone for another at sprint..
  13. #33  
    Quote Originally Posted by dpc View Post
    happened to me on my treo 680. The solution for me was to run a paper clip or bobby pin along the inside of the jack until the sound worked again.
    thank you.
  14. #34  
    The Old Nintendo cartridge trick worked for me
  15. #35  
    thanks dog44, phone been annoying headset mode, try your suggestion and working now
  16. #36  
    Mine must have been really dirty, because I had to use the q-tip method. It must be the metal shavings theory, I tried all the software tricks to no avail. I'm thinking that all of the attempts to fool the pre are working by coincidence; by inserting and removing the plug, they were brushing away the offending particles. The q-ti took 30 seconds and worked immediatly afterwards.
  17. #37  
    This happen to me also. I bought an aftermarket headset and it happened within a day or so of me using it. I had to take my phone to the sprint store and they gave me a new Pre. I assume the headset jack was the issue. Kinda sucks. I was looking for a headset which produced louder output than the stock headset. Especially when I listen to MSNBC on SprintTV...that channel is so low.
  18. #38  
    My first day release Pre, which has been flawless, just started this problem. Sprint repair has ordered another (May or May not be New) replacement phone due next Monday. I took a can of compressed air, held the phone upside down while letting it play music and shooting air in the jack; well low and behold the speaker came back. Now I'm going to try the developer mode and play with that until the replacement phone arrives; should be fun.
  19. dd7293's Avatar
    12 Posts
    Global Posts
    14 Global Posts
    For what it's worth.... I've had the same problem for quite some time now too. The thing that has always worked for me, up until today anyway, has been to run the interactive audio tests for the phone & speakerphone. Run the test & afterward everything worked fine.

    Then today... Running the interactive test stopped working as far as fixing the problem anyway... but after reading the posts in this thread, I used the q-tip w/ alcohol to clean out the head phone jack & everything was back to normal. Go figure!
  20. punzada's Avatar
    137 Posts
    Global Posts
    161 Global Posts
    Just wanted to contribute that I just experienced this problem as well and thought for a second "oh no, I guess this will be my first take back" - the blow trick helped for the meantime but I'm going to do a q-tip & alcohol solution soon. I use external speakers often with my pre so I'm willing to be those are the culprit (yesterday in particular was a long-term usage day due to football). Thanks for the heads up and suggestions fellas saved me from going into a panic (figures it started happening literally 2 minutes after I ordered my 2600 battery as well)
Page 2 of 3 FirstFirst 123 LastLast

Posting Permissions