View Poll Results: Is your push email working correctly using Gmail on Wifi?

124. You may not vote on this poll
  • No problems here! I get emails quickly on both Wifi and EDVO

    46 37.10%
  • Push email works on EVDO 3g (Instant), but not Wifi (Manually updating is all that works).

    10 8.06%
  • Works on EVDO (Delayed 5-10 min) and not at all on Wifi (Manually updating is all that works).

    28 22.58%
  • Push email does not work on either EDVO nor WIFI!

    40 32.26%
Page 3 of 4 FirstFirst 1234 LastLast
Results 41 to 60 of 68
  1. devonair's Avatar
    61 Posts
    Global Posts
    171 Global Posts
    Now my problem gets stranger: it appears to be working again over wifi, but not at all (wifi or evdo) when I'm charging on the Touchstone. I haven't yet found out if this is a problem with charging in general (i.e. if the problem also happens when charging via USB cable), or if it's just Touchstone related.
  2. devonair's Avatar
    61 Posts
    Global Posts
    171 Global Posts
    Okay, so I haven't tested this for very long -- certainly not long enough to consider this solution confirmed -- but I might have fixed my problem.

    As stated before, wifi stopped being a problem, but touchstone charging suddenly was. I.e., emails were not cycling in while my phone was on the touchstone.

    I had installed the patch to keep the Pre from making the charging alert sound, though. I removed it, rebooted, and now emails are cycling in over push. Go figure. I can live with the alert sound if it means my notifications are working correctly.
  3.    #43  
    Yea I gave up on Palm calling me back and doctored my phone. All is well with push email! This is def. A bug tho that needs to be addressed.
  4. delao13's Avatar
    313 Posts
    Global Posts
    341 Global Posts
    I'm having similar problem. My email (plain Gmail) pushes and notifies over WiFi/EVDO, but only if I run the mail program after a restart. Until I run mail for the first time, no new email, no notifications.
  5.    #45  
    We have hit the front page! So far looks like a decent amount of people are having issues. I gave up on Palm calling me back and tried doctoring my phone. It worked! Now ik this is not the optimal fix...but it worked. Fortunately for me my phone was a refurbishment phone that I had only had a couple days anyways. Heres hoping that palm can fix the issue in the next update.

  6. #46  
    Me and my wife both have Pre's. My Gmail and Yahoo accounts work fine on 3G (never used wifi), but my sbcglobal email does not work. Her Gmail account works but her Yahoo does not. It's very annoying because her Yahoo and my sbcglobal were our primary email addresses, so we had to start up new ones that would work with the phone. Nobody could tell us why some work and some dont....
  7. vreihen's Avatar
    495 Posts
    Global Posts
    506 Global Posts
    Quote Originally Posted by devonair View Post
    I am having problems similar to most of the posters here: when connected over WIFI, IMAP Idle does not automatically push my email (I have to manually refresh my inbox to see new messages). But it is working fine over EVDO.
    Several WebOS updates ago, I noticed that my Pre refused to route IMAP traffic over an OpenVPN link that I had set up in the phone. It insisted on sending IMAP over the cell radio interface, and even statically-coding a route through the VPN interface wouldn't make the traffic go through the tunnel. There was a thread on here at the time, if someone wants to go digging in the search feature.

    What I suspect was happening is that the Java-half of the Pre's mail package has some sort of built-in code to cope with IMAP IDLE over the cellular link, because the cellular link can shut down and/or change IP addresses at any time. My guess is that they are routing all IMAP traffic to some intermediate server on Sprint or Palm's network, which is keeping the IDLE link to the IMAP server up even when the phone's radio is disconnected. Because of this, IMAP apparently doesn't go out over any interface (wifi or VPN) but the cellular one that I can tell.

    I don't know if they have addressed this problem in a recent update, but some people here reporting that they have success after setting their phone to poll IMAP every X minutes instead of using the "as messages arrive" (IMAP IDLE) option seems to point the finger at IDLE as being the cause. For those that don't see a difference, try rebooting your phone after changing the setting, to restart the Java part of the mail service. (With the older WebOS version that I was using at the time, the Java service didn't seem to pick up this setting change right away.)

    This was really driving me crazy, since I work in an underground bunker that doesn't get a good enough Sprint signal to hold a reliable data connection, and the phone refused to use a solid wifi signal to get my e-mail.....
  8. #48  
    Quote Originally Posted by JFGABEL View Post
    I had this issue last week. I deleted and then readded the gmail account. After that I've had no problems.
    I'm going to try this. I've tried a few things even going as far as doctoring it.

    I'm having issue with a Google Apps e-mail account.
    Palm M100 => Treo 755P => Treo 800w => Treo 755p => Palm Pre => No more Palm/HP products
  9. cl191's Avatar
    112 Posts
    Global Posts
    148 Global Posts
    I've deleted and re-added the accounts, everything worked fine for a day or two and now it's back to not getting email again...
  10. #50  
    Quote Originally Posted by cl191 View Post
    I've deleted and re-added the accounts, everything worked fine for a day or two and now it's back to not getting email again...
    Same here... deleting and readding worked fine for a little while but eventually just reverted back to not pushing at all... help us with this one Palm! I'm glad to see (through the issue making the front page) that the problem isn't isolated to a select few but this is clearly an issue that we're having problems with! OTA mini-update fix in the works?
  11. #51  
    I was at a local chick-fil-a today and I was on their wifi and I got a ssl error on both of my exchange accounts. I'm guessing this isn't the same issue because I'm pretty sure they limit traffic that goes over https. Weird though. It was just the first time I saw the yellow triangle while trying to sync my email.
  12. #52  
    I've been having the same problem. For a while, i could push the refresh button, the program would poll the email accounts, new mail would be downloaded and then the yellow triangle would disappear. Now, not even that is working.

    For me, the problem account is the Yahoo acount that won't push.

    I've also noticed that some of my other apps that rely on autoupdating information (e.g. FlightView and Pack 'n' Track) are also stuttering while on Wi-Fi.

    Is this a WebOS software conflict with certain programs?
    Is this a Yahoo problem (Remember, Palm recently updated their mail to work with Yahoo more efficiently 2-3 months ago)?
    Is there a conflict with Homebrew stuff (I have Preware and some patches installed).

    This is really frustrating...
  13. #53  
    I had problems with my gmail account over EVDO but it worked fine over wifi. I contacted palm support and after 2 minutes of general ideas he asked me to sign into my gmail via the web browser, which didn't make any sense to me, BUT I did it, and now my gmail works over both EVDO and Wifi with no problems. It might work for you guys if not give palm support a try they were able to fix my email problem in minutes.

  14. #54  
    I had the same problem. I doctored my phone and started adding things one at a time and checking my phone to see if the problem would come back. I found that when I added the web browser ad-blocker (2nd thing I added) in the webOS quick install, tweaks, and did a luna restart I had That obnoxious triangle again when I set my email to get mail as it arrives on wifi. I went back into qi and unchecked the ad-blocker and did a luna my phone gets the email as items arrive with no delay on wifi or EVDO. Worked for me, maybe it can work for you.

    Good luck!!!!!
  15. mauro1's Avatar
    205 Posts
    Global Posts
    213 Global Posts
    Quote Originally Posted by drchiromike View Post
    I went back into qi and unchecked the ad-blocker and did a luna my phone gets the email as items arrive with no delay on wifi or EVDO. Worked for me, maybe it can work for you.

    Good luck!!!!!
    Me too. Did exactly that. Fired up WebOS Quick Install, unchecked the ad block tweak and from the WOSQI Linux Commandline interface I typed "stop LunaSysMgr" followed by "start LunaSysMgr". After restart I changed my GMail account from 'every 5 minutes to 'as they arrive'; sent myself some mail and within 30 secs my LED was blinking... all over WiFi. Haven't tried EVDO yet. Wanted to post my experience ASAP.
  16. #56  
    I'm cautiously optimistic, it seems like removing the browser ad blocker fixed it for me, too. Time will tell for sure, but so far it's working!

  17. #57  
    The ad-blocker is just a modified hosts file that block access to a blacklist of webservers.

    The only was the ad-blocker would be the cause, would be if a mail server were listed in it.

    I've attached the modified hosts file. Tell me if ya see anything that shouldn't be blacklisted.

    EDIT: I did notice one thing. line 2 says:
    Code: castle
    whereas on current devices it should be:
    Code: palm-webos-device
    I'm uncertain if that's the cause, but I'll have that updated in wosqi 3.0.
    Attached Files Attached Files
    Last edited by Jason Robitaille; 01/31/2010 at 11:45 AM.
    If you've liked my software, please consider to towards future development.

    Developer of many apps such as: WebOS Quick Install, WebOS Theme Builder, Ipk Packager, Unified Diff Creator, Internalz Pro, ComicShelf HD, LED Torch, over 70 patches and more.

    @JayCanuck @CanuckCoding Facebook
  18. imex99's Avatar
    634 Posts
    Global Posts
    953 Global Posts
    add another poll option.... i have trouble sending email period with my launch PRE with any email account(hotmail,gmail,roadrunner) while using WIFI.

    Digg my story help raise $$$ & awareness for webOS, Palm Pre, HP.

    #WebOS Internals "Telethon"#Palm Pre
  19. #59  
    I just switched from gmail/imap to exchange and problem is gone for me...this does appear to be isolated to gmail or imap with push turned on.
  20. #60  
    Anybody able to see if the ad-block patch in Quick Install 3.0 fixes this?
    "'Form follows function' that has been misunderstood. Form and function should be one, joined in a spiritual union."
    Frank Lloyd Wright
Page 3 of 4 FirstFirst 1234 LastLast

Tags for this Thread

Posting Permissions