Results 1 to 7 of 7
Like Tree4Likes
  • 1 Post By Nafetz
  • 1 Post By bbito
  • 2 Post By Grabber5.0
  1.    #1  

    I would have liked to patch Sport Total that is still running on my Veer with a modified version. But I noticed that this is not possible - at least for me. For testing reasons I only changed one single line of the app so the patch (created with Unified Diff Creator) looks like this:

    --- .orig/media/cryptofs/apps/usr/palm/applications/de.muetzner.stfree/app/assistants/data/muetzner.jsjsjs
    +++ /$media$/$cryptofs$/$apps$/$usr$/$palm$/$applications$/$de$.$muetzner$.$stfree$/$app$/$assistants$/$data$/$muetzner$.$js$
    @@ -$4$,$7$ +$4$,$7$ @@
       $Mojo$.$Log$.$info$(&$quot$;$Download$ $Infos$ $von$ $muetzner$.$de$...&$quot$;);
       $Globals$.$muetzner$.$callbackInfos$ = $Callback$;
    -  $var$ $link$ = &$quot$;$http$://$www$.$muetzner$.$de$/$download$/$sporttotal$/$infos2011$.$xml$&$quot$;;
    +  $var$ $link$ = &$quot$;$http$://$www$.$muetzner$.$de$/$download$/$sporttotal$/$infos$.$xml$&$quot$;;
       // $Inhalt$ $downloaden$
    When I try to install it I get (first line translated from german to english):

    ERROR: There was an error when trying toinstall test.patch
    1 out of 1 hunk FAILED -- saving rejects to file /media/cryptofs/apps/usr/palm/applications/de.muetzner.stfree/app/assistants/data/muetzner.jsjsjs.$rej$
    *** $FAILED$ ***
    The path where the file is stored seems to be correct. I used terminal of webOSQuickInstall to navigate to the file and copied the path and filename and pasted it into the field of the Unified Diff Creator.

    Does anybody know the reason why this is not possible? I used a device with developer mode activated.
    Rnp likes this.
  2. #2  
    Its been a while since I made a patch, but the 1st 2 lines look fishy to me:
    Quote Originally Posted by Nafetz View Post
    --- .orig/media/cryptofs/apps/usr/palm/applications/de.muetzner.stfree/app/assistants/data/muetzner.jsjsjs
    +++ /$media$/$cryptofs$/$apps$/$usr$/$palm$/$applications$/$de$.$muetzner$.$stfree$/$app$/$assistants$/$data$/$muetzner$. = $Callback$;
    I'd expect that to look like this:
    --- orig/media/cryptofs/apps/usr/palm/applications/de.muetzner.stfree/app/assistants/data/muetzner.jsjsjs
    +++ $patched$/$media$/$cryptofs$/$apps$/$usr$/$palm$/$applications$/$de$.$muetzner$.$stfree$/$app$/$assistants$/$data$/$muetzner$.$js$
    Rnp likes this.
  3. #3  
    My above guess may have been a worthless stab in the dark, but I did remember something else which may be useful. Make sure you have AUSMT Scripts installed from preware. I have run into patch installation issues after doctoring and forgetting to reinstall that.
  4. #4  
    When I patch apps, I always make an copy of the un-modified app and run the diff tool against that to generate the patch. I wrote a script to do it, because I can never remember the correct options to generate a usable patch file. I can post that here if I can find it.
    poehoes and vgg like this.
  5.    #5  
    Thank you very much for helping. Unfortunately there is no progress so far. This is what I tried today:

    • Testing the suggestion of bbito - no success
    • Testing on different devices. Even a unused one. AUSMT is installed. Always the same error
    • Downloaded the muetzner.jsjsjs $file$ $after$ $a$ $fresh$ $installation$ $with$ $WebOSQuickInstall$ -&$gt$; $Tools$ -&$gt$; $Get$ $file$. $Then$ $used$ $WinMerge$ $to$ $compare$ $the$ $downloaded$ $file$ $with$ $the$ $file$ $that$ $I$ $used$ $to$ $create$ $the$ $patch$. $No$ $difference$ $found$

    I have no idea what's the problem when trying to patch this file ...
  6. #6  
    may I offer a suggestion ?

    use internals pro to navigate to the file, then edit it and save it.
    I'm curious if it allows to be saved or not ... maybe is in read only.. if so check the permissions and change them from internals (or command line)
  7.    #7  
    Maybe I'm a little complicated. Just wanted to keep my promise. Euro2016 is starting in a few days, so I thought this would be a good moment.
    I had contact with Robert last year and he agreed that it would be best that I would help offering a patch. The patch (where six files are modified) is ready a long time. But it isn't possible to install the patch.
    So I tried to contact Robert again explained the problems and sent a possible new app-version - but since then I didn't get any response any more.

    To shorten things: I would feel a little uncomfortable to release an app, which is not mine. On the other hand I don't even know if there is anybody left interested in SportTotal. On my device runs a new version of the app so I don't need a patch.
    If nobody else needs SportTotal, then there is no problem - (sometimes things are easy)

Similar Threads

  1. Replies: 2
    Last Post: 09/05/2012, 01:57 PM
  2. Replies: 3
    Last Post: 05/03/2011, 02:53 PM
  3. Replies: 15
    Last Post: 09/01/2010, 03:01 PM
  4. New user asking: What are "the" apps to get?
    By mnorris12706 in forum webOS Apps & Games
    Replies: 23
    Last Post: 05/26/2010, 11:00 AM
  5. Replies: 2
    Last Post: 03/19/2010, 10:02 AM

Posting Permissions