Page 26 of 26 FirstFirst ... 16212223242526
Results 501 to 507 of 507
Like Tree59Likes
  1. #501  
    Oh boy... That's gonna be quite difficult for me to do lol. There's no easier way to get even just Gmail working?
  2. #502  
    Quote Originally Posted by nickmiller71 View Post
    Oh boy... That's gonna be quite difficult for me to do lol. There's no easier way to get even just Gmail working?
    I know it sounds like a lot, but really there isn't much required for Gmail and Google sync on a fresh device with 2.2.4 (phone) or 3.0.5 (tablet). Unless I'm forgetting something, it's just openssl updater, frantid's cert root cert update package (perhaps not mandatory for Gmail yet, but may be eventually), and the Google sync behaviors and ubercalendar patches. You may be able to set Gmail up as a generic imap account without Google sync/ubercalendar - it's been a while since I did any of this, so I can't promise it hasn't changed or stopped working. Hang in there, and don't be afraid to ask for help.
  3. #503  
    Quote Originally Posted by nickmiller71 View Post
    Oh boy... That's gonna be quite difficult for me to do lol. There's no easier way to get even just Gmail working?
    Just to note: You wrote that the Pre3 is on 2.2.4. Well, that's as far as you will get, so leave it as is as far as the OS is concerned. The Pre2 will be OK on 2.1, but you may as well get that to 2.2.4 also.

    Remember these phones are old now. Any new fixes are usually aimed at Pre2, Pre3 and Veer running 2.2.4 and the TouchPad running 3.0.5. At minimum, a Pre+ that was never officially upgraded to 2.2.4 (but can be) should be OK. With any earlier models or OS versions there will be limitations on how many updates can be used.

    That these things are even still usable is pretty good. Hardware development halted in 2011, partially open-sourced and effectively abandoned in 2012, servers closed in 2015. Four years later, we're still here (just!).
  4. #504  
    The OpenSSL update pretty much completely breaks SSL on 2.1. It's not even close to okay.
    Preemptive likes this.
  5.    #505  

    Google has announced that it will be terminating the form of Oauth2 that is used in this patch on Oct. 3, 2022. I am sorry, but I do not know of a workaround since the browser in webOS will not meet the new requirements. Calendar and contact sync will stop working on Oct 3, 2022


    Last edited by frantid; 05/06/2022 at 12:21 PM.
    French Pre3, UK Pre2, US Veer, German gsm Pre, 680, garmin ique 3600 & still have my working palm pilot 1000 with the 1 Mb adapter

    Please remove UberCalendar and google sync behavior patches prior to system updates.
    patch Google calendar sync behavior for 2.x.x and TouchPad (Oauth2 and advanced sync requirements enabled)
    Preference guide for MetaView's UberCalendar patch
  6. #506  
    Quote Originally Posted by frantid View Post

    Google has announced that it will be terminating the form of Oauth2 that is used in this patch on Oct. 3, 2022. I am sorry, but I do not know of a workaround since the browser in webOS will not meet the new requirements. Calendar and contact sync will stop working on Oct 3, 2022


    Do you know if the same would apply to the C+DAV connector that's available?

    Sent from my Titan pocket using Tapatalk
    HP Veer (daily driver), HP Pre 3, HP Touchpad Proper 4G/LTE (Sierra MC7710), HP Touchpad 32GB WiFi, Palm Pre 2
  7.    #507  
    Quote Originally Posted by Herrie View Post
    Do you know if the same would apply to the C+DAV connector that's available?

    Sent from my Titan pocket using Tapatalk
    Hi Herrie,

    Sorry didn't see this post earlier, I don't think subscriptions are working on the forum for me.

    I am not sure about C+DAV. Google is terminating the "OAuth out-of-band (OOB) flow". My code is using the WebView to login and approve access, but has to use OOB because the WebView is not the "application" that accesses the data, the native calendar and contact sync services are doing that. The WebView is sort of the man in the middle, and they say this OOB flow is susceptible to man-in-the-middle attacks.

    I think C+Dav has it's own service, so it might be ok, if the same service gets the authorization and the data. Depends on how it's written.
    Last edited by frantid; 05/22/2022 at 11:47 AM.
    French Pre3, UK Pre2, US Veer, German gsm Pre, 680, garmin ique 3600 & still have my working palm pilot 1000 with the 1 Mb adapter

    Please remove UberCalendar and google sync behavior patches prior to system updates.
    patch Google calendar sync behavior for 2.x.x and TouchPad (Oauth2 and advanced sync requirements enabled)
    Preference guide for MetaView's UberCalendar patch
Page 26 of 26 FirstFirst ... 16212223242526

Posting Permissions