Page 1 of 2 12 LastLast
Results 1 to 20 of 28
  1.    #1  
    On a Pre 2 / webOS 2.0.1 , bookmarks under preferences are sometimes not displayed and deletion and reordering is not possible. This patch fixes that.

    Since I do not completely understand what's happening in the original webOS 2.0.1 code, 'I'd appreciate a few beta testers'. I do understand the code I have added though.

    [..deleted the code part..]

    ===== edit
    webOS 2.2.4 version included 99 bookmarks patch.
    Last edited by Dick99999; 12/27/2011 at 09:21 AM. Reason: Pre 2 added to designate webOS version. deleted code part
  2. #2  
    Such a patch was already posted HERE by ashirg.
  3.    #3  
    Quote Originally Posted by yitz0550 View Post
    Such a patch was already posted HERE by ashirg.
    That addresses another problem for another webOS version. The patch of this thread addresses an intermittent problem on the Pre 2. This patch is about the preference screen that is used for rearranging and deleting bookmarks using the bookmarks list screen, not the tiles screen.
    Last edited by Dick99999; 02/17/2011 at 11:22 AM.
  4. #4  
    Nice. I've run into this problem twice (had to clear all bookmarks each time to fix), so I'll give it a go if it happens yet again.
  5. #5  
    Yes! This worked beautifully for my Verizon Pre Plus meta-doctored to 2.1.0.
  6.    #6  
    Glad it worked. I'll post a technical question I have about this patch on this forum too. Anybody?
    After a while my Pre 2 displays a blank bookmarks list under browser preferences. That inhibits sorting and deleting bookmarks.
    Clearing all bookmarks fixes the behavior, but after a while the bug reappears. In my case after a restore.

    I looked at the code and don't completely understand it. The bug must be related to the code below, since a patch I made in there, fixes the bug on my Pre 2.

    The part I do not understand is the following:
    Question: Since there is not data model specified, how does the controller know which datamodel to use? (It's not the widget within a list widget case). Further down the app is using a variable this.bookmarksModel to populate the datamodel with bookmarkrs info
    Then it finishes by just updating the length info of the list widget.
    Since the code obviously works mosttimes, how is the datamodel passed on?

    I know that for widgets within widgets, the embedded widget uses the model of the top widget. But that seems not the case here. And perhaps if population of the data is done by callback one should/could? not specify a datamodel? The code above does not use the controller's callback to populate the datamodel.
  7. #7  
    WOW! Thank you! Thank you! Thank you! I have a Pre 2 on VZW. This was happening on 2.0.1 But I thought it would be corrected in 2.1 but, unfortunately, it did not. Your patch works beautifully, though.
  8. workerb's Avatar
    37 Posts
    Global Posts
    79 Global Posts
    Thank you so much for this patch! I migrated to a Pre2 last weekend and this issue started happening. I tried to clear the cookies, cache, history, and all the bookmarks. I then added them back in one and a time and verified that the bookmark list was still there. I finished re-adding all bookmarks and the list page was working fine - until I closed the browser. Then I was back to square one. Until I found your patch. It worked like a charm - saving me and my sanity.
  9.    #9  
    Glad it works well for you as it does for me. It's likely one of the few patches of which the designer does not know why the patch works and the original code does not ......
  10. Gwidion's Avatar
    215 Posts
    Global Posts
    216 Global Posts
    Does it function with Pre3?
  11.    #11  
    May be the PRe 3 does not have this issue? Have not tried it yet.
  12. Gwidion's Avatar
    215 Posts
    Global Posts
    216 Global Posts
    It function And yes, the Pre3 has this problem! ;(
  13. #13  
    Would it be possible to get the patch to work under
    WebOS 2.2.4 ?
    My Pre 2 has the bookmarks problem (again) after upgrading to this version.
    Last edited by lulilola; 12/26/2011 at 02:50 PM.
  14.    #14  
    The current version works for 2.2.4 too. I'll submit it. If you know how, you can install the current version.
    onto 2.2.4
  15. jaltman's Avatar
    285 Posts
    Global Posts
    740 Global Posts
    I tried to tell that to someone in another thread and linked him back to here, but he didn't understand or figure it out. It works fine in 2.2.4. Until submited use webosqi to install.

    Thanks for this patch, I appreciate it.
    Jim Altman
    Palm III ->Treos 600->650->750->Pro->Pre Plus->Pre 2->Pre3+TouchPad
  16. eny2002's Avatar
    66 Posts
    Global Posts
    68 Global Posts
    Quote Originally Posted by lulilola View Post
    Would it be possible to get the patch to work under
    WebOS 2.2.4 ?
    My Pre 2 has the bookmarks problem (again) after upgrading to this version.
    Until the submit is complete you can also just send the file in this thread to your email. And download the attachment from your phone. And Internalz will install it for you
  17.    #17  
    The 2.1 version installed OK on 2.2.4 but was not exactly right in referencing the code lines to be modified. The 2.2.4 version has been corrected and now also includes the 99 bookmarks patch done by Pastorrich1 with credits.
    Without that increase the fix bug patch does not make sense. Side effect: the original 99 lines patch has to be removed before installing the 2.2.4 version of this patch patch.
  18. #18  
    Installation via email attachment worked smoothly
    on GSM Pre 2 Webos 2.2.4

    The patch is really useful. Thanks!
  19. #19  
    Thanks for the patch's new version for webOS 2.2.4!!! \m/ It really works!!!
    El Sendero del Samurai: Lealtad, Paz Interna, Paciencia y Meditar a los pies de Buda

    Samsung Galaxy S4 + Root / HP TouchPad 4G + CM10 / iPod Touch 5 + Jailbreak 6.1.3
  20. #20  
    Are you guys able to install this patch through Internalz? I'm not, it says "only garbage was found in the patch input"!
    Was sucked into Palm when I bought the glorious Treo650, somehow subsequent phones didn't live up to expectations.
Page 1 of 2 12 LastLast

Posting Permissions