View Poll Results: Did you successfully update all of your patches after OTA to 1.4

500. You may not vote on this poll
  • Yes

    215 43.00%
  • No

    285 57.00%
Page 6 of 11 FirstFirst 1234567891011 LastLast
Results 101 to 120 of 201
  1. #101  
    I guess AUPT didn't kick in the first time I updated (using Preware): none of my patches updated. Doing it again now, 30min later, I have 34 updates [Patches only] available... weird! --- Sorry for voting 'NO' in the Poll... can you move my vote over to 'YES', or simply let us do the poll all over? I'm sure that many folks, including me, jumped to [negative] conclusions too quickly. Would hate not giving the AUPT folks the credit they deserve...
  2. #102  
    Wait a sec... what do I have to do before installing update? I thought I just left all my patches as is and then I update them afterwords?
  3. #103  
    Update of previous post: Yes, Preware shows all my patches to have updates available. But, wasn't the idea they all update automatically?? No such thing here. Looks like I will have to go through them/update them one by one (??) At least, I know which ones I had installed, so no guessing this time around...
    In the process of updating the "Package Manager", which I hope will resolve some of my update issues... we'll see.
  4. #104  
    I only used two patches before the 1.4 update - 4x4-icons-v3 and top-bar-ringer-switch-icon. 4x4-icons-v3 upgraded fine, but top-bar-ringer-switch-icon didn't function properly any more (leaves a permanent blank space in the top bar), though there were no reported errors when upgrading. Removal of that patch went cleanly.
  5. #105  
    Quote Originally Posted by arminusa View Post
    Update of previous post: Yes, Preware shows all my patches to have updates available. But, wasn't the idea they all update automatically?? No such thing here. I guess you missed the first post in this thread.

    NOTE: Once you have AUPT patches installed, you will no longer need to remove all patches prior to an OTA WebOS update. You will no longer be required to run EPR before or after an OTA WebOs update. Simply update your patches that require updating via Preware after an OTA WebOS update.
  6. #106  
    Oh well... Thanks for the update
  7. #107  
    HOWEVER... It takes forever to have Preware install my patches again. FOREVER! -- Looks like I'd be better off just installing the from scratch again. Sorry, but it does not seem to work well for me. Good thing, Palm Updates don't happen every week..
  8. #108  
    Quote Originally Posted by arminusa View Post
    HOWEVER... It takes forever to have Preware install my patches again. FOREVER!
    Well, think about it for a minute....there was just a WebOS update, thousands of people are updating now and once they get the 1.4.0 update, they check their patches via Preware, so I can guarantee you that the Preware servers are getting POUNDED about now.

    I'm sure things will be back to normal in a few days.
  9. #109  
    Quote Originally Posted by egaudet View Post

    Patches no longer needed for 1.4.0:
    • misc-no-network-time-zone-error
    • phone-call-duration-in-call-log
    • phone-enable-gps-dial-action-on-gsm

    and LED notifications. Thats not needed anymore either.
  10. #110  
    SAME HERE....... groundhog day again with the PRE.... same ole story
  11. #111  
    Hide music player app patch is now updated and working! Yeah WebOS Internals dBsooner, and noir. Hopefully the Hide NASCAR app patch will follow soon. I really miss e-mail in landscape mode. I can't figure out why Palm did not include this feature in the upgrade since is has been there since WebOS 1.0. Keep 'em coming guys!
  12. #112  
    Update went smooth - no real problems. Patches updated also, although most of mine are not available for 1.4 yet. The ones that are seem to be working OK. Thanks for the hard work and help this morning on irc.
  13. #113  
    Quote Originally Posted by pyrognome View Post
    and LED notifications. Thats not needed anymore either.
    Still a bug for missed calls (with no voicemail.) If you have simple PIN lock set up, LED doesn't blink until you wake up the screen which defeats the purpose of having an LED notification.

    If someone leaves a voicemail, it does work correctly.
  14. #114  
    Everything went great except .pdf redux. Removed the extract pdf app in hopes that reinstalling would fix the issue, but it's not showing up in preware now. I take it that it is not on the 1.4.0 feeds. Has the pdf viewer changed in the update?

    If you have a similar problem, and have the extract pdf app installed, DO NOT REMOVE IT!!! I believe that this may cause a problem.
    Last edited by amateurhack; 02/27/2010 at 06:33 PM. Reason: added warning
  15. #115  
    how am i suppose to know what patch really work with 1.4? i tried installing some patches ready for 1.4 but give me error !!! :/
  16. #116  
    Quote Originally Posted by cobra977 View Post
    Well... I voted yes, but it wasn't quite as smooth as advertised. I have 58 patches that were all confirmed AUPT-3 prior to the 1.4 update. When I hit 'Update All', I started getting IPKG errors almost immediately, which would not allow the update process to continue. This happened 4-5 times total, and I think at least a couple of the patches that caused the errors have now been mentioned in this thread, but not all of them. And certainly they are not all listed in the first post of this thread. It would be nice if there was a complete authoritative list somewhere of patches that people need to remove prior to hitting 'Update All.' It would be even nicer if the AUPT process just removed them automatically if their functionality was included in the update. In any case, closing and restarting Preware always seemed to remove the offending patch and allow the 'Update All' process to continue. All in all, much smoother process than EPR and reinstalling 58 patches, but it still needs some work.
    Post the error codes from the report. I was getting 404's earlier, but they went away when I retried.
  17. jdale's Avatar
    554 Posts
    Global Posts
    564 Global Posts
    Definitely an improvement with AUPT, but still some issues with it. I had a lot of failures, and each time it canceled the rest of the updates rather than at least doing everything it could. Each time I had to go in, read the IPKG log to figure out which patch failed, and then manually update that patch. If I tried Update All, it would fail on the same one. Manually updating would usually work after a try or two. Then I could Update All and get through at least a few more of them.

    Some of the failures indicated timeout errors, but all of them were for patches where there is no 1.4 version, so I don't know what the real issue was. I suppose it could be a timeout because everyone is hitting the feed all at once.
  18. #118  
    This is taking so long, and I'm getting so many IPKG errors, that I think it would have been quicker and easier to EPR before the update and re-add them all afterwards. Annoying.
  19. #119  
    I guess the trick really is to keep trying and give it some time... despite the IPKG errors in between. I finally got all my patches back (re-installed through PreWare), but it took a lot longer than simply installing them all manually. Then again, I now only have 30+ left, as I forced myself not to go crazy on the patches and kept it to a 'bare minimum'. I still believe one/some of the patches have been responsible for crashing WebOS on my Sprint Pre way too often before I uninstalled most of them - and now it's all fine again. No more unexpected screen-freezes or crashes. -- To sum it up: AUPT is a great idea, but still not working as well -for me- as simply using EPR and then installing manually. Kudos to the AUPT folks for coming up with a solution for letting the rest of us deal with Palm Updates more easily (as far as the patches are concerned). -- THANKS!
  20.    #120  
    Quote Originally Posted by dsevil View Post
    Didn't work the first time.
    - Was running Package Manager Service 0.9.36. (this tweet led me to believe this version was okay for AUPT update-all after webOS update.)
    - First package updated was Package Manager Service to 0.9.37. Appeared to not take complete effect yet, because...
    - Then it attempted to update the patches. IPKG errors were, to paraphrase, "couldn't unpatch, most likely due to OTA update".
    - Removing patches that failed to update *did* work, however.

    Stopped Preware; restarted Java (for good measure); started Preware again.
    - Update All is now working so far, albeit slowly.

    Bottom line, I guess.
    - Update Package Manager Service to 0.9.37; make sure Java is restarted; *then* update your patches.
    The message "most likely due to OTA update" is AUPT detecting a file has been updated by OTA during removal. When the install fails the package still shows as installed when it's not until feeds are updated or you manually tap remove on that package. Known preware issue explained in first post.

    Quote Originally Posted by dsevil View Post
    Also, I cannot install the USCL Memos Patch placeholder.
    Nothing appears in webos-patches.log for this so I had to type this on my own:

    An error ocurred, return value: 1.
    ERROR: cannot satisfy the following dependencies for org.webosinternals.patches.universal-search-uscl-memos-patch:
    Collected errors:
    Known dependency issue in Preware explained in first post.

    -Eric G

    WebOS Internals Developer.
    Follow me on Twitter for updates to my projects: | Virtual Keyboard | wIRC | SuperTux | AUPT | KeyBoss | freeTether |


Tags for this Thread

Posting Permissions