Results 1 to 20 of 20
  1. Jmark61's Avatar
    96 Posts
    Global Posts
    101 Global Posts
    I need help removing three patches so I can start anew. I removed all patches with EPR prior to installing 1.3.5.

    I have three patches “installed” on my Pre running 1.3.5: Character Counter 1.3.5-1, Enable LED Notifications 1.3.5-1, and SMS Tone Per Contact. After installing 1.3.5 the other night I installed each of these three. However, there was a problem with the SMS TPC patch as, I guess, it was not updated until this morning(?).

    I think the problem was that somehow I got SMSTPC on my Pre after installing 1.3.5 and it was not ready to be installed.

    It will not let me update the SMSTPC patch until I’ve removed the previous patch. When I try to do that I get an ipkg error and it won’t continue. Something about a unreversed patch detected and that makes it quit.

    I’ve tried to do as I did in preparation for 1.3.5 and run Emergency Patch Removal and remove all of them and then start from scratch and I get the following message:

    ERROR: An error occurred while attempting to run /tmp/

    NOTE: No patches found?
    Removing package org.webosinternals.emergency-patch-recovery from root…

    When I open Preware it shows all three of those patches are installed even though webosquickinstall says there are not patches.

    Furthermore, the character counter has quit working as though it has been partially removed. The LED notification patch is still working.

    Any help that people can provide would be much appreciated.
    Last edited by Jmark61; 12/31/2009 at 10:45 AM.
  2. #2  
    have yo tried using WOSQI to remove the patches? goto tools>tweakes>and push the EPR button. WOSQI often works beeter than the Preware patch removal.
  3. Jmark61's Avatar
    96 Posts
    Global Posts
    101 Global Posts
    I don't see the EPR button in the window/box that opens with tweaks? Am I missing a step or not understanding what you're instructing me to do?

    Thanks for your help....
  4. Jmark61's Avatar
    96 Posts
    Global Posts
    101 Global Posts
    I've also gone to WEOSQI/Tools/Device Management and pulled down to Patches and nothing shows up in that window.

    Does that mean WEBOSQI is not recognizing the patches that Preware insists are there?

    Ideas anyone? I know there is nothing people would rather do than this on New Year's Eve
  5. #5  
    Have you updated Preware and Package Manager Service since you did the 1.3.5 update?
    Treo 300 > Hitachi G1000 > PPC-6700 > PPC-6800 (Mogul) > PPC-6850 (Touch Pro) > Palm Pre & HTC EVO Optimus V
  6. #6  
    this is how i fixed my situation i installed the patch via webos quickinstall and then i restarted luna and then i removed it thru quickinstall hope it works
  7. Jmark61's Avatar
    96 Posts
    Global Posts
    101 Global Posts

    Yes. I have an updated Preware and I noticed, that when I went to webos quick install/device manager I have three versions of Package Manager Service on my Pre: .9.25, .9.24, .9.24.3. Should I have only .9.25?? Delete the other 2?

    Flush2810, I'm about to try your suggestion. Thanks.
  8. #8  
    let me know how it works for you
  9. Jmark61's Avatar
    96 Posts
    Global Posts
    101 Global Posts
    Flush2810 & anyone else with expertise....

    I did as suggested and used webosQI to install the patches and then immediately delete them. Before I deleted them I went to device manager to confirm that LED & Character counter were there...they were. I deleted them, restarted, opened Preware and all three patches still appear as being installed.

    I repeated the steps of installing LED and CC, then I installed/used Emergency Patch Removal and this time (see above) it was allowed to install and "work."

    I ejected the Pre, restarted, opened Preware, and the 3 patches are supposedly still there...according to Preware.

    Now, for my idea. As stated in an earlier post I have three versions of Package Manager Service on my Pre: .9.25, .9.24, .9.24.3. Should I have only .9.25?? Delete the other 2? Is this the problem?

  10. #10  
    I'm having same problem as you... only I have about 15 running invisible patches. They do NOT show up in Preware, nor in WOSQI. None of these mentioned fixes do any good.

    I have even done a partial erase (actually I wonder if that was the problem...) and no good.

    I've decided to wait until the WebOS Repair Utility is out for 1.3.5; shouldn't be too long. It will override and correct these files... till then it's really not anything that is hampering the device. As an instant alternative, you could run the 1.3.5 Doctor and just start over... but that's a lot of annoyance for a problem this small.
  11. Jmark61's Avatar
    96 Posts
    Global Posts
    101 Global Posts

    You are correct in implying it could be worse. The Pre is functioning fine with the exception of the patch issue. I have thought several times over the last couple of days that at least it's working properly.

    Where will I be able to find WebOS Repair Utility when it comes out?????

    Maybe somebody will have a solution to both our problems prior to that...I'm the impatient sort

    Thanks. Happy New Year.
  12. #12

    Hasn't been updated yet for 1.3.5

    Btw; are you able to install/show/remove all NEW patches? (ones you haven't installed previously) This is my experience; so I must believe that Preware is working fine and that somehow the erase is what caused this.
  13. Jmark61's Avatar
    96 Posts
    Global Posts
    101 Global Posts
    Thanks for the link to the repair utility. I've not attempted to install any patches that I didn't have on my Pre with 1.3.1 -- just the three I've mentioned.

    Any thoughts on having three versions of Package Manager Service showing up on the device manager in webosQI? I'm tempted to delete the two earlier versions....
  14. #14  
    im having the same issue. also i cannot update the EPR. ive tried everything to update the EPR in hopes that i may be able to resolve the patches issue but to no success.
    i guess i too will wait for the webos repair utility update
  15. Jmark61's Avatar
    96 Posts
    Global Posts
    101 Global Posts
    I have part of the problem solved. I was using an older version of WebOS Quick Install and 2.96 allows me to do much more. I was able to properly install all of the patches I want and have them function as they should.

    Whether I can uninstall the patches, I am not sure. Right now they are working and I am going to rest. Hopefully there is some time prior to the next OS update . I'll wait for the WebOS Utilities update for 1.3.5 to come out and then deal with it then.

    Now it's time to donate to canucksoftware and a few of my favorite patch makers. Without the homebrews and patches the Pre would be nowhere near what it is. Now if somebody would come up with a great to do app such as To Do Plus.

    Thanks to all for the suggestions and help.
  16. #16  
    When I saw that there's an update I decided to give in and doctor my phone. So, backed up USB items, ran EPR... and took her to the Doctor. Then did update. Then re-installed newest package manager and Preware... and it works fine. No more invisible patches, and I quickly set it back up the way I wanted. Took little more than an hour, but no real trouble.
  17. Jmark61's Avatar
    96 Posts
    Global Posts
    101 Global Posts
    I got through it well also. But I didn't go to the extent you did. I opened webosQI 2.96, installed EPR to delete the patches, uninstalled Preware and Packaging manager, installed the update, and then reinstalled the patches, Preware, and Packaging Manager. I was good to go.

    What I found odd was that in SMS tone per contact, once I reinstalled that particular patch, the individually assigned tones were in place. That doesn't make sense. It somewhat suggests that the patch was never completely deleted.

    But, everything is working fine.
  18. tuckprodigy's Avatar
    1 Posts
    Global Posts
    4 Global Posts
    I ran into the same problem and ultimately had to see the doctor. I think what caused it was issues with the patches still being on the phone when running the 1.3.5 update. I am new to using patches and did not properly uninstall them all before the update. I think that once that migration portion of the 1.3.5 update ran, i had patches that were not properly removed and got stuck in a place where neither webOSQI nor preware could remove them. That is just a guess though because, like i said, i'm very new to this.

    I tried to use the migration tool then re-run EPR and delete from both webOSQI and preware. Neither worked for me but that might be worth trying before doing any kind of erase.

    I also tried re-installing the patches, then running the steps above.

    Ultimately, i ended up using webOS Doctor with success. This solved the problem with the half uninstalled patches, computer connection issues, and all other issues re-installing apps. However i did lose all data (backed it up) - photos, music, videos ect. One thing i did not expect though was to lose all my homebrew apps. They were apparently not backed up in my palm profile. I can say though that my contacts, calendar and other synched info came back fine. I was VERY nervous about trying this because of all the warnings and horror stories, but if all else fails, this was completely successful for my problem and my phone is now running like new.
  19. #19  
    I am having this same problem with 11 patches that I cannot uninstall or update. I am also having the same error messages. Has anyone come up with a solution besides visiting the Doctor?
  20. wizll's Avatar
    9 Posts
    Global Posts
    66 Global Posts
    i'm having issues trying to remove or reinstall the SMS Tones per Contact patch. I keep getting the error that the OP already mentioned in this thread, but there does not seem to be a solution here. I've been using WOSQI 3.02

    anyone have any idea how to fix that? basically the result of it is that every contact now has an error that says it can't read a template that is a file that is no longer present.

    I've also tried WebOS Repair Utility. it did not detect anything out of the ordinary.

Posting Permissions