Results 1 to 9 of 9
  1.    #1  
    So I've created a patch for adding some more alarm reminder options to the calendar. Easy enough, but now I'm trying to create and share the patch and this is where I'm getting into uncharted territory.

    I followed the notes I found at the end of this link: Applying Patches - WebOS Internals I'm running into trouble with the "git commit" command.

    When I issue "git commit", it launches vi and I see this:
    # Please enter the commit message for your changes. Lines starting
    # with '#' will be ignored, and an empty message aborts the commit.
    # Committer: wtgreen <root@castle.(none)>
    # On branch master
    # Changes to be committed:
    #   (use "git reset HEAD <file>..." to unstage)
    #       new file:   calendar/more_calendar_alarm_choices.patch
    I haven't a clue what I should enter here. Should this be a patch description? I added a header file describing it as instructed previously in the guide. Should I be adding the comments here too, or does this need something else?

    Anyone have a link to more information that might explain some of what these steps are instructing me to do? Thanks.
  2. #2  
    It's just a comment that appears in your git repository as a label for the set of changes you're making. It's not terribly important. You can just say something like, 'initial commit of patch'.
  3.    #3  
    Thanks for the clarification. Now I've run into another problem - perhaps you can help with it.

    When I run git push origin master it fails. Below is the complete output
    The authenticity of host ' (' can't be established.
    RSA key fingerprint is 7e:af:8d:ec:f0:39:5e:ba:52:16:ce:19:fa:d4:b8:7d.
    Are you sure you want to continue connecting (yes/no)? yes
    Warning: Permanently added ',' (RSA) to the list of known hosts.
    Enter passphrase for key '/home/root/.ssh/id_rsa':
     ! [rejected]        master -> master (non-fast forward)
    error: failed to push some refs to ''To prevent you from losing history, non-fast-forward updates were rejected.
    Merge the remote changes before pushing again.
    See 'non-fast forward' section of 'git push --help' for details.
    And then of course when I run git push --help I get an error since man isn't installed:
    warning: failed to exec 'man': No such file or directory
    fatal: no man viewer handled the request
    Can anyone offer any help here? Thanks!
  4. #4  
    Here's what I did: I created a clone of the git modifications repo in my gitorious account, and then I was able to push my commit into my own repo, using the clone's 'push url' instead of the main url they give in the instructions. The theory was that I would then push my changes from my clone to the main repo. But then they had me just point them to the uploaded patch file, which, IMO, made using git kinda pointless for me, at least for now. :P

    Anyways, I suggest contacting dBsooner directly about it. You can PM him here or at gitorious. Or go to the IRC channel for webos-internals. Maybe you could avoid the hassle until/unless it really makes sense.
  5.    #5  
    Thanks samkin. I finally figured out what my problem was... I had cloned my patch copies sometime ago but forgot or overlooked the step to update it. After doing the update I could see how things had been reorganized since my copy. I've since almost been able to post my patch. Now it seems I don't have permission to update things.

    Enter passphrase for key '/home/root/.ssh/id_rsa':
    Counting objects: 14, done.
    Compressing objects: 100% (10/10), done.
    Writing objects: 100% (10/10), 1.70 KiB, done.
    Total 10 (delta 6), reused 0 (delta 0)
    == Gitorious: ===========================================================
    You do not have write access to this repository
    error: hooks/pre-receive exited with error code 1
     ! [remote rejected] master -> master (pre-receive hook declined)
    error: failed to push some refs to 'git@:webos-internals/modifications.git'
    I'll direct further questions to dBsooner as you suggest. Don't know who that is or where you got the name from, but you obviously know more than I do.

    Thanks again for the help so far!
  6. #6  
    No problem. I went through the exact same problems, plus a few more, a couple days ago. I got a lot of help on the IRC channel.

    dBsooner is now in charge of the patch feed at webos-internals, and is also a moderator in this webOS Patches forum. You want to ultimately get your patch into his hands.
  7. #7  
    What is your progress on this one?

    I am anxious to see what options you are adding!

    - Craig
  8.    #8  
    Quote Originally Posted by Milominderbinder View Post
    What is your progress on this one?

    I am anxious to see what options you are adding!

    - Craig
    The patch is done, but unfortunately I can't update the gitorious repository as I don't have permission. I PM'd and emailed dBsooner a few days ago but haven't gotten a response.

    I'll attach the patch here though if you'd like to try it out. I simply adds 45 minutes, 90 minutes and 2 hours to the alarm reminder options.

    You probably know this but if anyone else is interested, I've seen mentioned in other threads you can simply drag and drop the unzipped .patch file on WebOS Quick Install to get it installed. I've not tried it myself yet.

    I'll create a dedicated thread for this patch, but here it is.
    Attached Files Attached Files
  9. #9  
    cool, more time options would be helpful, like the old way

Posting Permissions