Results 1 to 3 of 3
  1.    #1  
    I'm having some issues getting the patches to work. I just tried to add the More Icons & the On-Screen Keyboard patches but neither would apply. I was following the Applying Patches Tutorial word-for-word but no luck. I was trying to remove them all with "quilt pop -a" but there was no change. Then (i'm sorry, i forgot exactly what i did) but i was able to get the Battery Percentage Patch to remove... however now i cannot apply it again.

    This is what shows up:
    root@castle:/# quilt import /opt/src/modifications/luna/show-actual-battery-perc
    Patch /opt/src/patches/show-actual-battery-percent.patch exists. Replace with -f.
    root@castle:/# quilt import -f /opt/src/modifications/luna/show-actual-battery-p
    Replacing patch /opt/src/patches/show-actual-battery-percent.patch with new version
    root@castle:/# quilt series
    root@castle:/# quilt push
    Applying patch /opt/src/patches/show-actual-battery-percent.patch
    patching file usr/lib/luna/system/luna-systemui/app/controllers/bar-assistant.jsjsjs

    Now at patch /opt/src/patches/show-actual-battery-percent.patch
    root@castle:/# reboot
    After the reboot i still don't have my battery percentage. I remember having similar issues when i first started patching & haven't touched it since because of those issues. Am i doing something wrong?

    ~thanks in advance.

    I tried nesl's post on getting the battery percentage back, when i was trying to install it, it said that a patch may have already been applied, & then failed.

    root@castle:/tmp# patch -p0 -i pre_battery_meter-3.diff
    patching file /usr/lib/luna/system/luna-systemui/app/controllers/bar-assistant.jsjsjs
    Hunk #1 succeeded at 1375 with fuzz 1.
    Hunk #2 succeeded at 1434 with fuzz 1.
    Hunk #3 FAILED at 1473.
    1 out of 5 hunks FAILED -- saving rejects to file /usr/lib/luna/system/luna-systemui/app/controllers/bar-assistant.jsjsjs.$rej$
    patching file /usr/lib/luna/system/luna-systemui/stylesheets/systemui.css
    Reversed (or previously applied) patch detected! Assume -R? [n] y
    root@castle:/tmp# /sbin/initctl stop LunaSysMgr && /sbin/initctl start LunaSysMg
    I'm sorry to make a post on this. Just starting to get really discouraged.
    Last edited by Veritas06; 08/13/2009 at 01:32 AM.
  2. #2  
    no response? did you ever figure it out?
  3.    #3  
    I think ended up using the Doctor when a new update came out, & now I use Preware for all my patches. No issues since I started with it.

Posting Permissions