Page 2 of 3 FirstFirst 123 LastLast
Results 21 to 40 of 45
Like Tree6Likes
  1. #21  
    These instructions are kosher, however there should be a step 4.5:
    4.5. Type:
    cd /media/internal

    It should also be noted that the VKB replaces the wave launcher, there's no way around this but it works well enough.
    webOS Ports' UI Architect & luna-sysmgr guru.
  2.    #22  
    Thank you for writing that up. However, googling "luna.conf patch" only keeps coming up with that 23-page thread, but damned if I can see where in that thread the luna.conf patch is.

    Lots of talk about it, just no sign of it..... which is precisely my angst with this forum. How hard can it be to put a sticky with the relevant file in, instead of a 23-page dialog?

    (Of note, somewhere I came across a post stating "the luna.conf.patch for webOS 2.x from Arthur Thornton is no longer available"). I take it that is the one and the same?

    But on the whole, this entire process is not something I want to get involved in. If it was a simple matter such as install this program and there's your keyboard, then fine. But this messing around with scripts isn't my bag.
    This really should have been in the pre as standard. That's why I've gone back to using my lovely LG GD900 with its massively useable (and standard) touchscreen keyboard.

    It's a shame. The Pre had the potential to be an extremely nice phone, instead it's useless for anything that a keypad is needed for.

    Thank you all, anyway.
    Last edited by NickM99; 08/05/2012 at 01:33 PM.
  3. #23  
    If we put a 'sticky' up for every patch and mod, all this forum would be only a list of stickies. Sometimes you have to do a little looking and research to get what you need. Homebrew items like patches are awesome resources, but if you think everything should be perfect and easy, no OS will give you that. You seem to get a bit negative when people are trying to assist. If you wanted the patch itself, simply ask for someone to post a link to it.

    I Googled "webos luna.config patch" and Arthur Thornton's patch was the 3rd link down in the results.
    Here you go:
    .... but it still isn't 'plug-n-play' and requires some tweaking by the end-user.

    I don't understand why should this "have been in the Pre as standard"? The whole concept of the Pre was to use a hardware keyboard and not a VK like others. VK's came to the Pre through the Homebrew community still have some bugs being worked through.

    If you are truly wanting help to get this running on your device the members are giving you step by step instructions. But realize that this option isn't simple 'plug-n-play' at the moment. It sounds like this isn't what you want.... so, good luck
    Last edited by HelloNNNewman; 08/05/2012 at 07:37 PM.
    bevcraw likes this.
  4.    #24  
    Thank you for those words. I guess I'm just disappointed it's such an ordeal to get the vkb when most phones come with it as standard. I know HP figured the physical keyboard would do, but come on, surely even the most daft of testers would have said "hey guys, the keys are too small, and they don't always work, we need a backup"?? Like I said, I have small slender fingers, but even I'm finding the keys way too small and they need a good hard press to get them to work. And even then that produces 2 or 3 more letters than intended. As said, the keyboard is a disaster, hence why the vkb should've been on the pre as standard, as a backup.

    Thanks for the luna patch, obviously googling webos luna patch made the difference. If I get the urge, I'll try to go through the steps kindly supplied earlier and see if I can get any results. Hey, what's the worst that can happen....
  5. #25  
    Nick I'm sorry the Pre2 doesn't seem to be the phone for you. You do sound frustrated. I would not suggest making modifications (I mean like rooting, or homebrew, or doctoring...any of those major modifications) to any phone for someone who isn't willing to take a little risk at being frustrated and having to start back at square 1(doctoring) if they mess things up. That is the nature of pushing an OS farther out there than it has been before. The very existence of so many patches and extensions and homebrew apps shows that webOS has great potential to be stretched (in my layman's view at least).

    So, 'stuff' is gonna happen when you try to modify the stock OS. Sometimes good, sometimes bad...sometimes weird. Since the VKB wasn't fully developed and not a part of the original OS, the modifications necessary to 'flesh it out' into use by jokers like me can be a little squirrelly.

    I tried it on my Pre+, but it never was of that much use for me. And that is with the early generation Verizon Pre+ keyboard...notoriously bad. The Pre2 keyboard is a good bit better. I've noticed that when I press those tiny keys, that even though I am pressing 2 or 3 keys at once, the Pre2 detects which one I meant to press (obviously the one that reached full depression first) and it ignores the press of the adjacent keys. I have a much better time typing on my Pre2 than on my Pre+. The Pre+ did get better after a software update that reduced the double entries and such, but as it grew older, it began to have more trouble.

    This forum is one of the most helpful I have seen. The people here are very knowledgable and they will help a seeker who is willing to listen and heed their advice. If doing that isn't your cup of tea, then I would say you should pick a phone that has little need to be modified (like an iPhone). There are a lot of people on this forum, however, that want to improve the functionality of their phones beyond the stock phone, and with the help of the talent on this forum, they are doing just that.

    Some folks like to mess with their phones, some just want it to work out of the box, and some are in between. Whatever floats your boat! But keep a paddle handy anyway.
    Sent from my slowly diminishing intellect

    I'm just a soul who's intentions are good...oh Lord, please don't let me be misunderstood!

  6.    #26  
    Well, I tried. I got the file loaded onto the phone using a usb cable. Tried loading the luna patch via webosqi but it just hung. So not sure what else to try.

    Sorry, for me to spend 99c for homebrew means a $30 minimum prepay credit card load, so not an option right now. That's the way it is when one is living on benefits.
  7.    #27  
    Guys, I have finally got success. I finally have the vkb up and running. However, I am not sure if the patch worked, as the first time I tried to use it, the entire phone froze, necessitating a removal of the battery in order to do a restart. The second time I tried to use it, the phone self-rebooted.

    Thanks for all your help. Back to the drawing board.
  8. #28  
    Great. Make sure you have done all steps in Part II of my post as the keyboard is apparently unstable unless you run that script.
  9.    #29  
    Yes I ran all of the steps. It hangs if you type more than three letters. On the fourth it hangs. It's doing it every time. The vkb is unuseable.
  10.    #30  
    I mean, I put the into the phone via usb, then installed the luna patch via webosqi, and then went into Linux Commandline and type in everything you posted. For some reason though I don't think the patch has worked, as it is still very unstable.
  11.    #31  
    I have just re-input the Linux commandline stuff exactly as typed (including the space after cd but before /media/internal.

    It made no difference, it still keeps hanging after about 5 seconds of use. Any ideas anyone?
  12. #32  
    What output do you get after running ./ From the sound of things it didn't apply correctly.
    webOS Ports' UI Architect & luna-sysmgr guru.
  13.    #33  
    Sorry, don't understand what you mean.
  14.    #34  
    Never mind. Finally, I think I have no choice but to quit.

    When I realise the vkb was unuseable I removed the file from the phone, and deleted the luna.config patch. Now webosqi won't let me install the luna config patch again.

    That's it. Finished. Thank you all. We tried.
  15. #35  
    Unless you uninstalled the luna.conf patch from Preware it'll still be installed on the phone- removing the file won't effect that, which is why it's giving you errors when you try to reinstall.

    And by output, I mean text appearing in the console (where you typed the commands, cd /media/internal, ./, etc.) an example would be 'no such file or directory' if you typed ./ in a directory where it didn't exist (cd stands for 'change directory').
    webOS Ports' UI Architect & luna-sysmgr guru.
  16.    #36  
    I don't understand this phone. One minute you try something and it hangs, the next you try it and it works. I'm just reinstalling the vkb stuff and i'll try again. I'll also take a screenshot of what it shows when I go into Linux Commandline.
  17.    #37  
    Attached Images Attached Images
  18.    #38  
    I've posted a screenshot in the post above, but it needs mod approval.

    Interestingly, all is fine until I unplug the phone from the pc, then I get a line of text that says this:

    novacomd socket was closed prematurely
    novacom: unexpected EOF from server

    And yes, using the vkb causes the phone to reboot unexpectedly.
  19. #39  
    I got to say Nick, you are working hard on this. I know it isn't what you wanted or expected, and it is not normal to have this kind of trouble installing the VKB. I'm sorry and don't know why. But I'm impressed that you have been trying to work the problem. If you are successful, perhaps you can get to the 'good' experience of using webOS...and you may have helped to write another chapter in troubleshooting!
    Sent from my slowly diminishing intellect

    I'm just a soul who's intentions are good...oh Lord, please don't let me be misunderstood!

  20. #40  

    It looks the script did not install because the phone would not let it write to the hard drive. This is actually a good protection normally because you would not want to alter those important files. But wait until someone else confirms what I think (and gives you instructions to let you write to the hard drive).
    All this shows what an unusual operation this is, although doable with the good help of the devs.
Page 2 of 3 FirstFirst 123 LastLast

Posting Permissions