I took the com board from a Verizon Pre Plus and put it into an unlocked GSM Pre 2.

I then installed webOS 2.1.0 using the meta-doctor script, while in linux.

The phone was working great until a couple of days ago, it started running extremely slow, then locked up, and restarted. It was not actually booting though, it just shows the webOS internals penguin for about 30 seconds or so, then restarts.

If I take the battery out for around 10 minutes, it will fully boot, and run for about 10 minutes or so.

I've tried all of the following:
1. Re-installed GSM com board, and doctored with the official 2.1.0 doctor.
2. Tried doctoring with previous versions for unlocked GSM.
3. re-compiled, and re-doctored using the frankenpre2-version-2.1.0 meta-doctor script, all from linux
4. tried membooting into the pre (works as much as the regular boot does)
5. tried formatting the USB drive from memboot (Steps Used Quoted Below)
6. Tried all of the above steps using 3 different palm USB cords, 1 non palm USB cord, several different computers, USB ports, and operating systems, all resulting in the same effect

All of those steps have been performed multiple times, and not in the same order, however the result is always the same (except the looping boot logo is from whatever doctor was used last)

It seems like the only thing left is to conclude that the problem is hardware failure, is there a log file somewhere that I can use to confirm that?

Anyone have any other ideas?

Thanks for any help

First put the device into recovery mode, then memboot the device using the installer uImage (extracted from your webOS Doctor jar and copied into the SDK bin folder):

cd C:\Program Files (x86)\Palm\SDK\bin
novacom boot mem:// < nova-installer-image-castle.uImage

After it boots, run novaterm:


Once connected to the device, type:

lvm.static vgscan --ignorelockingfailure
lvm.static vgchange -ay --ignorelockingfailure

then type:

mkdosfs -f 1 -s 64 /dev/store/media

Once that completes, put the device back into recovery mode and run the webOS Doctor.

-- Rod