Page 15 of 16 FirstFirst ... 510111213141516 LastLast
Results 281 to 300 of 303
Like Tree14Likes
  1. #281  
    Quote Originally Posted by geekpeter View Post
    ive had the same issue countless times and have cone to a potential theory..

    every time mine goes mental and luna restarts the device ive noticed over time that the active jail for tweaks which is typically noticable when using Tailor, is not there anymore, can you maybe run Tailor, get the message about "danger will robinson thar be jails active" etc and scroll far bottom, you should have your media/internal possibly /media/ext3fs if u made an ubuntu partition etc, possibly /opt and im guessing your entry for tweaks will be missing?

    i'm purely guessing as mines always gone when tweaks starts doing reboots every launch, and removing then installing doesnt get the jail entry back.

    normally there should be a line in tailor that reads

    USB (Media) /var/palm/jail/org.webosinternals.tweaks.prefs/media/internal
    pictture/attachment enclosed of a "normal" condition.

    if you could check and see if you also have the same issue then maybe that can help solve it, if you dont then it at least eliminates my longshot theory (which doesnt help me the next time i get the problem again).
    Well, mine is always mounted when launching Tweaks. Looks like the plot thickens...
  2. #282  
    1 theory eliminated, im stumped, my logs have never showed anything, doesnt look like theres time to get anything in the log, its literaly a case of launch tweaks, *BAM* Instant Reset.
    Touchpad Keyboard Themes - >> Click Me <<
  3. #283  
    Quote Originally Posted by geekpeter View Post
    1 theory eliminated, im stumped, my logs have never showed anything, doesnt look like theres time to get anything in the log, its literaly a case of launch tweaks, *BAM* Instant Reset.
    And that's what I see in Lumberjack too. Launch and then WebKit crash. Nothing in-between to show what causes it outside of launching. Hopefully there's a fix soon. I really would like to play with the new Luna settings in LunaCE.
  4. #284  
    have you tried removing all patches and deleting tweaks and reboot. Then reinstall tweaks and see if it works just installing the advanced patches? Maybe its something in there ?
    ĦṔ-Ḷṫ-Ŧḯη
    Here is a direct link to webOS Doc for all carriers
    http://www.webos-internals.org/wiki/...octor_Versions
    P.S. if i have helped you and you are thankful please hit the thanks button to the right---->
  5. #285  
    Quote Originally Posted by Shadavis08 View Post
    have you tried removing all patches and deleting tweaks and reboot. Then reinstall tweaks and see if it works just installing the advanced patches? Maybe its something in there ?
    I'll give that a try. If I remember correctly, the only patches I had installed were the no auto reload browser, enable private browsing, and maybe 1 or 2 others (all which didn't rely on Tweaks, except LunaCE).
  6. #286  
    Quote Originally Posted by Shadavis08 View Post
    have you tried removing all patches and deleting tweaks and reboot. Then reinstall tweaks and see if it works just installing the advanced patches? Maybe its something in there ?
    never worked for me yet, the only thign that cured it was an eventual doctor, and i never did that just to get tweaks working, thats too drastic, id just wait until an instance where i had no choice but to doctor.
    Touchpad Keyboard Themes - >> Click Me <<
  7. #287  
    I still have this crash when opening Tweaks, it's been going on for months now and even a doctor didn't help. I only have a few patched installed and LunaCE. I've already asked on IRC multiples times and did some debugging but noone could get something from the debugging.

    Noone came around a solution in the meantime? Because luna-send is not always that handy to use.
  8. #288  
    I had the same problem it was driving me crazy.

    Was a jailer problem.

    The solution simple just run a pdk app. And then run tweaks all good now.

    Pdk app robotek hd
  9. #289  
    not to beat a dead horse (read thread) but does tweaks work with apps or only patches? Ive included the appid.json file but tweaks doesnt find it. (note appid here is just a stand in for the actual id) Im sure the json file is accurate but just to test i simply copied the one from the wiki and still no joy.
  10. #290  
    Any app can use Tweaks, but I'm pretty sure the json file has to be put in the location Tweaks loads them from. I can't see much advantage other than not writing your own settings scene.
  11. #291  
    Quote Originally Posted by Grabber5.0 View Post
    Any app can use Tweaks, but I'm pretty sure the json file has to be put in the location Tweaks loads them from. I can't see much advantage other than not writing your own settings scene.
    just a learning exercise in interapp communication. Plus I also have a few patches and plan on doing more that need settings.

    From what ive seen in the wiki theonly requirements is thejson has to have the same name as the appid and reside within the apps folder however its still not working. ill look at it some more later when i get home
  12. #292  
    not exactly. I think the json needs to be put here

    /media/cryptofs/apps/usr/palm/services/org.webosinternals.tweaks.prefs/preferences
    ami mizuno likes this.
  13. #293  
    Quote Originally Posted by mazzinia View Post
    not exactly. I think the json needs to be put here

    /media/cryptofs/apps/usr/palm/services/org.webosinternals.tweaks.prefs/preferences
    indeed that worked. my next question is how do you get the file there? ive included it in my project so once its built into an ipkg when the app is installed it places the file in the root of the app directory. I noticed that the others also have the json in their root dir as well as the above dir you mention. is there a property to set when building the ipkg?
  14. #294  
    Quote Originally Posted by ami mizuno View Post
    indeed that worked. my next question is how do you get the file there? ive included it in my project so once its built into an ipkg when the app is installed it places the file in the root of the app directory. I noticed that the others also have the json in their root dir as well as the above dir you mention. is there a property to set when building the ipkg?
    At this point, you have to put it there manually. There is no "ready" mechanism to put it there during package install. When Tweaks was developed, it was for patches, which were packaged a special script to copy the json files there. WAIT! As I have started typing out this reply, I remembered something.. for advanced app packages that include a service, there is a way to package in a post-install script that will run after the app install, which can copy the file to that directory if it exists (meaning Tweaks is installed). I use that for my Cert Grabber app to copy the required custom service files needed for advanced services (with root permissions). Let me track that info down and post a link. It took me a long time to figure it out, as all of the guides were outdated or hard to follow, until I finally found one that had enough info for me to get it working. I only ever got the this to work on Linux.. the utilities on Windows that can modify IPK files would not work for me.
  15. #295  
    I think it's sort of all here (how to package and have scripts for after installation and before removal)

    http://forums.webosnation.com/webos-...k-s-webos.html
    Last edited by mazzinia; 10/03/2017 at 09:49 PM.
  16. #296  
  17. #297  
    Quote Originally Posted by mazzinia View Post
    I had already gotten the ipkg packager jar a while back and just forgot i had it. i was about to attempt writing a script to test it (once i figure that out) when i checked for replies lol
  18. #298  
    Quote Originally Posted by ami mizuno View Post
    I had already gotten the ipkg packager jar a while back and just forgot i had it. i was about to attempt writing a script to test it (once i figure that out) when i checked for replies lol
    Oh right.. I forgot the reason I could not use the IPK packager.. I do remember using it to package something, I think maybe even with a postinstall script, so now I'm left scratching my head.. I know it would not work for my cert grabber app.. I think it didn't support bundling a service with the app. Regardless, I never liked using IPK packager, because it does not remember your last directory, even when you leave it up and package the same app twice. (I always meant to post in Jason's thread or tweet him to see if he could change that..) If you'd prefer to use a script, this one works really well and is easy to use if you prefer the command line. I guess I should qualify that.. this is in my mast dev folder, but I did the development on my old laptop in a dual boot Ubuntu installation, but I'm pretty certain this is current. Even if the app source isn't the package script did not. I included the postinst and prerem scripts from my app just because they have the right names, not because I thought you needed an example.
    Attached Files Attached Files
    baldric and ami mizuno like this.
  19. #299  
    Quote Originally Posted by Grabber5.0 View Post
    Oh right.. I forgot the reason I could not use the IPK packager.. I do remember using it to package something, I think maybe even with a postinstall script, so now I'm left scratching my head.. I know it would not work for my cert grabber app.. I think it didn't support bundling a service with the app. Regardless, I never liked using IPK packager, because it does not remember your last directory, even when you leave it up and package the same app twice. (I always meant to post in Jason's thread or tweet him to see if he could change that..) If you'd prefer to use a script, this one works really well and is easy to use if you prefer the command line. I guess I should qualify that.. this is in my mast dev folder, but I did the development on my old laptop in a dual boot Ubuntu installation, but I'm pretty certain this is current. Even if the app source isn't the package script did not. I included the postinst and prerem scripts from my app just because they have the right names, not because I thought you needed an example.
    sweet. ya examples always help i wish i could play with it a bit more but i have to make some runs. lol but thanks for the example it looks like it will be a simple /bin/cp to copy the json to the right dir.
    Curently ive just used palm-package run as a custom external tool in eclipse (so i can use variables for the project dir etc..) like i do with xfer to emu/device
    Grabber5.0 likes this.
  20. #300  
    Ive run into another snag. when building the package it doesnt seem to include the tweaks json file. i get an error cp cannot stat file or similar. when i check the file size its smaller. if i add a package dependancy with the json it includes it but fails the install saying dependancies were not met.

    EDIT: Fixed it. looks like the path must be fully qualified. I assumed it was relative to the app install dir I was using

    ID=org.genscripts.app.junkapp

    then

    /bin/cp -f ${ID}.json <tweaks dir>

    apparently it doesnt like relative paths. when i changed it to the full /media/cryptofs/... path it worked.

    EDIT2: How does one add the strikeout to the text in a post?

    EDIT3: Now includes strike through. Fancy!
    Last edited by ami mizuno; 10/04/2017 at 12:29 PM.
    Grabber5.0 likes this.

Posting Permissions