Results 1 to 3 of 3
  1.    #1  
    When I execute "make stage" in the WIDK, it fails with the following error while compiling fuse:
    if /bin/sh ../libtool --tag=CC --mode=compile gcc -DHAVE_CONFIG_H -I. -I. -I../include  -I../include -DFUSERMOUNT_DIR=\"/usr/local/bin\" -D_FILE_OFFSET_BITS=64 -D_REENTRANT -DFUSE_USE_VERSION=26   -Wall -W -Wno-sign-compare -Wstrict-prototypes -Wmissing-declarations -Wwrite-strings -g -O2 -fno-strict-aliasing -MT fuse.lo -MD -MP -MF ".deps/fuse.Tpo" -c -o fuse.lo fuse.c; \
    	then mv -f ".deps/fuse.Tpo" ".deps/fuse.Plo"; else rm -f ".deps/fuse.Tpo"; exit 1; fi
    libtool: Version mismatch error.  This is libtool 2.1a Debian 1.9+20051221-1, but the
    libtool: definition of this LT_INIT comes from an older release.
    libtool: You should recreate aclocal.m4 with macros from libtool 2.1a Debian 1.9+20051221-1
    libtool: and run autoconf again.
    make[5]: *** [fuse.lo] error 1
    make[5]: Leave directory '/srv/preware/cross-compile/packages/common/fuse/build/armv6/lib'
    "dpkg -s libtool": pastebin
    "ld -v": "GNU ld (GNU Binutils for Ubuntu) 2.20.51-system.20100908"
    "libtool --version": " (GNU libtool) 2.2.6b"

    Any ideas? Thanks in advance!

    Edit: I use Ubuntu 10.10
    Last edited by pcworld; 01/05/2011 at 05:41 AM.
  2.    #2  
    I just saw that I'm not the only one with this problem, I found that comment on the WebOS-Internals wiki (
    It just doesn't work tried for over a week, with fresh Ubuntu 10.4 inside and outside of virtual box, fails on libtool for common/fuse/. Tried -j4 option with make stage, tried make staging-armv7. Also installed automake-1.9 after seeing complaints about that.
    I hope somebody can help me with this!
  3.    #3  
    I got it to work now and put my solution into the WI-wiki: WebOS Internals PDK - WebOS Internals

Posting Permissions