Results 1 to 2 of 2
  1.    #1  
    Well I had discussed with someone on IRC channel, but for the time differemce ( maybe 6-12 hours, I think) and problem with my VirtualBox, the communication is really hard so I post it here.

    First we need the rootfs of i686. This is located at Palm SDK., in the VMware virtual disk .vmdk file.

    I use a script to do that . My system is Ubuntu 10.4, with armv6/7 part made, also 7z and VirtualBox installed. (Warning : Install VirtualBox inside a VirtualBox VM Linux WILL work, but the VirtualBox addin in VM may be DISABLED like folder share and VT)

    Assume palm-sdk_1.4.5-svn307799-sdk1457-pho465_i386.deb has been downloaded to doctors/
    cd doctors
    rm -rf temp
    7z x -otemp palm-sdk_1.4.5-svn307799-sdk1457-pho465_i386.deb
    cd temp
    rm control.tar.gz
    tar -xf data.tar.gz
    cd opt/PalmSDK/0.1/share/emulator/images
    unzip "SDK"
    mv nova-cust-image-sdk1457.vmdk ../../../../../../../
    cd ../../../../../../../
    rm -rf temp
    VBoxManage clonehd nova-cust-image-sdk1457.vmdk rootfs_i686.raw.img -format RAW
    mv ~/.VirtualBox/HardDisks/rootfs_i686.raw.img ./
    mkdir /media/k/
    sudo mount -o loop,offset=32256 rootfs_i686.raw.img /media/k/
    cd ..
    cp -r /media/k ./rootfs/
    cd rootfs 
    mv k i686
    The keypoint is use VBoxManage to convert vmdk to RAW DISK that can be mounted directly.

    And then I use "make stagin-i686".

    Everything has worked properly until it meet glib-2.0. It shows that there's ARM assemble in the source code which cannot be compiled under i686 gcc.

    Can anyone help about that?
  2. #2  
    I have the same problem...
    But some really strange behavior:
    When I run scratchbox mapped to the i686-file and run "gcc", it shows that the arm-compiler is used:
    pcworld@pcworld-desktop:/srv/preware/cross-compile$ sb2 -M /srv/preware/cross-compile/staging/mapping-i686
    [SB2 mapping-i686 armv7] pcworld@pcworld-desktop cross-compile $ gcc
    arm-none-linux-gnueabi-gcc: no input files
    Does anyone know a way to compile something for the emulator in Linux?
    It would make testing so much easier if I could use the emulator for my plugin.
    Last edited by pcworld; 03/27/2011 at 01:57 PM.
    Apps (they're all free now): Explorer for Dropbox – a Dropbox app for webOS that actually works (TP+phones), 3-panel-interface
    File Explorer – fast and simple file manager (root support on webOS 3)
    QuickChat for Facebook – real-time Facebook chat (broken)
    Archive Manager – extract and create archives (zip, rar, 7z, …)
    FTPit! – full-featured FTP client for webOS
    e-mail (contact, support) – if you like what I'm doing, feel free to (alternatively in USD)

Posting Permissions