Results 1 to 11 of 11
  1. wipe's Avatar
    2 Posts
    Hi, I'm trying to install webos pdk toolchain, however the installation fails during "make stage" operation with a seg fault :

    /usr/local/bin/edje_cc: Wrote 1269 bytes ( 1Kb) for "collections/131" collection entry
    /usr/local/bin/edje_cc: Wrote 584 bytes ( 1Kb) for "collections/132" collection entry
    Segmentation fault
    /usr/local/bin/edje_cc: Error. Compiling script code not clean.
    make[5]: *** [default.edj] Fehler 255
    make[5]: leaving directory '/srv/preware/cross-compile/packages/elementary/build/src/data/themes'

    I tried several times on xubuntu 9.10 32-bit x86 platform.
    any ideas what's going wrong?

  2. #2  
    Did you install everything that is needed? You need git, gcc, curl, unzip, autoconf, subversion, libtool, and scratchbox. I got it running fine on Ubuntu 9.10...
  3. #3  
    Quote Originally Posted by wipe View Post
    I tried several times on xubuntu 9.10 32-bit x86 platform.
    any ideas what's going wrong?
    The WIDK is only tested on Ubuntu 9.10 Server 32-bit x86.

    If you don't need that package which is failing for you, just move it to the nonworking directory and try again.

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ if you find our work useful.
    All donations go back into development.
  4. wipe's Avatar
    2 Posts
    thank you for response!
    oh, my mistake, i have overlooked "server"
    however, after removing the elementary package, "make stage" completed successfully.
  5. #5  
    I am having trouble installing it also. After I do make stage, the first err is as follows

    grep: /srv/preware/cross-compile/rootfs/armv7/usr/lib/ipkg/info/unionfs-fuse.list: No such file or directory

    then I get a bunch of errors that are in the form of

    evas_gl_something.h or something.c

    and then something that says Make [7]: *** [evas_gl_contex.lo] Error 1

    there is a bunch of errors that follow that but they all look to be because of the first errors
  6. #6  
    on that same note before I ran make stage i found that after the

    PATH=/srv/preware/cross-compile/toolchain/arm-2007q3/bin:${PATH} sb2-init -c /usr/bin/qemu-arm armv7 arm-none-linux-gnueabi-gcc

    step it said it was complete but i did notice that is also said that install-info was not used anymore and to use ginstall-info and I don't know if that caused an issue for the make stage step
  7. #7  
    I have the same problems on a new install of Ubuntu 9.10 and a following the step by step instructions. The only thing I did was do the updates after installing 9.10 but other that that it was the basic fresh copy of Ubuntu 9.10.
  8. #8  

    I have made an installation inside of a VM, so I could spread that image (VirtualBox) if anyone's interested.


    Last edited by donbachi; 02/07/2010 at 11:59 PM.
  9. #9  
    I would be very interested
  10. #10  
    that may be very helpful, thank you. I'm curious if we could find someplace to host the image..
  11. #11  
    Sorry, was away for some time.
    The vm I'm currently using is a bit bloated and takes up quite some space (~ 10gig) - not the best solution for sharing
    I will prepare a small one with only the basic stuff.



Posting Permissions