Results 1 to 4 of 4
  1.    #1  
    Is the nslookup command gone from webos 1.3.1? I was having trouble resolving names like 3Com | Routers, Switches, VoIP, Wireless, Network Management and when I went to a shell and tried to run nslookup, the command was not found.

    A reset fixed the name resolution issue forme, but I still cannot look up DNS names from the pre.

    Any workarounds?
  2. JerryG's Avatar
    535 Posts
    Global Posts
    551 Global Posts
    Curious. Well... I don't see dig or host around either, but you can use traceroute to do name to address resolution. It's only half a solution, but...

    root@palm-webos-device:/# traceroute
    traceroute: warning: has multiple addresses; using
    traceroute to (, 30 hops max, 38 byte packets

    If I discover anything else, I'll post it here also...


    Uniden PC100 -> Visor -> Visor Pro w/VisorPhone -> Tungsten T -> Tungsten T2 -> Tungsten T5 -> TX -> Treo 650 -> Treo 755p -> Pre -> Evo 4G
  3.    #3  

    I was trying to find the names of the DNS servers the pre uses quickly and found that nslookup and dig are not there. it is funny that traceroute and the web applications work, although, I was unable to access any web sites by name until I rebooted the phone.

    As background I was running mytether to connect my laptop to the Internet. About 15 into my session, all my websites stopped responding and nslookup from my laptop failed. I was able to http to specific IP addresses such as, but name resolution stopped.

    I then checked the pre and the browser could not find 3Com | Routers, Switches, VoIP, Wireless, Network Management but could find it by address (the 139 addy above)

    Once I restarted the phone, DNS worked on my laptop and I was also able to resolve names on the phone itself...


  4. nti
    nti is offline
    nti's Avatar
    2 Posts
    I also have no dns resolution without tethering and on a german gsm pre since I update to 1.3.1
    It happend if I switch off airplane mode with WiFi on and then disable WiFi.

    Airplane mode + Wifi to GSM - WiFi = No Nameserver

    I put my providers nameservers to /etc/resolv.conf, that helps but it fixes not the underlying cause.

Posting Permissions