Page 223 of 305 FirstFirst ... 123173213218219220221222223224225226227228233273 ... LastLast
Results 4,441 to 4,460 of 6094
  1. #4441  
    Nope, screwed up again. Back to .9.24.
  2. #4442  
    I can get Preware to load but now I have a ton of "Unknown Packages". I have 166 now and I used to only have 8. Any ideas? Does it matter? What exactly are they?
  3. #4443  
    Managed to get Preware working again after some messing around. It did seem to just be Package Manager Service needing updating.

    Removing Preware and reinstalling it by WOSQI didn't help anything as for whatever reason I can't get WOSQI to show any Preware version newer than .9.1-something. This gives some of the "PMS not running" errors people are reporting. Old PW doesn't see the new PMS apparently. Remove Preware again and reinstall using Preware stand alone installer to get the newer version (>.9.5). This will work with new PMS.

    But Preware keeps trying to downgrade my Package Manager version back to 9.16? Already fell for it once and had to redo everything to get working again. Should a downgrade be appearing as an "update?" Everything is fine if I ignore it.

    That's also a warning to people: It seems for the time being that you should ignore any Package Manager Service "updates" that Preware finds if you know you have already updated it yourself!
  4. #4444  
    Possible fix for the "package manager service not running" issue with Preware:

    Uninstall Preware and Package Manager Service using Quick Install.
    Restart phone.
    Install Package Manager .9.24 ( ) using the file from YOUR hard drive after you download it.
    Restart phone.
    Install Preware (still using QI).
    Restart phone.

    Worked for me. And I tried tons of various combos... this was the only way that worked. Now, when you get into Preware and rejoice... DO NOT update Package Manager to .9.25 or you will get kicked out of Eden again.
    Last edited by andrewhime; 12/29/2009 at 02:46 PM. Reason: added link
  5. sirmicro's Avatar
    30 Posts
    Global Posts
    31 Global Posts
    Finally got all my patches removed. Using WOSQI, reinstall the patch that it says is still installed. LUNA restart. Using WOSQI, run EPR to remove all patches. LUNA restart. Patches are now gone.
  6. #4446  
    forgot to uninstall patches is there anyway to remove update
  7. dago52's Avatar
    85 Posts
    Global Posts
    87 Global Posts
    Quote Originally Posted by Aaron Tee View Post
    I installed the Avatar theme (which looks really cool on the Pre) but I can't see it in Preware in order to uninstall it. In fact, when I go to installed applications, the theme option does not even show up. Are there any known issues with this theme?
    I think once you install a theme it will not show in preware. Just open preware and click on installed packages and then click on themes. This is where you can uninstall the theme.
  8. #4448  
    Quote Originally Posted by rwhitby View Post
    Another update.

    I've just released Package Manager Service 0.9.25 to the public feeds.

    This version moves the migration helper code (which we suspect might be causing the Package Manager Service not running problems) to a separate utility called the Emergency Migration Helper (or EMH for all you trekkies).

    It should be safe for anyone to upgrade to Package Manager Service 0.9.25 at any time (preferably *before* you upgrade to webOS 0.3.5, but it works just as well afterwards if you update it using WebOS Quick Install 2.96), and to run the Emergency Migration Helper at any time.

    I used the PMS .9.24 this time instead of .9.25 after installing MH

    The Emergency Migration Helper simply adds a dummy appinfo.json file to any homebrew packages left in /var/usr/palm/applications that don't already have such a file (e.g. services, patches, themes, plugins, etc), so that the automatic migration functionality that occurs when the Luna user interface boots (you can cause a Luna Restart to happen at any time using the Luna Manager tool, or just reboot your phone) can successfully migrate these packages across to the new application area in /media/cryptofs/apps. This takes some time, and you phone will run a bit slower while it's happening, so give it 30 minutes before trying the app catalog again after running the EMH just to be sure it's finished.

    -- Rod
    Preware and Luna app do not work because i dont have PMS running...i have installed the mig helper and updated pms, tried restarts between on the second time around...i was able to dl app cat. before and after i installed the EMH and PMS .25, but still cant use Preware...what's next...????

    FIXED!!! TRY THIS but not the way above, this way:
    I tried installing the .25 PMS after downloading the EMH but with no success so
    Using Web OS QI:
    I uninstalled both Preware and PMS restart
    Restarted started Windows cuz i continuously lose connection after a device restart
    I installed PMS .24, and tried Luna once again and it finally worked so i knew PMS was finally being recognized. So Luna after install of PMS .24
    Then installed Preware and it's working perfectly. hope this may help someone out there!
    Last edited by holley2583; 12/29/2009 at 03:45 PM. Reason: Fixed
  9. bkcrown's Avatar
    41 Posts
    Global Posts
    42 Global Posts
    Quote Originally Posted by rwhitby View Post
    Here's the status of Preware and webOS 1.3.5 ... in summary, it's a dog's breakfast, even though Palm did everything they could to give us early access to 1.3.5 for testing.

    Firstly, there was a migration scenario that we couldn't test for (no way to get early access to OTA updates), and which broke Preware.

    Package Manager Service fixes that.

    Next, it seems that the Palm migration functionality (which moves apps from /var to /media/cryptofs/apps) expects all packages to have an appinfo.json file, and barfs if they don't. When it barfs, it stops app catalog installs. Services, Plugins, Patches and Themes don't have that file.

    Package Manager Service fixes that (we hope - assuming we correctly understand what the migration functionality does, since it's a binary that we can't read to see what it does).

    So everyone who is having app catalog problems should upgrade to Package Manager Service ...

    However, it seems that for a small number of people, installing Package Manager Service 0.9.24.x breaks Preware with a Package Manager Service not running error. Note that reinstalling over and over won't fix this, so don't waste your time trying to reinstall it 100 times.

    We don't know why it breaks for some people, and we're not able to reproduce the problem locally.

    If you do have a problem with, but are able to install stuff from the app catalog ok (i.e. the apps have all migrated successfully), then you can try going back to 0.9.24 (use WebOS Quick Install 2.96 to install it from to see if that fixes the Package Manager Service not starting problem.

    If you're having problems installing patches, then use WebOS Quick Install 2.96 to install diffstat and patch and see if that fixes it.

    Make sure you only use WebOS Quick Install 2.96 if you're installing stuff - earlier versions than 2.95 will not work properly with 1.3.5 and will install stuff in the wrong place.

    If you want to skip all this hassle, you can use the WebOS Doctor and everything will work perfectly afterwards. If you're patient, we will sort stuff out over the coming days and you won't need to doctor. Your call.

    Be aware that the Virtual Keyboard has not been ported to 1.3.5, as the author did not get early access to 1.3.5 sorted out in time. So he needs to start porting it now.

    For real-time updates, follow @webosinternals on Twitter.


    See post #4320 for an update on Package Manager Service 0.9.25 and the new Emergency Migration Helper tool.

    -- Rod
    Rod, Will be patient and standby for the PreWare fix. I really enjoy the usability of your program once it is installed properly. Thank you.
  10. cbellevie's Avatar
    52 Posts
    Global Posts
    53 Global Posts
    Quote Originally Posted by northward View Post
    Same problem here. Never installed any themes. Uninstalled all patches prior to updating. After updating and running into this problem I ran mvapp ra to restore all original app locations, but that didn't fix it. I did notice that extra launcher pages are still there even though I removed the patch prior to updating and I wonder if that's causing the problem.

    Anyone out there have any ideas? I really don't want to doctor the thing if I don't have to.
    I would say it's not the extra launcher page, as I used doctor and have the same problem with the App Store...

    I used doctor, restored my profile which reinstalled all my apps except Twee (which was available once I got 1.3.5 on there) and updated to 1.3.5.

    I put Preware on there and everything from there seems to work fine, but the App Store fails, requires 'system adjustments' and a reboot.
  11. #4451  
    I had zero issues loading the updaye via WiFi. The only patdch I had prior was the virtual keyboard. I removed it and a theme and have had no issues. Preware didnt work so I did as suggested. removed it and the service package then updated my weOSquickinstall to version 2.96 (the older will not work) and everthing is fine except no more Virtual keyboard
  12. sstea#WN's Avatar
    5 Posts
    Global Posts
    7 Global Posts
    Has anybody been able to get any of the roaming patches to work with 1.3.5.? This was one of the most useful patches to get coverage where Sprint forces you to stay on their network in a location that is bouncing between 1 and 0 bars.
  13. #4453  
    I can't download anything from the App catalog either. Sometimes I can, but it'll ask me to restart afterwards, then I get an "install failed."
  14. #4454  
    Quote Originally Posted by JMiller613 View Post
    I can get Preware to load but now I have a ton of "Unknown Packages". I have 166 now and I used to only have 8. Any ideas? Does it matter? What exactly are they?
    I have the same exact problem.
  15. #4455  
    Rod, your efforts are greatly appreciated. Based on the above post, I tried again to install diff stat and GNU patch. I get the following error.

    Clearing state_wanted and state_flag for pkg=org.webinternals.diffstat (arch_priority=0 flag=16 want=2)
    an error occurred , returned value 4
    cannot find package org.webinternals.diffstat

    same message for GNU patch.

    I can install program updates and new programs both from App catalog but cannot view/download patches in Preware. I had to use the Emergency Migration tool this morning to address the app catalog issue.

    Palm Pre
    WebOS 1.3.5
    WebQI 2.96
    Per Device management user installed content
    PMS 0.9.25
    Preware 0.9.012

    Hope this helps
  16. #4456  
    I waited until 1.3.5 to install Preware. I've been able to download some apps, but whenever I try to install ANY patches, I get an error on install. It tells me to look in the IPKG LOG, and all it has is a generic error. Any ideas?
  17. #4457  
    Quote Originally Posted by sirmicro View Post
    Finally got all my patches removed. Using WOSQI, reinstall the patch that it says is still installed. LUNA restart. Using WOSQI, run EPR to remove all patches. LUNA restart. Patches are now gone.
    I opened WOS QI and I opened Device management and wrote down the offending patches (that are showing but not working an d cannot be removed)

    Then I opened Tweaks -> Repository to reinstall patches as you descrobed, but ONE of the offending patches show ion the list!

    I tried EPR again anyway and still got error and message that there are no patches installed. Weird. Any other ideas?

  18. #4458  
    I found that after I removed all patches, updated to 1.3.5, it took a second reset in order for everything to work quickly. I didn't find in any posts or directions that I needed to reboot again. But it worked!
  19. #4459  
    Quote Originally Posted by rwhitby View Post
    Package Manager Service is released, to ease the transition to 1.3.5 - upgrade it using Preware before you accept the OTA 1.3.5 update.

    -- Rod
    Definitely uninstall Package Manager Service app and reinstall. I was having issues where PreWare said I had patches installed, which I did through Quick Install, but they were not taking. After I uninstalled Package Manager Service, reinstalled it, then reset my Pre every patch went into effect. Quirky!
  20. gypsyritsa's Avatar
    7 Posts
    Global Posts
    8 Global Posts
    Before updating I ran EPR and updated the package manager service. I've never used themes, so didn't have to mess around with removing any.

    After the update, I was having the same problem with failed updates of apps from the app catalog after getting the same useless restart message as everyone else. (I assume the restart was supposed to move the app from /var to /media and failed to properly do so?) I decided to test out installing a brand new app from the app catalog to see if that would work, since it would be installing fresh in the media partition rather than needing to be moved, but it also failed and requested a restart that failed.

    Next step was to test out Preware and see what happened if I tried to install a homebrew app, but got the same "OnFeeds Error" error mentioned by others.

    I figured "when in doubt, reboot." I did a soft reboot using orange-sym-r, and after one of the longest reboots my Pre has ever gone through, and once my screen came back up, all of my previously-failed updates and the one fresh install automatically installed.

    There were four apps that did NOT install automatically, but they appear to no longer be available at all, or were apps that I originally installed via homebrew that have now become paid apps so it isn't a huge surprise or disappointment. Funny little bug that didn't hurt anything-- Classic updated (and unlike with the last update, doesn't appear to have lost my profile info), but the icon on my launcher page turned into a blank outline. As soon as I opened Classic, my icon came back, so no harm, no foul.

    Preware is back to working fine, and I am currently re-installing my patches. I like how Preware now not only lets you know if your patch requires another package to be installed to work, but that it lets you install both with the touch of a single button. Slick new addition.

Tags for this Thread

Posting Permissions