Page 1 of 5 12345 LastLast
Results 1 to 20 of 86
  1.    #1  

    SmartRunner is a new sportstracking and geotracking application for your Palm Pre and Palm Pixi, which allows you to record your next run, biking trip, hike, walk, ride, or any other outdoor activity and publish them on The application informs you in real time about your average and maximum speed, distance and calories burnt. Sign up for a free webaccount at and you can archive your training history and undertake detailed analysis of tracks on maps and altitude profiles. If you want, your uploaded tracks will be sent automatically via Twitter, Facebook and other Social Networks to your friends. Become part of one of the most active sports enthusiasts communities whos members uploaded over 80.000 tracks already.

    Why at precentral:

    Always before new version is released and got to official app catalog, we would like to take time and give our members opportunity to test new release and give there feedback to new features and request for some other ones.

    Also all complaints are welcome, so that we could improve the application for you.

    And we wish you to train hard and with good results.

    Known issues:

    ● Using large image as avatar slows down the app

    Change Log:

    - improved track recording(track-stop bug seems to be fixed)
    - gps optimizing

    - bugs from 1.0.3 fixed

    - gps optimizing changed(must be better)
    - twitter status update

    ps: Thank you all for testing and all your feedbacks they are really helpful.

    application link
    Last edited by SmartRunner; 05/02/2010 at 10:37 AM. Reason: version update
  2. #2  
    Used it for the first time yesterday and it works great. Nice web interface as well.
  3. #3  
    i have been using this when i run outdoors...

    one comment i have is that it takes time for the GPS signal bars to get to full. I have to turn on VZ navigator for it to get a lock on me. I am not moving and staying still before i get a good full bar of the GPS.

    another one is that, it posts to my fb and twitter accounts, which is great for sharing, i noticed that it posts my distance as MILES in twitter while in FB it posts it in KM. my preferences are set to miles. I want them to say both distances in miles.

    But other than these 2 issues i have ( i know i am nitpicking here), this is a great companion! I cannot see myself running without this app. It keeps me motivated!
  4. #4  
    I can't get this to install on my Pre, it downloads fine and then just sits on the "installing" page but never actually installs.
    Any ideas?.
  5. #5  
    I've been using this app for a while now. Love it.

    I use it to measure my commute when I drive 90 minutes to work, and compare different ways to get there, etc. This app has made my drive a little more interesting. I was very happy when you guys included miles per hour.
  6.    #6  
    thanks you all for your replies, its very important to know, that this application is not only for us useful, it motivates to go forward with development, while it's the best thing in the world to make for people smth. nice.

    trener1, could you please tell, how you install the application, using official catalog? fileCoaster? ...
  7. #7  
    Sure, I am using the official app catalog, and it just stays on installing, I have tried restarting the phone at least 4 times, have let it stay on that window for a few hours just to see what happens, I think I have tried it about 6-7 times and I am just getting the same thing.
  8.    #8  
    hm, it's really strange, there are so many downloads, and nobody had install problem, launch problem yes, but not the install trouble. Could you,please, try some alternative installers, such as filecoaster or webos quick install? What webOS version have you on board? 1.4?
    I'm sitting now and trying to find out, what could causes the problem and have still no idea. But i'll try to get it out.
    as developers, we have no influence on install process, it copies only all files to an application folder, and thats it. Then it is visible in menu and you can launch it. So that it is so difficult to find out the problem ...
    Last edited by SmartRunner; 03/24/2010 at 06:28 PM. Reason: some more thoughts...
  9. #9  
    Things I would like to see in the app:

    -Dashboard mode. If enabled would show stuff like speed/time/distance in the dashboard when the app is minimized.

    -Dark theme.

    I can't really think of anything else.
  10. #10  
    I tried this app about a month ago and after a few days gave up on it. It was very slugglish,,for me anyway. Never had any problems at all with anything on my pre,,but this app was just so slow. Maybe you have updated it abit,and I'm thinking about trying it again,but last few weeks I have been using jogstats,,and even on cloudy days,,it is working pin point perfect.
  11. #11  
    I am running 1.4.
    I tried the Quick Install and that worked, and it did work.
    I wonder how many people had the same issue that I had and just said forget and didn't post (or don't even know about this site).
  12.    #12  
    trener1, that's why it's important to find out where the problem is, could you think on what is different in your device(preferences). (language, location service, memory, amount of installed apps...)

    Thanks for your help!
  13. #13  
    Hey Smart Runner.
    Hmm I can't really think of anything significant.
    I am running 1.4, I have some patches but really nothing major, I am not using any themes, I have about 25 or so apps installed.
    This one the only time that I have had this type of problem.
    Some were installed before 1.4 and some after.
    The one thing that I noticed is that after 1.4 my File Coaster was getting stuck on the loading apps window, so after a few tries I just deleted file coaster.

    My wife actually found your app on her Pixi by browsing the official app catalogue, and I saw it on her phone so decided to try and get it.
    But she has no idea about homebrew or quick install etc.. so if it would have hung up on her installation she most likely would have just moved on.

    Anyhow, let me know if I can answer any more detailed questions, I'll be happy to help if I can.
  14. #14  
    I have been using SmartRunner for two weeks now, on a daily basis. I like it, it's simple to start, runs smoothly and keeps a nice track history on my phone. I have two issues with it at this time. The first is that it is not reliable: I am walking the same 2.4 km track each day and the distance comes out accurately about 60% of the time, and the other 40% of the time the same track reads around 1.4 to 1.5 km for the same 2.4 km walked. This might be related to where I live (Hamilton, Ontario, Canada) and perhaps some unreliability in the GPS. I have noticed this with other apps that track my distance. The second issue is that I can't figure out how to upload my tracks to the website. There is a link for downloading software on the SmartRunner page that is currently broken. There are no instructions on the phone-based app that I can find that allow me to upload my tracks - so I have a track history that I can read on my phone, but not on the website. Notwithstanding, I like this app and I will continue to use it daily, and hope for more accuracy.
  15.    #15  
    trener1, i couldnt still solve the issue, but i'll keep it on mine mind. It could be file encoding problems ot smth else wrong with files, so that they couldn't be copied. I prepare some updates, please than try to download it, and to install from app catalog. And thanks for your help!

    carlton Brown, yeah , it could come to gps accuracy problem, there is small gps signal measurement panel near the sport icon, how good is the signal?

    To upload tracks to the web site it should be no problem, on the main veiw you go menu, select Track history, new view opens, select some track in the list, tap menu and select upload ... and it should upload selected track or show some error message
  16. #16  

    i have been using your app extensively and so happy with it... but i just tried your iphone version and it seems like the iphone gps has issues locking into the location too, but what is funny is that the GPS of the iphone is much more accurate with the distances. I ran the same course yesterday and today and found out the pre's gps was off almost 3 Miles!

    Pre run

    iPhone run

    is there anything you can do about it?
  17.    #17  
    johnj2803 :
    yeah, it's the problem of gps accuracy, i've implemented in palm version gps optimizing methods, so that it must be better now with track saving. I've updated the app in homebrew catalog, so please try it and give short feedback.
  18. diggedy's Avatar
    246 Posts
    Global Posts
    248 Global Posts
    Its great that theres an update for this problem as the app is fantastic. Problem is, when I go to update in preware it takes me to a precentral webpage about smartrunner, it doesnt actually allow me to update
  19. #19  
    Quote Originally Posted by diggedy View Post
    Its great that theres an update for this problem as the app is fantastic. Problem is, when I go to update in preware it takes me to a precentral webpage about smartrunner, it doesnt actually allow me to update
    Try to use the WebOS Quick Installer as described in Getting Started: Homebrew Apps, Patches, and Themes with WebOS Quick Install. That works fine for me.

  20. #20  
    I want to say thank you for this great app, I have used it several times and it works great.
Page 1 of 5 12345 LastLast

Tags for this Thread

Posting Permissions