Page 2 of 9 FirstFirst 1234567 ... LastLast
Results 21 to 40 of 161
Like Tree8Likes
  1. #21  
    I have tried many different fixes for the stuck headset problem and nothing has worked...Until now. The only problem is when I switch the phone mode to speaker, with your wonderful app, it will only work for one phone call then revert to headset mode. I also tested keeping the app open to see if it would prevent the speaker mode from reverting back to the headset but it was not successful. Thank you for saving me from the horror that is the Sprint retail store! I really was not interested in trading my pre for a referb.
    Last edited by nolyrics2; 03/08/2010 at 03:21 AM.
  2. #22  
    I wonder if there is a way to have the program run and set for speakers automatically. I reboot the pre overnight and every morning I have to rerun TGH to set the phone and music back to speakers. Preset Reset (used to restart everynight) does have the ability to run a program after it is rebooted. It would be nice if this could be ran some how so that I do not need to do it manually every day.

  3. #23  
    Huge thanks! You saved me from smashing my phone with a hammer, I've been dealing with this for 2 months now!
  4. #24  
    the program works but it doesn't stay permenant. that is, i run the program and it put its back to regular mode. if i make a call it stays in regular mode but right after i hang up and close the program it goes back to headset mode. ughhhhhhhhhhhhhhhhhhhh
  5. phee68's Avatar
    6 Posts
    Global Posts
    7 Global Posts
    I really appreciate this. It does what it is supposed to do. It doesn't eliminate the problem, but it does fix it temporarily so that I can actually use my phone.

    Side note:
    Palm is really stupid for putting a phone out that does this. It's not like a phone with a headphone jack is new technology. Cutting corners = bad business.

    ... Yep, only works for one phone call. Not so impressive.

    ... And I just read all your posts for the first time. Sorry for being a ****** and telling you what you obviously already know.

    ... And I do not think that ****** is a bad word. It's simply an out-dated method of feminine hygiene. ha
    Last edited by phee68; 03/11/2010 at 09:57 PM.
  6. #26  
    I went to sprint last night to get it "repaired." they obviously couldn't fix it and are mailing me a replacement.
  7. #27  
    yeah, I have this problem too. It usually happens because I yank out my earbuds in a hurry when I'm done with laundry or something. Maybe it it becomes a huge problem (does it at random), I can muster up some gumption and force sprint to replace it. Good idea on the app though, forcing it to switch at the software level.
  8. #28  
    i just got the stuck headset for the first time, although unplugging it a few times worked for me. but i downloaded this just in case that does not work next time. thanks for the hard work, also i love battery monitor. good stuff man
  9. strick922's Avatar
    33 Posts
    Global Posts
    46 Global Posts
    Whatever program i'm using with my headphones i close that program and wait about 5min's and then unplug my headphones and it never gets stuck in headphone mode!
  10. #30  
    Thanks, neville!!!

    I have been haunted by the Phantom Headphones periodically for the last few months, but yesterday it moved in permanently, or at least that's what I thought until a minute ago. I went to the Sprint store this morning and they couldn't fix it. They're sending a "new" (Refurb) in the mail but now I don't need it.

    This app is excellent for watching the real time state of the headphone sensor while cleaning. The qtip method did nothing for me, but this app and a toothpick did the trick (well, at least until junk from my pocket mucks with the switch again)

    It appears to me that the sensor is on the camera side of the socket and trips by being pushed to the side by the jack. With the app open, a focused light and a toothpick I poked lightly at the bigger contact/switch that's deep in the socket and, for a lack of better terminology, unstuck it. The contact made a slight but noticeable move closer to the center of the barrel.

    Before, I could stick the toothpick until the tip hit the bottom and move it to the side without feeling or hearing any type of switch. Now I can hear and feel the switch engage when using the toothpick to push it to the side like a headphone jack would.

    It's terribly dorky, but I'm just enjoying plugging and unplugging headsets to watch the app say "Speaker" then "Headset" then "Speaker" then "Headset with Mic" then, best of all "Speaker" again.

    I've had a Pre since launch and I've never sat down to mess with homebrew apps, but figuring there's a new phone in the mail and here's an app you wrote addressing my issue, I decided to give homebrew a try. Now my phone works again and I have a bunch of apps to look through. I'll stop typing right after I say.....

    Thank You, Thank You, Thank You!!!

    Last edited by cscotto; 03/17/2010 at 07:40 PM.
  11. tatsumaki's Avatar
    12 Posts
    Global Posts
    14 Global Posts
    Quote Originally Posted by neville View Post

    Download here and install via preware:
    This is a newb question, but how do I use this link to install via preware? I haven't been able to find anything that says how to do this.
  12. psm9's Avatar
    328 Posts
    Global Posts
    340 Global Posts

    You're my new best friend! Awesome app. It took 2 seconds to fix what an hour of spraying contact cleaner and jamming the headset in and out couldn't do.
    Palm V -->m505 -->Tungsten T3-->T5->Centro-->Pre!
  13. #33  
    Thank you for the suggestions!!
    Been having this problem for a week now, finally found some time to look into it.
    Just used the Q-tip / alcohol method and it's back to normal now.
    A dust cover or an insert would be a great idea.
  14. keithjjo's Avatar
    16 Posts
    Global Posts
    21 Global Posts
    This is the second time I had this problem. Tried a number of the items in one of the other posts (but not the qtip) and got it back. This app worked but the lack of a permanent switch for the phone is problematic. I found it very useful to show the status when I did use the qtip this time to do the cleaning and it showed when I had successfully changed the state back. Thanks!
  15. #35  
    thanks for this app. My wifes pre stopped playing music out of the speaker. We tried it all like the pandora thing and unplugging while on call, etc... And none of it worked and this app absolutely fixed it. So thank you.
  16. #36  
    Quote Originally Posted by netwrkr9 View Post
    I had the "stuck in headphone mode" issue a few months back too. The problem is that the open port allows dust/debris to enter and slow/stop the trip mechanism that switches the phone into "headphone mode" when you install the headphone plug into the jack. While alcohol does clean out the jack, I found something that worked better for me. What I did was take some WD40 and lighty spray some on the tip of the headphone plug and insert it into the headphone jack, then I removed it and cleaned it with a cloth. I repeated this procedure a few more times and this solved the problem for me. Am I suggesting that you take the nozzle of the spray can and spray directly in the headphone jack, NO! I don't know, maybe this might work for you. I did this a few months ago and have yet had this problem reappear.
    Thank you!
  17. jp22382's Avatar
    355 Posts
    Global Posts
    418 Global Posts
    None of the other fixes were working this time. App took care of it first try. Thank you!!!

    Both media and phone were stuck in headset mode, kicked them over to speaker and worked immediately.
  18. Shineon's Avatar
    121 Posts
    Global Posts
    137 Global Posts
    Would this help with car audio as well? I plug it into the Aux input to listen to my tunes, but when a call comes in, they cannot hear me.
  19. #39  
    Yeah, I took mine to Sprint, they "fixed" it, but offered to give me a replacement, to which I agreed. The new unit is awesome!
  20. jp22382's Avatar
    355 Posts
    Global Posts
    418 Global Posts
    Anyone have problems getting bluetooth headsets working with media?

    I can't get anything on bluetooth for the life of me. The headset shows as connected on the phone, but the headset itself does not produce any sound.

    But if I place a call I get sound no problem...

    Media works fine with a wired headset or via the speaker.
Page 2 of 9 FirstFirst 1234567 ... LastLast

Posting Permissions