Page 1 of 2 12 LastLast
Results 1 to 20 of 21
Like Tree15Likes
  1.    #1  
    Greetings, WebOS community! I am excited to announce the first major release for my fork of WebOS Quick Install - I call it the "u" branch, for unofficial. This update includes numerous improvements over the ancient 4.6.0, including bug fixes on multiple platforms. I plan to support this, so if anyone has feature requests, just let me know!

    UPDATE: v4.7.2u has been released, fixing compatibility with Java 7-10! Download below.

    Download/Learn More: https://github.com/NotAlexNoyle/webo...es/tag/v4.7.2u

    Donate to support future development (I am a broke college student): www.paypal.me/NotAlexNoyle

    Donate to support the original developer: https://www.paypal.com/cgi-bin/websc...=7G5QLAXMVVSGY

    Report a bug: https://github.com/NotAlexNoyle/webo...install/issues

    **Features**

    * Stylish easy-to-use GUI
    * Cross-platform support (Windows, Mac OS X, Linux)
    * Supports off-feed .ipk and .patch files
    * Full-featured feed viewer, with custom feeds allowed
    * No Linux knowledge required, no root access required.
    * webOS 3.x-compatible
    * Full device information section
    * Send and receive files to and from a webOS device.
    * Multiple device support
    * Supports Open webOS/LuneOS
    * Supports English, French, German, and Simplified Chinese

    For a full record of changes from the legacy 4.6.0, check out the releases archive: https://github.com/NotAlexNoyle/webo...stall/releases

    ------------------------------
    What's new in v4.7.2u:
    ------------------------------

    1. Fixed compatibility with Java 7-10

    2. Added eclipse-related files so others can more easily experiment with the project

    ------------------------------
    Planned for future versions:
    ------------------------------

    1. Fix more code spacing and indentation (Currently up to FeedViewer.java)

    2. Fix several eclipse warnings

    3. Fully comment/document code

    4. Show a photo of whatever device that is currently selected, instead of always showing an original Pre. Also show this in "installing" view.

    5. Migrate from Better Swing Application Framework to standard Java Swing

    6. Fix prefs warnings at runtime on Linux

    7. Fix a couple of windows registry errors

    8. Add support for BSDs and Solaris-based operating systems (and possibly more)

    9. Distrbute operating system-specific packages with icons (.exe, .app, etc) instead of .jar for everything.

    10. Fix armhf device detection

    11. Locate and remove unwanted loop when loading image assets in PackageViewer upon first launch

    12. Fix layout of About window on MacOS

    13. Fix Linux novacomd installation, and add support for installing novacomd on armhf

    14. Work on community feedback and implement community requests!

    15. Fix code order / refactor in general.

    16. Update translations

    17. Resolve this issue: https://github.com/JayCanuck/webos-q...stall/issues/4

    18. Fulfill this request: https://github.com/JayCanuck/webos-q...stall/issues/3

    19. Add "continue anyway" option in the "there are no devices currently connected" pane, and change "ok" to "quit"

    20. Fix splash screen

    Requirements

    * [OpenJDK 1.7 or greater](https://www.adoptopenjdk.net/)

    * Novacom or [Adb](http://lifehacker.com/the-easiest-wa...-to-1586992378)
    * Novacom will get installed automatically when you run WebOS Quick Install (except on linux for now). ADB is required for LuneOS only.

    * DevMode enabled
    * This can be done on your device by typing "upupdowndownleftrightleftrightbastart", opening the DeveloperMode app, and enabling the feature. Not required for LuneOS.

    * When you plug in the device, if you want to use WebOS Quick Install, choose the "Just Charge" option on the device.

    Running WebOS Quick Install:

    * Simply double-click WebOSQuickInstall.jar and (as long as Java is installed properly) it will launch.
    Last edited by NotAlexNoyle; 05/12/2019 at 01:03 AM. Reason: v4.7.2u Update
  2. #2  
    May I ask why you forked this rather than contributed to the original?

    Can you clarify the differences from 4.6.0?

    I'm curious because I was unaware of any particular issues with the original, though that doesn't necessarily mean it wasn't dated or that new features wouldn't be welcome.
  3.    #3  
    Quote Originally Posted by Preemptive View Post
    May I ask why you forked this rather than contributed to the original?

    Can you clarify the differences from 4.6.0?

    I'm curious because I was unaware of any particular issues with the original, though that doesn't necessarily mean it wasn't dated or that new features wouldn't be welcome.
    A changelog is available in the original post and at this link, and I describe which issues existed from the original that are now fixed: https://github.com/NotAlexNoyle/webo...ses/tag/4.7.0u

    I didn't contribute to the original because I assumed the original project is dead. For example, there are issues on it's GitHub page that have been unresolved for years.
  4. #4  
    I haven't tried it yet, but fantastic!

    -- Sent from my TouchPad using Communities
    NotAlexNoyle likes this.
  5. #5  
    Yep, glad to see active development
    NotAlexNoyle likes this.
  6.    #6  
    Quote Originally Posted by George Mari View Post
    I haven't tried it yet, but fantastic!

    -- Sent from my TouchPad using Communities
    Let me know what you think! I am looking to incorporate the feedback I get from the community
    HelloNNNewman likes this.
  7. #7  
    Uhm,

    in the notes you mentioned that java 7 is the minimum requirement to run this, and I have version 7 update 67 installed (this one allows to use the "older" quick install). But with this is not launching

    I:\Webos Quick Install 4.7.0>java -jar WebOS-Quick-Install-4-7-0.jar
    Exception in thread "main" java.lang.UnsupportedClassVersionError: wosqi/WebOSQuickInstallApp : Unsupported major.minor version 55.0
    at java.lang.ClassLoader.defineClass1(Native Method)
    at java.lang.ClassLoader.defineClass(Unknown Source)
    at java.security.SecureClassLoader.defineClass(Unknown Source)
    at java.net.URLClassLoader.defineClass(Unknown Source)
    at java.net.URLClassLoader.access$100(Unknown Source)
    at java.net.URLClassLoader$1.run(Unknown Source)
    at java.net.URLClassLoader$1.run(Unknown Source)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at java.lang.Class.forName0(Native Method)
    at java.lang.Class.forName(Unknown Source)
    at org.eclipse.jdt.internal.jarinjarloader.JarRsrcLoader.main(JarRsrcLoader.java:59)
  8.    #8  
    Quote Originally Posted by mazzinia View Post
    Uhm,

    in the notes you mentioned that java 7 is the minimum requirement to run this, and I have version 7 update 67 installed (this one allows to use the "older" quick install). But with this is not launching

    I:\Webos Quick Install 4.7.0>java -jar WebOS-Quick-Install-4-7-0.jar
    Exception in thread "main" java.lang.UnsupportedClassVersionError: wosqi/WebOSQuickInstallApp : Unsupported major.minor version 55.0
    at java.lang.ClassLoader.defineClass1(Native Method)
    at java.lang.ClassLoader.defineClass(Unknown Source)
    at java.security.SecureClassLoader.defineClass(Unknown Source)
    at java.net.URLClassLoader.defineClass(Unknown Source)
    at java.net.URLClassLoader.access$100(Unknown Source)
    at java.net.URLClassLoader$1.run(Unknown Source)
    at java.net.URLClassLoader$1.run(Unknown Source)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at java.lang.Class.forName0(Native Method)
    at java.lang.Class.forName(Unknown Source)
    at org.eclipse.jdt.internal.jarinjarloader.JarRsrcLoader.main(JarRsrcLoader.java:59)
    Thank you for reporting! I fixed this in v4.7.1u. Let me know if it works for you

    And in the future, please use GitHub for this if possible, it is easier for me to track that way.

    https://github.com/NotAlexNoyle/webo...es/tag/v4.7.1u
  9. #9  
    Not working, still same error present
  10. #10  
    WOSQI 4.7.1u not working/loading.
    WOSQI 4.6.0 still functioning well - no problems.

    Win 10 - 1809 + accumulated JAVA Updates.

    TP 32Gb 4G. 3.0.5 / CM10. ~ Pre3 16Gb GSM. 2.2.4. ~ TS2 BT Audio-Dock ~ HP iPaq. hx-2790b.
    TP 32Gb Wifi. 3.0.5 / CM10. ~ Veer (Wht.) 8Gb GSM. 2.2.4. ~ HP Omen-15-5206tx. 256Gb SSD. i7-O/C@3.39Ghz. Win10.
  11.    #11  
    Quote Originally Posted by Mutoidi View Post
    WOSQI 4.7.1u not working/loading.
    WOSQI 4.6.0 still functioning well - no problems.

    Win 10 - 1809 + accumulated JAVA Updates.
    Try this test build: https://www.dropbox.com/s/m69xih74xt...DEBUG.jar?dl=0

    If it works. let me know, otherwise, I need your Java version and the error message you're getting please.
    Last edited by NotAlexNoyle; 05/10/2019 at 11:29 AM.
  12.    #12  
    Quote Originally Posted by mazzinia View Post
    Not working, still same error present
    Try this test build: https://www.dropbox.com/s/m69xih74xt...DEBUG.jar?dl=0
  13. #13  
    Quote Originally Posted by NotAlexNoyle View Post
    This worked, and in case you need the output, there are only 2 warnings

    I:\Webos Quick Install 4.7.0>java -jar WebOS-Quick-Install-4-7-2-DEBUG.jar
    mag 10, 2019 10:22:25 PM org.jdesktop.application.LocalStorage getId
    WARNING: unspecified resource Application.id using WebOSQuickInstallApp
    mag 10, 2019 10:22:25 PM org.jdesktop.application.LocalStorage getId
    WARNING: unspecified resource Application.vendorId using UnknownApplicationVendor
  14.    #14  
    Quote Originally Posted by mazzinia View Post
    This worked, and in case you need the output, there are only 2 warnings

    I:\Webos Quick Install 4.7.0>java -jar WebOS-Quick-Install-4-7-2-DEBUG.jar
    mag 10, 2019 10:22:25 PM org.jdesktop.application.LocalStorage getId
    WARNING: unspecified resource Application.id using WebOSQuickInstallApp
    mag 10, 2019 10:22:25 PM org.jdesktop.application.LocalStorage getId
    WARNING: unspecified resource Application.vendorId using UnknownApplicationVendor
    Great! I will release this as v4.7.2u later today. If you experience any more problems, or have any requests, I'm all ears

    That output is a result of using Better Swing Application Framework - Migrating to standard Java Swing is on my long-term to-do list.
  15. #15  
    Well, one request .. I can think of one, tbh.
    Normally when it starts, if a device is not connected it just asks to retry the discovery or to quit the program. I've always thought it would be more useful if it just starts and if a device is not connected, it simply allows to do a discovery.. in the meanwhile being able to check the feeds etc even without having a connected device.
    Would it make any sense ? ( asking to the others here that peek )
  16.    #16  
    Quote Originally Posted by mazzinia View Post
    Well, one request .. I can think of one, tbh.
    Normally when it starts, if a device is not connected it just asks to retry the discovery or to quit the program. I've always thought it would be more useful if it just starts and if a device is not connected, it simply allows to do a discovery.. in the meanwhile being able to check the feeds etc even without having a connected device.
    Would it make any sense ? ( asking to the others here that peek )
    If I understand you correctly, that’s on my todo list above as #19.
    MudShark22 likes this.
  17. #17  
    hops, true. my bad
  18. #18  
    Quote Originally Posted by NotAlexNoyle View Post
    Try this test build: https://www.dropbox.com/s/m69xih74xt...DEBUG.jar?dl=0

    If it works. let me know, otherwise, I need your Java version and the error message you're getting please.
    It works.. a bit slow to load, but functional.

    Thank you.

    TP 32Gb 4G. 3.0.5 / CM10. ~ Pre3 16Gb GSM. 2.2.4. ~ TS2 BT Audio-Dock ~ HP iPaq. hx-2790b.
    TP 32Gb Wifi. 3.0.5 / CM10. ~ Veer (Wht.) 8Gb GSM. 2.2.4. ~ HP Omen-15-5206tx. 256Gb SSD. i7-O/C@3.39Ghz. Win10.
    MudShark22 likes this.
  19.    #19  
    Quote Originally Posted by Mutoidi View Post
    It works.. a bit slow to load, but functional.

    Thank you.
    Great! I will work on improving the startup speed in the future.

    The test build I sent you has been released as v4.7.2u which you can download here: https://github.com/NotAlexNoyle/webo...es/tag/v4.7.2u
    MudShark22 likes this.
  20. #20  
    Quote Originally Posted by NotAlexNoyle View Post
    Great! I will work on improving the startup speed in the future.

    The test build I sent you has been released as v4.7.2u which you can download here: https://github.com/NotAlexNoyle/webo...es/tag/v4.7.2u
    Thanks again!

    TP 32Gb 4G. 3.0.5 / CM10. ~ Pre3 16Gb GSM. 2.2.4. ~ TS2 BT Audio-Dock ~ HP iPaq. hx-2790b.
    TP 32Gb Wifi. 3.0.5 / CM10. ~ Veer (Wht.) 8Gb GSM. 2.2.4. ~ HP Omen-15-5206tx. 256Gb SSD. i7-O/C@3.39Ghz. Win10.
    MudShark22 likes this.
Page 1 of 2 12 LastLast

Similar Threads

  1. Replies: 3
    Last Post: 05/31/2019, 01:19 PM
  2. Is there no virtual keyboard that works in WebOS 2.2.4?
    By Blaby in forum webOS Discussion Lounge
    Replies: 12
    Last Post: 05/31/2019, 12:27 AM
  3. Title only Search on webOSNation site doesn't work for me
    By Rover775 in forum webOSNation.com - Site News, Feedback & Help
    Replies: 0
    Last Post: 04/07/2019, 02:42 AM
  4. Replies: 1
    Last Post: 03/24/2019, 07:59 AM

Tags for this Thread

Posting Permissions