Results 1 to 6 of 6
Like Tree1Likes
  • 1 Post By Preemptive
  1.    #1  

    found that this topic was discussed before, but didn't find if there's a workaround. So far I always believed the problem is caused by old or wrong certificates. And in most cases the problems could be solved by installing new certificates out of the certificate chain. But in some cases it was impossible for me to load a specific site. This morning I found a very interesting example:
    When trying to load my Touchpad says that the site could not be loaded (Error 2035 on a Veer). Lumberjack says: "Unknown Handled Error: SSL connect error".
    When I checked the certificate chain on my desktop PC I found that the site is using exact the same root- and intermediate certificates that I'm using on my site It's a Let's encrypt certificate. And I had no problems loading sites with Let's encrypt certificates so far.

    So I would guess that the error in this case has nothing to do with possible old certificates on my device. Maybe it is caused by the server settings?
    How can I get more information about this error - and is there a chance to fix this?

    Best regards, Stefan
  2. #2  
    I was going to suggest trying to loading the site using a desktop browser - which might have more detailled error messages. Well, I am suggesting that, but I just tried loading it in Qupzilla and it worked.

    So it may be something in the configuration of the site or the stock browser being strict, but I assume Qupzilla is fairly secure and it hasn't complained. I think it comes with a lot of it's own machinery built in rather than interfacing with webOS much.

    When you write of installing certificates, I wonder, do you have the OSSL upgrade & bundle installed?
  3.    #3  
    Quote Originally Posted by Preemptive View Post
    When you write of installing certificates, I wonder, do you have the OSSL upgrade & bundle installed?
    On my Touchpad is OpenSSL Updater and RootCertsUpdate installed. On my Veer none of them.

    It's difficult to locate the problem on desktop PC, because there is no problem. All is configured well for the browser and OS I'm using.

    When checking my site and the ip-phone-forum on there are many differences. I don't know exactly what all of the information is about. But maybe the information in "Handshake simulation" may be interesting. There are "Server closed connection" messages on several systems for ip-phone-forum. Even one for OpenSSL 0.9.8y.
    My site seems to be supported for OpenSSL 0.9.8y. Is exactly this point the problem? The only solution would be another OpenSSL Update? Or has OpenSSL nothing to do when calling a site with the browser?

    There's another test to check my client:
    There are several warnings, but I can't find a proof, that loading of ip-phone-forum will fail when using stock browser or Advanced Browser. Maybe there is a proof but I don't understand...
  4. #4  
    This might be interesting:
    I tried in my Pre3 and got the Error 2035.

    The Google weblite url works.
    Last edited by Preemptive; 09/03/2017 at 08:25 PM.
    Nafetz likes this.
  5.    #5  
    Yes, that's a really great patch and a usable workaround.
    What a pity that it doesn't work with all sites (e.g. or loading images fullsize (e.g. opening the preview images of my site). But that is not the fault of the patch
  6. #6  
    Yes, unfortunately there will always be sites that won't work. does however work for me on my touchpad (JavaScript on). works too (both with JavaScript on and off; but in the latter case it doesn't show images).
    Last edited by Misj'; 09/05/2017 at 12:44 PM.

Similar Threads

  1. Hoping for some insight
    By Fred Zyphal in forum HP Pre 3
    Replies: 9
    Last Post: 12/20/2017, 03:03 PM
  2. Use of line tube
    By docsdad in forum HP TouchPad
    Replies: 1
    Last Post: 08/27/2017, 02:54 PM
  3. Recent column that I'd love to get the real community thoughts on?
    By allen832008 in forum webOS Development
    Replies: 5
    Last Post: 08/14/2017, 07:49 AM
  4. SlingTV app WebOS 3.0 - How-To or instructions?
    By elkcaps in forum LG webOS TV
    Replies: 0
    Last Post: 08/02/2017, 09:16 AM
  5. Migrating from pre3/webOS to Android - need help
    By dreamseekeroo in forum HP Pre 3
    Replies: 2
    Last Post: 07/23/2017, 07:04 PM

Posting Permissions