Results 1 to 9 of 9
Like Tree2Likes
  • 1 Post By bbito
  • 1 Post By bbito
  1.    #1  
    A few days ago I got interested in the WebOS platform. After long hours of searching, I finally found the WebOS 3.0.5 SDK and emulator. The emulator works perfectly fine. But: when trying to install Preware, the ssh connection using PuTTY did not work. The palm-install command didn't work either, showing no devices found. WebOS Quick install also doesn't detect the emulator, even after reinstalling the novacom drivers several times and rebooting. At this point I am pretty much stuck on what to do, as I do not see anything that I have done wrong. So I request help from here, as it is the only place that seems active.
  2. #2  
    @jray4559, Can you let us know what platform you're on, e.g. Windows7/32bit?
    Windows7/32bit happens to be what I just tested with and I can palm-install into the 3.0.5 image no problem. It seems to me that your novacom is not working correctly, but other than re-installing novacom yet again I can't offer anything useful without more info...
    EDIT: I just checked and the PuTTY and "Device Browser" that come with the PDK connect as well...
    Last edited by bbito; 06/23/2017 at 06:36 PM. Reason: add PuTTY and Browser
  3.    #3  
    @bbito I am on windows 10 64bit. The thing is, my computer is so old that I can only run 32-bit images. Maybe I should try installing 32-bit novacom
  4. #4  
    So you did a Win-32bit SDK install? That would have installed 32bit novacom - maybe that is the issue...
    I've only run the 64bit SDK on Linux so far, so I'm not sure of the Win-64bit pitfalls, but if your problem isn't from running 32bit SDK on win64, I'd look at firewall blocking the virtualbox ports.

    -- Sent from my Palm Pre using Forums
  5.    #5  
    @bbito No, I actually installed a 64-bit sdk. I probably should check in the firewall for blocks though
    Edit: I don't see anything in the firewall that could cause it.
    Last edited by jray4559; 06/24/2017 at 10:36 PM. Reason: firewall info
  6. #6  
    I have a new (used) win10/64 thinkpad I've been slowly setting up and finally got around to installing the HP_webOS_SDK-Win-3.0.5-676-x64 SDK.

    1) I installed Java JRE jre-8u131-windows-x64.exe from: Java SE Runtime Environment 8 - Downloads
    2) I installed old virtualbox VirtualBox-4.1.18-78361-Win.exe from:
    3) Restarted and checked java -version
    4) Then installed the 64bit SDK: HP_webOS_SDK-Win-3.0.5-676-x64 SDK
    5) Started Emulator
    5a) When Windows Firewall complained about VirtualBox I "Allowed" it access.

    I can connect with the included PuTTY - Check
    I can palm-install an ipk - Check
    I can connect with nova-browser (device browser) - Check

    Windows Task Manager: Services tab shows NovacomD and Palm_TCP_Relay running

    So it is possible to get this all running in 2017 on Windows10/64bit
    -Hope this helps!
    Last edited by bbito; 06/25/2017 at 10:13 AM. Reason: typo fix
    Blaby likes this.
  7.    #7  
    I managed to get it installed by using the Older Virtualbox.
    I was using the new virtualbox with the patch to make it work, and the patch must have hidden it or something. Everything now works!
    There is one other problem, though. I don't have the i686 version of preware.
    I tried installing the arm version, but it didn't work. Do you know where I can find it?

    Update: Nevermind. I figured out where to install the i686 via WebOSQuick Install
    Last edited by jray4559; 06/25/2017 at 12:54 PM. Reason: Preware was installed
  8. #8  
    Quote Originally Posted by jray4559 View Post
    I tried installing the arm version, but it didn't work. Do you know where I can find it?
  9. #9  
    In case you want to try the phone images, I had forgotten how to add them to the 3.0.5 SDK, so I figure this is a good place to have the info.
    1) Grab the 2.2.4 (and 1.4.5 for old phones) Emulator Image ZIPs, links are here:
    2) Bring up a command prompt where you downloaded the ZIP(s) and "palm-emulator --install" them, e.g.:
    palm-emulator --install ""
    Blaby likes this.

Similar Threads

  1. Twitch on WEBOS
    By AntivladinForum in forum LG webOS TV
    Replies: 2
    Last Post: 11/20/2018, 12:35 PM
  2. Replies: 0
    Last Post: 06/19/2017, 09:14 PM
  3. Replies: 0
    Last Post: 06/19/2017, 09:12 PM
  4. preware - orcrest
    By mazzinia in forum Other webOS Tablets
    Replies: 14
    Last Post: 06/16/2017, 06:58 AM
  5. Using WebOS TV Universal Control with Atto Net4
    By arkadyzalko in forum LG webOS TV
    Replies: 0
    Last Post: 06/11/2017, 10:04 PM

Tags for this Thread

Posting Permissions