I have a Pixi Plus on Verizon, (although the problem was present in just 1.4.5) and this issue applies to both 3G and Wifi connections.

My /media/cryptofs is a read-only filesystem. When I start Preware, I get a slew of errors that look like the following:

'/media/cryptofs/apps/usr/lib/ipkg/cache/webosinternals': Read-only file system,rm: cannot remove

Preware hasn't shown me an updated or new app in over a week. I assume the feeds are not being refreshed because the cache is unwritable. The feed download happens just fine, as far as I can tell.

The App Catalog will not download or update any app either. It will attempt to download for about 10 seconds, then tell me "Download Failed". I have about 4 apps that I can't use now because when I tap on them it takes me to the App Catalog update screen, and then proceeds to fail updating. The app will not launch.

On the command line, I can't create or remove any file from /media/cryptofs or any subdirectories. I tried "touch test.txt" in several places. It works in /media/internal or /var/home/root, but in /media/cryptofs I get "touch: test.txt: Read-only file system"

I have tried "mount -o rw,remount /media/cryptofs/" and the command executes with no output (just like when it works on /media/internal), but it doesn't change the Read-only error.

Here's my /etc/fstab:
# <filesystem> <mount point> <type> <options> <dump> <pass>
rootfs / ext3 ro,suid,dev,exec,auto,nouser,async,noatime 1 1
/dev/mapper/store-var /var ext3 noatime,data=writeback 0 0
/dev/mapper/store-log /var/log ext3 noatime 0 0
/dev/mapper/store-update /var/lib/update ext3 noauto,noatime 0 0
proc /proc proc defaults 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0
tmpfs /tmp tmpfs size=64M,mode=1777 0 0
tmpfs /var/run tmpfs size=16M,mode=1777 0 0
tmpfs /media/ram tmpfs defaults 0 0
/dev/mapper/store-media /media/internal vfat utf8,shortname=mixed 0 0

And my /etc/mtab:
rootfs / rootfs rw 0 0
/dev/root /boot ext3 rw,data=ordered 0 0
/dev/mapper/store-root / ext3 ro,data=ordered 0 0
proc /proc proc rw 0 0
sysfs /sys sysfs rw 0 0
/dev/mapper/store-root /dev/.static/dev ext3 ro,data=ordered 0 0
tmpfs /dev tmpfs rw 0 0
/dev/mapper/store-var /var ext3 rw,noatime,data=writeback 0 0
/dev/mapper/store-log /var/log ext3 rw,noatime,data=ordered 0 0
devpts /dev/pts devpts rw 0 0
tmpfs /tmp tmpfs rw 0 0
tmpfs /var/run tmpfs rw 0 0
tmpfs /media/ram tmpfs rw 0 0
/dev/mapper/store-media /media/internal vfat ro,fmask=0022,dmask=0022,codepage=cp437,iocharset=iso8859-1,shortname=mixed,utf8 0 0
cryptofs /media/cryptofs fuse.cryptofs rw,nosuid,nodev,user_id=0,group_id=0,allow_other 0 0
none /dev/cgroup cgroup rw,cpu 0 0
/dev/mapper/store-var /opt ext3 rw,noatime,data=writeback 0 0
extractfs /var/luna/data/extractfs fuse.extractfs rw,nosuid,nodev,user_id=0,group_id=0 0 0

As you can see, it says /media/cryptofs is mounted rw, but that's really not the case. My /media/internal also boots up ro, but I'm not sure if that's related. The cryptofs read-only problem doesn't change when I make /media/internal writable via the mount command.

I have tried Jason Robiltaille's WebOSRepairUtility, and it found 4 files to restore, 3 of which were pictures, and the fourth was something like /etc/.RW-rootfs, which I thought would make a difference, but it didn't. I would like to avoid Doctoring, if possible. Being enough of a Linux hand to understand file systems and mount points and all that, I thought it would be possible to fix this at the command line without Doctoring. Maybe I'm wrong.

My phone seems to work just fine otherwise, I just can't add or update any apps. I don't have too long until my upgrade comes around, so it won't kill me to sit on this for a while longer (I've lived with the Pixi Plus for a year, which is all kinds of masochistic), but I'd love to know how to fix it. Any ideas?