I'm having trouble logging in to my bank's website. I have read other posts on this forum from others having similar problems, but different banks...so I have to conclude that the problem is somewhere in the Pre.

I can get to the bank's website fine, and enter my login information, click submit, and it starts to load a page, then seems to restart (if you watch the loading icon in the lower right corner, it hitches as if it restarted). Then, I'm left with a blank white page, with the title "Security Settings." If I click the refresh button in the lower right, I just keep getting the same blank white page over and over. But, if I click in the bubble at the top that says "security settings", I get a URL (very long), and if I hit Enter, then I get a new page that says "Cookies are invalid or disabled.", asking me to log in again.

I have tried every possible combination of cookies accepted yes/no, Javascript on/off, and Popup blocker on/off, always the same result.

I have cleared the cookies, and cleared the cache, no change.

The interesting thing is, when I first got the pre, this bank's website DID work, and I was able to log in with no trouble. The trouble began when my password expired (the bank requires a password change every 180 days). As soon as I changed the password, BOOM, couldn't log in.

Thinking that maybe there was a cookie left out there somewhere, I did hard reset my pre (Device Info/Full Erase, but NOT Secure Full Erase), and tried logging in RIGHT after the reset, before I reloaded anything. And....Nope, couldn't log in, same problem as before.

I contacted the bank, they basically shrugged and said they didn't know what the problem was, that I should just use their mobile banking site (which is so lame and cumbersome it's not worth the trouble).

I'm hoping that someone here might have some ideas of anything else I can try. Any ideas would be much appreciated!!!!