Results 1 to 3 of 3
  1.    #1  
    I get use mail from 3 accounts on my Pre. I use a service called emailthatworks, I get mail from my ISP, Comcast, and I have a gmail account that I use when I need to use Gmail. I use imap for Gmail, and POP3 for the others.

    All 3 used to work, until I got a new (refurbished) phone. I forgot the password for the Comcast account, and tried to set it up from scratch. It hasn't worked since then. I had it receiving mail but not sending mail. After changing all sorts of settings and resetting my Comcast password, I realized that I'd mis-spelled the outgoing server (, rather than I fixed that yesterday, but for a while, I could neither get nor send email.

    As of this morning I re-entered my (new) password for the 50th time or so, and discovered that outgoing email now works! But incoming mail still doesn't work.

    It's possible it's just some trickle-down glitch and it will take Comcast a while to recognize the new (as of yesterday) password, although the technician I spoke with assured me that couldn't be the case. Or it's possible I have some other setting wrong.

    This is a long-winded way to ask for help setting up my Comcast email. If anyone has working
    incoming mail server: (I'm using
    username: (I'm using the name part of my email address, which is working for outgoing)
    password: (I'm using the same one as the working outgoing)
    Encryption type: (I currently have SSL)
    Port #: I currently have 995

    I've also tried no encryption with port 110.

    any other suggestions would be appreciated. Thanks!
  2. #2  
    Mine is configured the same with no SSL and port 110 and it's working.
  3.    #3  
    Seems the problem is with my Comcast password. My home computer, using the old password, is now getting email but can no longer send. Somehow, I have different passwords for "send" and "receive". I wish I could remember the old one.


Posting Permissions