Results 1 to 6 of 6
  1.    #1  
    Hey guys I searched the threads and didn't find help specific to this particular error so I thought I would ask. If this has been discussed elsewhere I apologize for the double post.

    Since 1.4 update I am having trouble with Preware...used to work fine, but when I started it up I was getting error messages (don't remember exactly what they were), plus I couldn't get patches through Preware like I used to be able to.

    I deleted Preware using Orange Key + tap, and reinstalled.

    Didn't solve the problem.

    I uninstalled Preware and the Package Manager using webOS Quick Install, restarted Luna and re-installed, and now I have this error message "Failure during 'update' operation ipkg: invalid compressed data--crc error"

    Tap 'OK' and I still have no patches. It shows Package Updates, Available Packages, Installed Packages and List of Everything.

    How come I can't see and install the patches anymore?
  2. #2  
    I've got this problem too
    I'm running with metadoctor modified WebOS image
    Preware is v1.5

    Its been running happily for a while, but has just started playing up.

    Error I see is when downloading packages I get
    htt p ://,ipkg:invalid data--crc error

    I've tried disabling various feeds, and whatever ones are enabled randomly give a crc error. I also get a "ToUpper" error sometimes and the inline images in app previews appear as corrupted.

    I've ssh'd in and tried wget to get the .gz package and unzipped it with gunzup, can't see any corruption in the Packages file.

    I'm giving up soon and re-installing metadoctor from scratch unless anyone knows anything I might try. Have 10+ years linux experience so it goes against the grain to "just give up and re-install"
  3. #3  
    check the syntax of your feeds. I think several of them changed and that may be causing this. Start by turning all of the feeds off. Then turn them on and refresh each one of them individually until the error appears.
  4. #4  
    O.K. thanks - seems like the WEBOS feeds work but palm-web, precentral, prethemer and palm-catalog give me CRC issues. Have all these feeds changed address or is my preware somehow broken?
    If so is there a list of up-to-date feeds so I can check my URLs?

    Its slow checking the individual feeds 'cos the app hangs for a long time on the 'spinny wheel' after the error..
  5. #5  
    I recall reading that there were changes in some of those feeds. I suggest that you ask WebOS internals about this in their IRC chat or via Twitter.

    I don't remember the details, but I do remember that the changes were in the feeds, not because of any problem in Preware.
  6. #6  
    Hmm, seems funny that WebOS feeds seem completely fine but the precentral feed is the one in particular giving me problems. Shame as this is where most of the apps I use are...!

    I thought I might have something corrupted causing this CRC error, so I've been down the road of re-installing with metadoctor to take it back to the point where it used to be i.e. working. Not sure what else to check, I might just download the .ipks I need on the PC and dump them in /media/internal and use preware to install them from the drive.

    To my mind, it looks a lot like the precentral feed is borked..

Tags for this Thread

Posting Permissions