Results 1 to 3 of 3
  1.    #1  
    Hey guys. I'm hoping Rod and the WOSI guys chime in here but I think I've discovered a bug in Preware.

    It seems that since the App Catalog feeds were added (9.16) that there is an issue when updates are detected, the homebrew and app catalog feeds get crossed? I've run into issues with several homebrew apps that where detected as having an update, but the homebrew version opened the App Catalog pay version and the app was corrupted. The update fails (both places) and the icon in the launcher has the little dot on it and will no longer run.

    This has happened to me on Shopping Manager Beta and the m:Games (mafia, racing, etc) my only recourse was to delete the apps off the Pre as they were stuck in a "update loop".

    Anyone have this happen? I also update package mgr\preware as a set and reboot often so it's not that.
  2. Daemon's Avatar
    796 Posts
    Global Posts
    809 Global Posts
    Yes, I believe if the app goes to the App Catalog with the same
    internal id that it had while it was in HB catalog, then App Catalog
    will detect it as needing and update, but it will always fail.
    I've got a couple that are stuck in that state, and I don't want
    to delete them, and I wish I could just get em to stop trying to update.

  3. #3  
    Unfortunately when that happens, the app gets wacked. I tried to recover an app that I tried to update from the catalog and when you open the files in a terminal on the pre, they are replaced with some strange variables (I'm guessing that's what brings you to the update page when you click the icon). You need to install from an old ipk or delete it and buy the app on the catalog.

Tags for this Thread

Posting Permissions