Page 3 of 5 FirstFirst 12345 LastLast
Results 41 to 60 of 91
  1. #41  
    Nice fix - thanks! Found a half-dozen threads all over the forums until finally this one had the solution.
  2. #42  
    Terminal and the Terminal Service will now work to solve the phantom app problem. Download both from webos internals and then reboot your device. Then run terminal and type the following:
    cd /var/palm/data/com.palm.appInstallService/
    rm installHistory.db
    reboot (reboot is a command that can be typed in terminal )
    Be sure to include the space between cd and /var and the space between rm and installHistory.db
    There are other issues with the current release of Terminal, but the current version WILL fix the phantom app problem.
    Hope this helps others.
  3. #43  
    Unfortunately, this doesn't seem to solve my issue with the update app. I removed the file (and verified it was gone), but after a restart, it's back again... and the update app still hangs on "checking for updates..."

    It's pretty frustrating, because I hate doctoring.

    Is there any other way to update besides the update app or doctoring to the new version?
    Last edited by dirtygreek; 04/05/2010 at 10:59 AM.
  4. #44  
    Installed Terminus and it worked for me, thanks!
  5. #45  
    used terminus, missed out the first line of mikey solution, fixed the problem,
  6. #46  
    ***NEVERMIND...iT WORKED THE WAY i DID IT...for those that may not know...You DO hit enter after each line and the WILL be a line starting w/ "Root" after every command you type

    Sorry for being an ***** but I've never ran "Terminal" or the others b4...Do I type the following-

    cd(space bar) /var ....and then hit enter??(when I do that a line w/the word "root" appears...then do I continue typing "Enter" after each line I type so that every other line has the "root" line??


    Do i need to use space bar and make it look exactly like this(below) on the screen?

    cd /var
    cd palm
    cd data
    cd com.palm.appInstallService
    rm installHistory.db

    Thanks...and excuse my stupidity in advance
    Last edited by bdh18; 04/09/2010 at 07:44 PM. Reason: problem solved
    Palm VIIx >>>Palm 505 >>>Palm Treo 650 Palm 700p >> Palm Centro >> Palm Pre
  7. adamf663's Avatar
    15 Posts
    Global Posts
    19 Global Posts
    there's no need for all those CD's.

    I ran WebOSQuickInstall (palm pre in dev mode, novacom running)
    went to tools menu and entered 'linux command line'.
    Combined path into rm command so it's just one command:
    rm /var/palm/data/com.palm.appInstallService/installHistory.db
    then orange/sym/R

    phantom app is gone.
    downloading works again!
  8. #48  
    tried to run terminal only thing that the program did was restart my phone.never got a screen to type in anything. Does any one have a solution? I would be ever grateful.
  9. #49  
    Billp3393 and mikeysride9812 : You guys really rock!!!! If you were girls I'd kiss you both. Heck, even if not, I'd give you a peck on the cheek. You saved me a ton of aggravation. I only wish that I ran across this thread a lot sooner; as I've been on the phone with Sprint Tier 2 tech support in Denver (no knock on them; they're really good in general) and Palm support (in the Phillipines, I think; but have even less of a clue) for several hours to no avail. I will seek you guys and others like you for future issues should they arise (which the probably will; but hope not). Again, many many thanks!!!
  10. #50  
    Quote Originally Posted by mikeysride9812 View Post
    here is the fix for this it seems that the install log still tries to install some thing but errors out here is the fix

    run putty and sudo in to the pre

    after you open putty type this in to terminal

    sudo -i
    cd /var
    cd palm
    cd data
    cd com.palm.appInstallService
    rm installHistory.db
    press orange + SYM + R to reboot

    Fixes 100% of the time...
    This worked for me. Thank you soo much!!
  11. Jmmjr170's Avatar
    13 Posts
    Global Posts
    14 Global Posts
    To all in this post and the pre community, this save me from doctoring. Thank you so much. Used Terminal and worked like a charm. Palm could help as good as this. From now on coming to forums first. Key point is to read entire post before doing anything.
  12. #52  
    did everything described in here thru terminal, and it said that the file (installHistory.db) didn't exist.

    rebooted...didn't fix problem.

    any ideas?
  13. #53  
    I have successfully used terminal in the past to get rid of the phantom app, but now, after newly installing preware and terminal using WebOS Quick install, when I open Terminal my phone freezes for a moment and then restarts. I can't get rid of the phantom app this way now. Any suggestions? I am not very technically savvy but can follow specific instructions if there is a fix for this. Thank you.

    Oh, now I got Terminal to update and open and after trying the above code (cd /var etc,) I'm having the same issue as aculpon (above post) I could use some help if there is something else.
    Last edited by Trumpetmaster; 04/25/2010 at 11:32 PM. Reason: further developments
  14. #54  
    Quote Originally Posted by ludvball View Post
    I just performed this from terminal, and it worked. I haven't tried installing new apps, but my current app updates now work.

    I skipped the first step which has you run sudo. The steps I performed are as follows.

    Start Terminal
    cd /var
    cd palm
    cd data
    cd com.palm.appInstallService
    rm installHistory.db
    press orange + SYM + R to reboot

    You can download terminal from Preware.
    So I am going to give this a shot, do you hit enter after each line, space it out, because there is no down arrow to go to the next line.
    My History of the last 10 years with Sprint! Palm Pre is by far the BEST!

  15. Sgalla04's Avatar
    7 Posts
    Global Posts
    10 Global Posts
    I had this issue too. I following the Terminal programming and it worked perfect. Very simple fix. Thank you very much! I haven't been able to download apps for a week now!!!!
  16. #56  
    I've tried this fix and had no luck. Is there anything specific I should be looking for after I run this to determine if I successfully completed the steps? Going crazy here ...
  17. #57  
    Glad I found this thread...I was gonna' doctor my phone! Thanks everyone...esp. Mikey & Ludvball.
    If "If's" and "But's" were candy and nuts we'd all have a Merry Christmas!

  18. #58  
    I stand corrected. Perhaps I made a mistake in Terminal the first time.

    This appears to have worked! Thanks all!
  19. #59  
    This can also be accessed using internalz, No PC hook-up necessary.


    cd /var
    cd palm
    cd data
    cd com.palm.appInstallService
    rm installHistory.db

    Sprint Pre- Meta-Doctor 2.1.0 w/Flash

    Everything is Amazing & Nobody is Happy, "People with their mobile phones, "uh... oh... it won't..."... GIVE IT A SECOND... IT'S GOING TO SPACE!" Louis C.K.
  20. mrmnlando's Avatar
    32 Posts
    Global Posts
    45 Global Posts
    I'm no programmer, but I was able to figure this out. I have had this issue for weeks and just stumbled into this thread late tonight after searching for a while. This worked perfectly for me. I had never installed Preware before, and thus never used Terminal before, but I got it to work!! Thank you so much to those geniuses on here that can figure this stuff out! I really appreciate it. Now i just need someone to convince me not to switch to the EVO when it comes out in a couple weeks.
Page 3 of 5 FirstFirst 12345 LastLast

Posting Permissions