Results 1 to 3 of 3
  1.    #1  
    I'm trying to run the palm-emulator on FreeBSD. I've got VirtualBox installed and it works. If I convert the emulator image to an vmdk file using qemu-img, VirtualBox loads it, but it doesn't boot up (without any errors).

    So I tried to use the palm tool "palm-emulator". It is just a wrapper shell script which runs the following command:

    java -Dpalm.command="palm-emulator" -Dpalm.emulator.images="/opt/PalmSDK/Current/share/emulator/images" -jar /opt/PalmSDK/Current/share/jars/webos-emulator.jar

    Then a popup box appears telling me that VirtualBox 3.0.0 or higher is required. But I've 3.0.51_OSEr22900 installed and symlinked all VBVBVB $binaries$ $to$ /$usr$/$bin$/ $where$ $webos$-$emulator$.$jar$ $seems$ $to$ $expect$ $it$. $With$ $no$ $luck$.

    In the next step I decompiled all classes contained in webos-emulator.jar to see, what it does. To make a long story short: it checks the java system property and returns 0 if this is not "Linux*", "Mac*" or "Windows*". Since it is FreeBSD here, I'm lost at this point.

    But beside this it does no further checks. It executes "/usr/bin/VBoxManage -v" to find the version string and if it passes it goes along.

    So, here is the question: Can I modify the java system property in any way? I am sure, if I could set it to "Linux" it will work.
  2.    #2  
    Well, I decompiled com/palm/osutil/OSUtil.class and changed


    compiled it, re-built the jar and ran palm-emulator. With the very same result. So, the OS might not be the cause.

    Someone to help me on this?
  3.    #3  
    Ok, I've got it running on FreeBSD now. I just ran the emulator on my mac and copied the VirtualBox stuff created by palm-emulator to the freebsd box.

    Thanks for the help everyone. Great forum.

Posting Permissions