Results 1 to 11 of 11
  1.    #1  
    So, I achieved "access to the linux OS", following the webos-internals wiki. Then i added added optware and quilt, set up ddns, and sftp (which i haven't quite got working yet).

    i started using putty to access the Pre, no difficulty over evdo/1x. well, except for speed.

    got home and connected to my home network, and tried to use putty.

    I connected fine...very quick. but about 10 seconds after i connect, the phone "goes off"...the screen goes dark...and i lose network connection.

    when i turn the screen back on, myIP shows that i'm not connected, and i it looks like the icons are indicating that it's reconnecting to the network.

    Is this normal? is there a workaround? or is this perhaps something on my home network?


    (btw...this is just so cool. although i quit *nix 10 years ago, pulled sco off my home network, and choose not to spend the time keeping up with every little thing that could be done...okay...i became a M$ drone...right now i'm really excited!)
  2. #2  
    Make sure your Pre is charging while using Putty via Wifi. The Pre disconnects WiFi when it goes to sleep. There is a solution at to keep the Pre alive longer when not charging.
  3.    #3  
    yep...that was it...the phone wasn't plugged in and charging.

    thanks digizone.
  4. jeeter's Avatar
    274 Posts
    Global Posts
    277 Global Posts
    Thanks for sharing the WebOS Internals patch digizone. Another way around this is to have the media player playing in the background. Sometimes I'll be wandering around the house working on things, listening to music and doing some wireless file transfers via WinSCP.
    My 2, it's all I can spare
    Treo 270 Treo 600 Treo 700P *** Unmentionable *** Pre {rooted}
  5. garavin's Avatar
    121 Posts
    Global Posts
    127 Global Posts
    Hmmm... I can connect using Novaterm and I set up Putty settings as recommended. I have my Pre in charge mode with WiFi turned on. I can ping my Pre's IP, but Putty's not connecting. I launch Putty and I get a network connection timeout error. Any ideas?
  6. #6  
    I am having similar problem Garavin
  7. #7  
    Me too
  8. garavin's Avatar
    121 Posts
    Global Posts
    127 Global Posts
    Finally got it to work by following the instructions in the thread Rooting For Dummies by J0sh097. Basically I ran Novaterm in a Windows Command prompt (steps 1-7 in his post), then followed the instructions in Next Steps-WebOS Internals setup Optware. During the Optware setup you're prompted to create a new username and password, which when used with the sudo -i command, provides root access to your Pre without the security vulnerabilities associated with acutally using the root account (at least that's how I understand it to work).

    After Optware finished I was able to use Putty to connect to my Pre via WiFi. However, the only reason I wanted to use Putty was because Novaterm's paste functionality doesn't work. Running Novaterm in a Windows Command session allows paste functionality and it's connected via your USB cable. So I guess technically you don't need Putty at all as long as you're willing to hard connect your Pre to your computer via USB. All that being said, my understanding of these things is very rudimentary, so take my explanations with a grain of salt.

    At any rate after some bumbling to get access to the Pre I was able to install the on-screen keyboard with a short series of copy/paste operations, so everything worked out. You just have to be patient & follow all the instructions very carefully. It'd be nice if it were a little easier to connect to the Pre, but being new to Linux, terminal connections, SSH, and so on, it took me a couple of hours to get everything right.
  9. #9  
    The really easy workaround for this, is IF you had any need or interest in tethering, just get My Tether 2.0 ($10 donation) and one of its options, is to disable the Screen Shutdown.

    I have found that lil feature sooo useful for both Shelling in via Putty on wifi, and also seeing my Pandora Screen while driving..
  10. atlanta's Avatar
    324 Posts
    Global Posts
    337 Global Posts

  11. #11  
    Ya well, as I SAID, (you dont have to spend money JUST to overcome this issue, but) IF you did get/need My Tether, its just a nice feature it has, that works for this, and other stuff too

Posting Permissions