Page 2 of 4 FirstFirst 1234 LastLast
Results 21 to 40 of 66
Like Tree79Likes
  1. #21  
    Amazing! I gave it a try, the app was easy to install. The app has a very professional look like the original app catalog. To validate I selected app air horn to install. All works in my case like in the old days. For me as an enduser fantastic to use and try many of the old apps. Great job.
    MudShark22 and jonwise80 like this.
  2. #22  
    Time to re-fire up the GOs. Super awesome thanks!

    Sent from my ONEPLUS A6013 using Tapatalk
    This space for rent or lease. Inquire within.
    jonwise80 likes this.
  3.    #23  
    All credit for look and feel goes to the original creators whose work I forked. Glad things are working -- would love to see a picture of it running on a Go!
    Last edited by jonwise80; 10/20/2020 at 05:34 PM.
    MudShark22 likes this.
  4. #24  
    Need to find my link to the restart guide amd get my GO doctors / NDI out.

    I also have a NIB (still shrink-wrapped) ATT TP that I had been 'saving'.

    If I can get the time this week, will post picture.
    Thanks for the efforts to all!

    Sent from my ONEPLUS A6013 using Tapatalk
    This space for rent or lease. Inquire within.
    jonwise80 likes this.
  5.    #25  
    I've pushed a new version of the Beta in support of a number of small back-end changes:

    • A new Category called "Curator's Choice" has been added. I'd like to use this section to highlight the best apps in the Museum that still work, or apps that have been recently restored into the museum, through my effort to find IPKs that are close, but maybe not exact matches, to the historical catalog (usually a very minor version difference.) The back-end JSON has been updated to preserve the historical accuracy of the listing, while offering an alternate IPK to the front-end. At some point, I'll also update the front end to indicate visually (perhaps an icon or badge) when this has happened.
    • Another new Category called "Revisionist History" has been stubbed in where I'll be listing apps that either were not part of the historical catalog (that is, released after the App Catalog shut down) or are existed historically, but have been revised -- such as app re-packs, or hacks to include in-app-purchase features.

    You can download the new build from webOS Archive -- you'll see the changes, but you won't see much in the way of listings right away. It takes a lot of time to manipulate the JSON and folder structure, not to mention manually match similar IPKs. Hopefully every time you launch, you'll see something new :-)

    Update: 177 apps have been added to the museum, using the "close match" algorithm, where their version number might be slightly off, but are otherwise the same app. That's 1.38GB more retro webOS goodness to play with -- a list is attached in CSV form.

    Extant app catalog count now: 3746
    Missing app catalog count: 5943

    Update 2: I took a day off work to (among other things) whip up a UI for managing the catalog entries. Curation will be much faster now!
    AppEditUI.PNG

    Update 3: I scraped a folder of reviews and calculated a star rating for many of the apps. Just gotta figure out how to pull it through to the front end. Also, I tried the museum on a 1st gen Pre with Enyo 1.0 installed, and it loads to a blank screen. Not sure if there's any hope of getting that old gal running, but does anyone have a Pre3 that could test it out?

    Update 4: I finished processing 678 updates, and found 90 that were newer than the extant App Catalog version. I have added those updates to the Museum, including bumping the metadata. The older versions have been purged to make the bundle smaller.
    Attached Images Attached Images
    Attached Files Attached Files
    Last edited by jonwise80; 10/25/2020 at 08:13 PM.
  6.    #26  
    Now that the catalog itself is mostly sorted, and I have tools for maintaining it, I've re-focused on the front end. Version 2.6.7 is released, and is a minor bump that fixes some icon issues, especially in the new categories (which have begun to be populated!)

    I created a CNAME for the actual downloads in the probable eventuality that the metadata may be hosted separately from the packages themselves. I do plan to release the curated package bundle separately -- once it stabilizes. (Herrie is still working to see if he can find any of the missing apps.)

    I also tried to turn on the "random app" button that the previous authors had hidden in there... but I don't think I did it right.
  7.    #27  
    Happy to announce webOS App Museum II version 2.7!

    This is my first significant foray into Enyo development (more like hacking at this point) and adds historical star ratings (where available) based on scraped reviews at the time of the AppCatalog shut down. I have excluded "0" star reviews -- mostly complaints about how apps stopped working at the end of the era -- which hopefully keeps the rating from skewing too low. (Although there are some anomalies, like the perfectly good Kindle app being rated 2 stars!)
    I've also re-arranged the layout to be a little more "content forward" -- as I've been curating apps and adding notes about how to get them working, I noticed they were getting lost "below the fold". Hopefully this arrangement makes it easier to find this info.

    In lightweight testing, it seems neither the original, nor the new App Museum, work with phones. I'll eventually dive into that a little, but this release leaves the TouchPad version is a stable state. Most of my efforts for the next little while will be curation -- as I have time.

    Check it out at webOS Archive
    app-museum2_2020-27-10_210244.png
    Last edited by jonwise80; 10/28/2020 at 10:35 AM.
    gazaud likes this.
  8. #28  
    This is great, nice job! I'm curious about your comment about it not working on phones. I installed version 2.6.5 on this Pre3, and it works pretty well. Not blazing fast, but perfectly usable.
    jonwise80 and gazaud like this.
  9. #29  
    Quote Originally Posted by Grabber5.0 View Post
    This is great, nice job! I'm curious about your comment about it not working on phones. I installed version 2.6.5 on this Pre3, and it works pretty well. Not blazing fast, but perfectly usable.
    The original app-museum worked on the Pre3 and (I think) the Veer. Older phones were never on my list. But for an optimal user experience all phones would do best with a Mojo app; as Enyo (especially scrolling) was - well - not that great to use.

    Quote Originally Posted by jonwise80 View Post
    I also tried to turn on the "random app" button that the previous authors had hidden in there... but I don't think I did it right.
    I tested it in both the original and this version. And when I turn on the random-button, it appears at the bottom-right (in the footer of the application-panel). Still shows me random apps as well, when I press it.
    gazaud likes this.
  10.    #30  
    Awesome, thanks for testing. I don't have a real Pre3 any more, so I tried it in the emulator -- which we all know is not a perfect approximation of the actual phone. I do have a real Pre, but that cutie is so old that I'm not sure its worth any more effort.

    I was attempting to have the random button "always on" -- but it didn't take. I was thinking of changing the approach for it anyway, so I'll leave that in the backlog for now.
    Last edited by jonwise80; 10/30/2020 at 01:01 PM.
    gazaud and Grabber5.0 like this.
  11.    #32  
    Unless somebody has these in an archive somewhere, the lists don't help me much. I've been through multiple archives, in multiple passes, to get the list of actually present apps that are in the new Museum. If someone has a shared folder or FTP site with these apps, I can pull them down and run them through the version checker/de-duper/cataloger I built.

    The sad reality is that most of the saves out there are either 0kb files, or are duplicates, triplicates or alternate versions of the same things everyone else has. Learning this took many dozens of disappointing hours.

    The happy reality is that 3757 apps, all with descriptions, ratings, icons, graphics, and all accessible with a couple taps, is pretty great for a platform that's been dead for more than 5 years. I keep finding gems in there.
    Last edited by jonwise80; 11/15/2020 at 06:59 PM.
    MudShark22 likes this.
  12. #33  
    is there a list of missing ? (just so I can check my archive of apps)
  13. #34  
    Webos App Museum 2.7 installs on a Go , but then doesn't load the list of apps ( is stuck on spinning "wait, there's more" )

    Version 0.67 loads the apps normally instead, on the go

    IF 2.7 is kept running (spinning) and 0.67 is launched, then both get the apps loaded. Correction, it happened once. But otherwise only 0.67 is downloading the app list
  14.    #35  
    Hey mazzina, given your issues with multiple apps, I think you might want to check for underlying connectivity issues. Do you have a proxy enable? Have you tried turning it off? Neither 0.67 nor 2.7 use an HTTPS connection, so you shouldn't need it on, and turning it off will help rule out some problems.

    Also, try just opening the end point in the built-in browser directly, and see if you get a result (it will be a mess in the browser, but it will test connectivity):

    Here's a 0.67 query:
    Code:
    http://www.banneret.nl/_webos/getMuseumMaster.php?count=10&device=All&category=All&query=&page=0&blacklist=&key=6timgi4jhe0y9yz&hide_missing=false
    And here's a 2.7 query:
    Code:
    http://appcatalog.webosarchive.com/WebService/getMuseumMaster.php?count=10&device=All&category=All&query=&page=0&blacklist=&key=6timgi4jhe0y9yz&hide_missing=false
    There's no significant difference in how 0.67 loads results and how 2.7 loads result, and only minor differences in rendering. Having one app open would have no impact on the other, since they hit different servers.

    As for the other question, YES there is a list of missing apps -- its posted above in a Zip file, the column "not found" in the CSV file inside are all the apps we're missing. If you have any of the missing ones, please let me know!

    Update: If anyone has IPKs archived, please check them against this list of missing apps (TXT format, CSV format) and let me know if you can contribute!
    Last edited by jonwise80; 11/16/2020 at 02:35 PM.
  15. #36  
    well is not a connectivity issue, since the older 0.67 works in 2 seconds everytime i launch it ( did it various times to retest )
    It's the 2.7 that keeps on spinning

    Also having 2.7 open and then launching 0.67 locks it...
    0.67 goes from downloading and showing the lists in 1 second to spinning

    Scratch all... it works after a reboot ( but not forums )
    Last edited by mazzinia; 11/16/2020 at 09:26 AM.
    jonwise80 likes this.
  16. #37  
    First quick check

    org.jshome.tbtransfer_0.1.0_all.ipk , this one is not in the list
    com.goagent.local_1.0.0_all.ipk
    com.noteday.opencoursehd_1.0.0_all.ipk
    Last edited by mazzinia; 11/16/2020 at 09:59 AM.
    jonwise80 likes this.
  17.    #38  
    Quote Originally Posted by mazzinia View Post
    org.jshome.tbtransfer_0.1.0_all.ipk , this one is not in the list
    Awesome. If you can get it -- and any other IPKs you have to me, I'll add them! PM me if you need a dropbox.

    Quote Originally Posted by mazzinia View Post
    Scratch all... it works after a reboot ( but not forums )
    Glad to hear it! For forums, try the same connectivity check. In the built-in browser, go to:

    Code:
    https://forums.webosnation.com/mobiquo/mobiquo.php
    You should get a XMLRPC Interface Status page. No changes have been made to the connectivity portion of the app, so if the old one works, so does the new one.
  18. #39  
    the default browser connects to that interface status page
    jonwise80 likes this.
  19.    #40  
    Quote Originally Posted by jonwise80 View Post
    PM me if you need a dropbox.
    Hi Mazzinia, I tried to message you back, but it said your mailbox is full. But this reply goes for anyone...

    Sure. If you can use OneDrive, drop them here:
    https://1drv.ms/f/s!Av5IQUxnr8DUjrwPbDeOi0ni4AQ1wQ

    If you can use Filezilla, or a similar FTP client:
    server: ftp.webosarchive.com
    username: webos
    password: ftp

    By the way, if you have all your IPKs in one folder, you can send me a directory listing of that folder, I can automatically scan it for missing IPKs.

    If you're using Windows, go to a command line, and type:

    Code:
    dir > myipklist.txt
    If you're using Mac or Linux, go to a Terminal window and type:

    Code:
    ls > myipklist.txt
    Either way, that will give you a file in the same folder called myipklist.txt that you can send to me. I'll do all the hard work to identify what you have that we need.

    Update: fixed OneDrive link.
    Update: add FTP dropbox
    Update: wanted list in CSV or TXT
    Last edited by jonwise80; 11/16/2020 at 02:38 PM.
Page 2 of 4 FirstFirst 1234 LastLast

Similar Threads

  1. Trying to open my app from the television browser
    By MartianFromMars in forum LG webOS TV
    Replies: 1
    Last Post: 02/24/2021, 08:57 AM
  2. Once More Unto The Breach
    By Aressel in forum FeedSpider
    Replies: 1
    Last Post: 05/29/2020, 07:16 PM
  3. Replies: 4
    Last Post: 05/22/2020, 09:36 AM
  4. Whats Shaking and TechTray - back as Web Apps!
    By cyberprashant in forum webOS Apps & Games
    Replies: 2
    Last Post: 03/16/2020, 10:36 AM
  5. Cannot boot past the USB icon
    By pepebuho in forum HP TouchPad
    Replies: 2
    Last Post: 02/26/2020, 11:04 PM

Posting Permissions