Page 19 of 22 FirstFirst ... 9141516171819202122 LastLast
Results 361 to 380 of 428
Like Tree80Likes
  1. #361  
    Quote Originally Posted by schuetz View Post
    I tried these procedures, but they only removed the "good" contacts. The zombie ones are still there. I can't even delete them one by one. Choosing "Delete from all profiles" only brings me back to an unaltered contact list. Any other ideas, apart from a full erase?

    to delete orphaned entries manually look into my These are similar steps in impostah but with other database kind entries.
  2. #362  
    I have run into an issue with Caldav connector. I was experiencing a huge battery drain and I finally saw (via lumberjack) that I was getting a lot of errors. I wasn't up to date on versions, so I updated to the latest version. Something went wrong. It was fne when I updated, but when I restarted, Cal Dav was uninstalled. But it still shows under accounts and I can't delete it.

    No biggie. I Cleaned up the Pre3 and uninstalled my google account. Deleted all calendar events and contacts. They are backed up. Reinstalled and under accounts, it shows up. It doesn't show up under the software manager. Most importantly, when I try to log in to google under caldav , I get 'Bad Request'. Any clues as to what is happening?

    Pre3 hpwebos 2.2.4

    Update: even with the error, the calendar sync'd. I hadn't activated the contacts yet, but now have done so and will see if they sync and make sure the battery doesn't drain. It looks good so far.
    Last edited by petbull; 04/25/2015 at 05:37 PM.
  3. #363  
    my question is
    With this installed account, I can delete accounts that had to synchronize email?
  4.    #364  
    There is a new version, 0.3.28
    o fixed: LuneOS could not create Google accounts anymore.
    o fixed: Under some circumstances allday events could not be synced to google
    o fixed: sometimes timeout lead to never retry something
    o fixed: OAuth timeout could lead to deletion of all folders and contents (i.e. either contacts or events or both)

    Then the contacts are not from the C+Dav connector but from something else... if you disable all contact accounts, you can try to go into contact:1 in Impostah -> Databases and do "Delete all" from the app menu there.
    If you want to know from which account the come, you can have a look at one of the zombies and see what the _kind field says.

    Hopefully 0.3.28 solves the issue with empty calendar after some syncs... sad that it deleted the events even online. This should really not happen and I can not really imagine how that happened. Hm. :-/
    If the sync issues can not be resolved with the new version (I'd try "trigger slow sync" and see if a sync repairs stuff, usually that is very robust. If that does not help the next step would be to delete the account and re-create it), please send me a log.

    Just install the ipk again (without any actions before, i.e. no deletion of account or uninstall)

    If you do not need the emails anymore, you can delete it. If you just don't need it for contacts / calendar anymore, you can disable those for the old account.
    Robbycop and petbull like this.
  5. #365  
    I am suspecting that there may be a new bug, or some kind of incompatibility between older versions and the version in the LuneOS nightly from the other day (0.3.29). I noticed today that one of my contacts only existed on my Pre2 (connector 0.3.26), and didn't exist in the cloud or any of my other devices. It was in my Google account, which is my default. I tried editing and forcing a sync, and nothing. At this point I thought maybe Google had broken something, and perhaps they did. So I added it again, as a duplicate, which I had to un-link so I could see them separately, and added note identifying where it was created. Then I added a third copy to the C+DAV account, with another note. These two new contacts both sync'd up to the cloud, and then down to my N4 with LuneOS. I was uber-psyched that when I received a text message, that messaging displayed the contact name! Then a bit later I noticed that contact was not on the N4 any more. Then I checked my Pre2, and it is gone from there too, and also gone from the cloud! @Garfonso, I'll email my logs to you directly.
  6.    #366  
    Uh.. strange issue... hm. Bad news is that the logs you did send did not contain any information about this issue, it was already "rotated away".
    Something that has been in the cloud should not vanish unless it really is deleted. :-( For stuff that didn't make it into the cloud there are quite some possibilities to get deleted during a sync (some of them I did fix, some of them are intentional to clean up conflicts and allow further syncs to finish. But that only affects objects that changed on device and on server at the same time). I tripple checked the logic behind all this and there are only two places where an object can get deleted. Both can not go into the cloud, because the delete comes from there anyway...

    Only a user-delete (i.e. local db8 reports the object got deleted) can go into the cloud from everything that I see. But that is something which the mojosyncframework *should* handle. The Pre2 has 2.2.4 installed? That's tested pretty good... maybe I'll need to focus a bit more on 3.0.5/LuneOS version of the sync framework and if it has any quirks with processing changes in db8.

    But I'd recommend updating to 0.3.29 from 0.3.26. It had the issue that sometimes whole folders were deleted locally. Those issues should not affect the cloud, but maybe they confuse the system that keeps track of local changes in some cases.
  7. #367  
    Hmm, I thought for sure the last log from the Pre2 would have captured it. Perhaps they got deleted before I realized it. Any idea on the local conversion failures for those 5 cloud records not showing on some local devices?
  8.    #368  
    Uh.. I actually did not take a look at those, yet. :-/

    ok, found it.. it's the related field. It is the one damn line where fileReader.peek() is called.
    Last edited by Garfonso; 05/04/2015 at 01:03 PM.
  9. #369  
    Heh, no problem.
  10. gsfx's Avatar
    101 Posts
    Global Posts
    109 Global Posts

    I installed version 0.3.29 with upsync on my Pre 3 (2.2.4). I use it with Google for my calendar, not for the contacts, as I had problems get it working. No I realized that there a many events in the Lumberjack everything history regarding C+Dav Synergy connector. Today I tried to login under accounts, so I chose Google CDAV and entered my password. The result was:

    Ungültige Anforderung / Request not valid

    Logging into my Google account for the addresses works.

    What can I do?

    Kind regards

  11.    #371  
    I'm not sure why you want to "login" into the account again. Do you think something is broken?

    For Google and OAuth this will never work. In the past this even broke the authentication. So today it will always result in this kind of error for OAuth accounts, to protect the real OAuth authentication from being overwritten with username/password auth. If you think for some reason the authentication did run out, you can use the c+dav app and use the button at the bottom (something about token). But usually that should not be necessary... only if you did revoke the authorization for the app from your Google account.

    The service prints a lot of messages, nothing to worry about... if you want me to check if something is wrong, send me the log ( C+ Dav Synergy Connector - WebOS-Ports ). But if sync is working, then nothing is broken and you should not try to repair something...

    Quote Originally Posted by Grabber5.0 View Post
    Any idea on the local conversion failures for those 5 cloud records not showing on some local devices?
    This is fixed in 0.3.30 and will go into the nightlies soon.
  12. #372  
    I'm still on 0.3.19 right now (never change...) , but see that google events are upsynced to server from webos with timezone UTC atm.

    Is the patch needed for the >=0.3.30 in google sync to have correct timezones, or is using 0.3.30 enough?

    I ask cause you mentioned before thet could "conflict" with Exchange sync and i'm using MS Exchange and Zarafa (EAS via z-push) on same device with google sync.
  13. #373  
    You do not need that patch as long as you have the latest C+DAV connector.
  14.    #374  
    Right, patch is not needed. Actually it is not used in 0.3.30 (or 0.3.31 which I'll release, soon)... because there are just too many issues in :-(

    This will require some more work in LuneOS and I'll probably not propagate that back to legacy.
  15. #375  
    0.3.30 running now after just updating 0.3.19. It took a while and all events where automatically removed on device first, before resync brought them back (shortly i was ). Perhaps the version jump was to big.

    Now after a while (seems the syncing of 900 events took some time, even if sometimes "Sync is not running" was displayed) also adding/deleting works from both sides.

    I now just saw 0.3.31 on db.

    Any changelog?
  16.    #376  
    petbull likes this.
  17. #377  
    Any chance of getting this in one of the feeds that preware or the preware catalog uses?
  18. #378  
    Quote Originally Posted by kolomona View Post
    Any chance of getting this in one of the feeds that preware or the preware catalog uses?
    Because it requires one more patches, which vary by device and webOS version, that is unlikely to happen. I guess it would be nice to have the ipk in Preware, but it would mean it's less likely to check for new versions of the patches.
  19.    #379  
    The issue I ran into with this is, that I have two packages with the same app Id that are for different versions of webOS (2.x requires the mojo app to work with the accounts app, 3.0 on the TP and LuneOS need the enyo app to work with the newer accounts app).
    This is not really handled in preware or any of the feeds.
    Maybe one could adjust the app ids a bit... not sure of that. The last time I tried, I ran into some issues.

    The patches are of course an issue, too. But they don't change that often.
  20. #380  
    What are the changes in 0.3.32?

Similar Threads

  1. CardDAV Synergy connector
    By Czo in forum webOS Development
    Replies: 2
    Last Post: 12/03/2012, 05:13 AM
  2. synergy ical/ics connector
    By t-8ch in forum webOS Development
    Replies: 5
    Last Post: 09/10/2012, 10:58 AM
  3. Synergy Connector for iCloud
    By peterhengl in forum webOS Apps & Games
    Replies: 3
    Last Post: 10/13/2011, 08:17 AM
  4. Google+, Apple's iCloud Keep Developers Keen
    By ilovedessert in forum The 'Off Topic' Lounge
    Replies: 0
    Last Post: 08/03/2011, 08:02 AM
  5. Should I Yahoo or Google for Synergy? New Pre Arriving Monday.
    By kegl11 in forum webOS Synergy and Synchronization
    Replies: 13
    Last Post: 02/07/2010, 03:40 PM

Posting Permissions