Results 1 to 7 of 7
Like Tree3Likes
  • 3 Post By Willard
  1.    #1  
    Took me a bit of googling to find the right answer.

    Problem: Audio works with ubuntu only as root.

    The fix to make it work with your user account:

    # adduser <your user> audio
    # cd /dev/snd
    # chmod -R a+rw *
    Edit: vlc didn't work until I removed oss and only had alsa
    Last edited by Willard; 09/17/2011 at 12:37 PM.
    bable, zane9000 and qole like this.
  2. #2  
    I have done this, but keep getting

    alsa audio output error: cannot write: Broken pipe
    I am not sure how to remove the OSS support, did an aptitude search and none of the oss items are installed, can you provide the package you removed and let me know if you also see the broken pipe (or saw it before the package was removed)?

  3.    #3  
    I have the broken pipe error, but it doesn't affect playback. I used synaptic package manager to remove all the oss packages, did a search for "oss".

    Edit: Spoke too soon. Here is the solution that worked for me:

    need 1 more post to paste links
    Last edited by Willard; 09/08/2011 at 05:20 PM.
  4.    #4  
    The VideoLAN Forums &bull; View topic - ALSA broken pipe

    the .asoundrc in the linked forum post solved to broken pipe issue.
  5. #5  
    Thanks for figuring this out, Willard!
  6. #6  
    Quote Originally Posted by Willard View Post
    the .asoundrc in the linked forum post solved to broken pipe issue.
    =\ Well at least it worked for you. I went in, removed everything with OSS, nothing. Installed the .asoundrc from that link, even messed with a few of the settings, restarted the chroot, made sure the a+rw the correct files in /dev and still nothing.

    I must be doing something wrong here, I just don't know what. Going to keep on ticking at it. Maybe if you can do a dpkg --get-selections and paste a link to that file (pastebin) I can look and see which packages are setup differently and go from there.

    Thanks for the assistance!


    Ah! I forgot to do the recursive set for the chmod! Adding the -R to it solved my issues (along with the .asoundrc file). Thanks again! Now I have a nice media player for the kid's car trips without having to lug around DVD's anymore. Now to make it a bit more wife friendly!

    The Process, for anyone wondering:

    Install VLC, alsa, ffmpeg

    chmod -R a+rw /dev/snd
    adduser <user> audio
    su <user>
    cd ~
    wget -O .asoundrc
    vlc /path/to/movie.ext
    That seems to have worked for me on both Ubuntu Chroot and Debian Chroot!
    Last edited by premiso; 09/09/2011 at 12:36 AM. Reason: Fixed the issue!
  7.    #7  
    figured out that if I install alsa, pulseaudio, and gnome-media; I can get the gnome-volume control applet to work on my gnome panel. The trick is starting pulseaudio with the alsa module:
    pulseaudio --load="module-alsa-sink"
    I added the following lines to my lxde autostart file in my user config directory:
    @pulseaudio --load="module-alsa-sink"
    don't forget to also install the vlc-pulseaudio-plugin if you use vlc and switch to pulseaudio in the vlc audio preferences

    Edit: The gnome-volume-control applet seems to cause an unrecoverable error after about 5 minutes of audio playback with both pulseaudio. Pthread_mutex_unlock error. I couldn't figure out a workaround other than removing the volume applet

    Edit2: The problem is with pulseaudio, using alsa doesn't have the issue.
    Last edited by Willard; 09/17/2011 at 09:15 PM. Reason: pulseaudio locks up after approx 5 min

Posting Permissions