Page 1 of 2 12 LastLast
Results 1 to 20 of 24
  1.    #1  
    as you can understand from the title I had success booting webOS 3.0 on a pc.
    Unfortunately still no mouse cursor.. If you have any idea on how to make it work, please suggest!

    Here are the instructions:
    replace xx with tt

    and a photo:
    hxxp:// (replace xx with tt)
    Last edited by pipposanta; 08/27/2011 at 12:06 PM.
  2. #2  
    Did you use the emulator image?

    The top left says virtua (suggesting emulator).
    Developer of Ultimate Hockey, netSpeed, BatteryMonitor, The Ghastly Headset,
    netSpeed HD, St4rs and Matrix Exhibition
    Follow my webOS projects on my blog and follow me on twitter
  3.    #3  
    yeah I used the emulator image, I placed its content into an empty partition of an internal drive. Then edited grub to boot from it.
  4. #4  
    could you tell me your steps (by pn or here)?

    I want to test it on my pc..
    I installed the emulator for testing self written apps.

    So I can also test the emulated rom on pc.

    I hope it works fine

    Thanks a lot



    SDK within the file: nova-cust-image-sdk3032.vmdk

    This should be the right image of webOS 3, or?

    Please, tell me what you did with this file(s).

    2nd edit:

    VMDK files are for the VM (like the name says..)
    How you got the data from it?

    Does VM open it, extract it anywhere and start it?
    Or will the VM easily open the vmdk file and start the rom from this file?
    Last edited by freibergisch; 08/27/2011 at 02:57 AM.
  5.    #5  
    see here hxxp:// for instructions. replace xx with tt
  6. #6  
    fine, i will test and see

    I will tell you my results..
  7. #7  

    I have lot of problems..
    I installed VMWare 4.1..
    And the Palm SDK.
    In VMWare there is the entry "WebOS 3.0".

    But I don't know how I can extract the vmdk file with vmware-mount.
    I don't have vmware-mount.

    Could you tell me how I can extract the vmdk?

    (Using Ubuntu 11.4 - installed with WUBI)

    Thanks a lot
  8.    #8  
    first, ubuntu installed with wubi would cause some problems if you want to make webos boot with grub after... you should install ubuntu as a standalone install...
    to extract the image first install the VmWare Virtual Disk Development Kit you find the link in the guide I posted before. to install it extract the file you download and then go to the folder and run as root the file "install". follow the steps to install.
    then execute from a terminal this command.
    sudo vmware-mount position-of-image mount-point
    so for example it could be
    sudo vmware-mount /home/nova-cust-image-sdk3041.vmdk /mnt

    I hope it works for you!
  9. #10  

    Tomorrow I will start it again..

    One problem could be the mouse-support..
    So we have to bring mouse drivers from linux into the package..

    We will see...

    Good Night!

    I will give you a report
  10. #11  
    root@ubuntu:~/Arbeitsfläche# sudo /vmwareddk/bin/vmware-mount nova-cust-image-sdk3041.vmdk 1 webos1

    This created a directory on "Arbeitsfläche" (Desktop) called "webos1" (directory existed).

    In this directory I found a file: M59967.lck (512 Bytes (512 Bytes))

    What to do now??
  11. #12  

    I have got the right files

    directories: usr, boot, bin, etc, ... md5sums.gz file

    Thank you

    I will test it
  12. #13  
    How could you copy the extracted files?
    My Ubuntu couldn't copy it because of an error message.

    It copied some files from the first three directories and then the error message was shown

    So I have the right mounted WebOS directory at the desktop but I can't copy the files into it..

    Do you know a way for me to copy without errors?

    Thank you..

    PS: Isn't there anywhere a complete rom to use for our port?
  13.    #14  
    have you tried placing the word 'sudo' (without the quotes) before the command to copy the files?
    Anyway better to use rsync and not cp.
    sudo rsync -avHx /origin /destination
  14. #15  
    yes I did..

    All correct

    I want to edit the grub list from ubuntu..
    But I don 't know the right data..

    How did you do this?
  15. #16  
    Oh I have forgotten to tell you that I testet it with the ROM from TouchPad..
    I will test this with vmdk, too... I don't know to start the rom or the vmdk version..
  16.    #17  
    It will not work with the rom of the touchpad. It is compiled for the processor of the touchpad which is different from the one of a normal computer. You have to use the vmdk one.
  17. #18  
    yeah I will try it
  18. #19  
    Could you explain me how you edit the grub line for webos?
    I copied the files to USB-stick and want to start the webos from there..

    media/webos << I called it so..

    Or should I use a partition from hdd?
    But I think it could start from usb port.

    menuentry "WebOS3" {
    insmod part_msdos
    insmod ntfs
    set root='(/media/webos,msdos2)'

    I didn't have a initrd file (copied the lines above and edited them)..

    Please give me your lines.

    Of curse, I also write my own lines and hope that it starts..

    Thank you
  19. #20  
    With the following lines I will try to start webos:

    menuentry "WebOS3" {
    insmod part_msdos
    insmod ntfs
    set root='(/dev/sda3,msdos2)'
    search --no-floppy --fs-uuid --set=root 01CA6F8D1140ED20
    linux /boot/bzImage-2.6.26 root=UUID=01CA6F8D1140ED20 vga=ask ro quiet splash

    Could you tell me now your config?

    It doesn't start..
    So I have to edit the grub.cfg again..

    Please help me..
    Last edited by freibergisch; 08/31/2011 at 12:44 PM.
Page 1 of 2 12 LastLast

Posting Permissions