Results 1 to 4 of 4
  1. pbox's Avatar
    4 Posts
    I've got huge problems with my (wife's) Palm Pre. It worked fine with Rebel SIM card for a few months, then stopped so I had to root it (from Debian Linux) using novacom and do the PmModemUpdater<castleumtsfw.tar. It worked for another month until my wife has hit the button requesting another firmware update!

    Well, since then I tried to use the same rooting method but it did not work (although I was able to root into the Palm Pre). I decided to give it a go and asked local unlockers whether they were able to unlock the phone. They accepted the challenge and after a week or so they returned the phone, still locked. But, at that point I was unable to root into the Palm Pre, which is now seen by any operating system as an external disk, no matter whether in the normal or developers mode.

    I have bought the NextGenServers solution to unlock the phone but I am unable to install the drivers on any Windows XP or Vista 32 machine I have been able to use. The technical support from the seller says that the local unlocker must have used an old unlocking solution that has messed the firmware! To be honest, I am really running out of ideas about how to fix the phone. Is reverting to WebOS factory settings possible without any serial communication with the Palm Pre? Do you have any idea how to do that? I would appreciate any help from this forum!
  2. #2  
    I believe you forgot to put the phone into Dev Mode?

    Check that first, it's usually the case, just a whoops, I forgot thing!


    Robert L
    Astoria Queens, N.Y.C
    - Palm Pre (Sprint) - formally Palm Treo 650
    Sprint Configuration 2.3
    Model: P100EWW
    Hardware Version: A
    Firmware: CC1.4(510)

  3. pbox's Avatar
    4 Posts
    Switching modes does not have any impact on the discovery of the phone by my operating systems. It is just seen as a USB disk, that is in fact detected as such even before I am able to hit 'Charge Only' button on my Pre. Please see the dmesg output below, the same for both modes (apart from the timings, of course):

    [122643.916124] usb 2-1: new high speed USB device using ehci_hcd and address 36
    [122644.050219] usb 2-1: New USB device found, idVendor=0830, idProduct=8004
    [122644.050228] usb 2-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
    [122644.050234] usb 2-1: Product: Pre
    [122644.050238] usb 2-1: Manufacturer: Palm Inc.
    [122644.050243] usb 2-1: SerialNumber: xxxxx
    [122644.050448] usb 2-1: configuration #1 chosen from 1 choice
    [122644.053183] scsi16 : SCSI emulation for USB Mass Storage devices
    [122644.053982] usb-storage: device found at 36
    [122644.053986] usb-storage: waiting for device to settle before scanning
    [122649.052597] usb-storage: device scan complete
    [122649.053378] scsi 16:0:0:0: Direct-Access Palm Pre 0000 PQ: 0 ANSI: 2
    [122649.061163] sd 16:0:0:0: [sdd] Attached SCSI removable disk

    Any other ideas? Do you know how to upload any earlier WebOS firmware in eg bootie mode (when you have a huge USB sign on the Palm screen). I don't think it is possible. So maybe I could upload an older version of WebOS while connected to the Palm in its USB mode, place it somewhere in the boot area so that it could be picked up during the start up of the phone? Where do I get older versions of WebOS from?


    I have managed to root into the Pre, following instructions given here: www(dot)webos-internals(dot)org/wiki/Last_Resort_Emergency_BootLoader_Recovery. I had to use the last Linux method provided, ie the one under the heading Alternative Recovery because nothing else had worked for me.

    Now, while my Palm is rooted in the bootie mode, does anybody know how to proceed? What files/images needs to be uploaded to the phone to get it working/installing the necessary files for it to work? What tokens need to be changed and how to do it? All modifications have to be done in novaterm/novacom CLI as webOS doctor have not gained access to the phone (don't ask me, why?) Can anybody help, please?

    OK, one more thing I have discovered. Comparing the above link with the tokens --list command on my rooted Pre, I've found that one token should be PN=180-10722-03, whereas on my phone it is "PN" = "180-10644-03". Maybe that was the alteration done by the local unlockers, maybe one of many? So far, so good. I'm not trying to lose my faith in the revival of my phone. But, can anybody help to speed up the process?
    Last edited by pbox; 06/14/2010 at 06:01 PM. Reason: Progressed towards the solution to the problem
  4. pbox's Avatar
    4 Posts
    Anyone has modified the Pre's flash disk or knows how to do that? Here is the link: www(dot)webos-internals(dot)org/wiki/Pre's_flash_disk

    I'm stuck and I think the only option now would be to upload a working vmlinuz and initrd.img to my Pre to get it working and then possibly webOSdoctor to recover it. At the moment webOSdoctor does not recognise my phone, I'm afraid. :-(

Posting Permissions