Results 1 to 6 of 6
  1.    #1  
    Ok so I know what is "supposed" to work, I should be able to use command line to package up the .ipk using palm-package and the directories

    but anytime I try this I get a generic error about java not being recognized, I updated my Java, restarted, same deal

    I can use Eclipse and even Ares without a problem, I just can't package my final app out of Eclipse, everywhere I search on how to package it everyone says use the command line tool... well I'm trying to!

    any help is greatly appreciated, running windows 7 64bit, Eclipse, I don't use the emulator I use my device, maybe something about java still isn't installed correctly? if I try to start the emulator it just flashes the command prompt window and closes... which works totally fine on my windows server 2003 box.... so I'm familiar with setting it up and having it actually work that way

    tips/help please, trying to get an app out to the web distribution (free) for an event that's going on in Detroit next weekend
  2.    #2  
    well, I found a round about way to do this, I took my project folder from eclipse, zipped it, and added it to Ares, then had ares package it for me, worked perfect, people have downloaded my project from the web dist just fine and I loaded it with QI with no problems w00t

    so I guess that's a work around when you have java issues? or don't like command line (which I have no problem with if the mofo worked!)
  3. #3  
    If palm-package commandline doesn't work, you could just package it using Ipk Packager
    If you've liked my software, please consider to towards future development.

    Developer of many apps such as: WebOS Quick Install, WebOS Theme Builder, Ipk Packager, Unified Diff Creator, Internalz Pro, ComicShelf HD, LED Torch, over 70 patches and more.

    @JayCanuck @CanuckCoding Facebook
  4.    #4  
    awesome, thanks for the reply, I appreciate it, and all you've done for the community! I think I've donated a couple times already I'll surely keep doing so

    I'm still curious why the command line doesn't work but I guess I don't really care if I have easier options

    thanks again
  5. #5  
    Another thing you can do is grab it from the temp directory that Eclipse uses when compiling for the emulator. I don't remember the path off the top of my head though.

    Only thing I don't understand about this method is that I can run the app from Eclipse THEN open the temp directory and the IPK is there to grab, BUT if I leave file explorer open and viewing the temp directory, Eclipse will generate the IPK then delete it. <scratches head> I've actualy gotten good at doing a "ctrl c", "ctrl v" real quick before the file is deleted. Seems to work so far.
  6.    #6  
    that's not bad either, someone mentioned that when I was reading, but I couldn't find the temp directory and it seemed like a 'hack' so I was trying to do it one of the correct ways

    the Ares way was at least a true "package" after an import so it felt better, the package program jason mentions looks promising, I'll try it when I get home.

Posting Permissions