Results 1 to 10 of 10
  1.    #1  
    Hello All,

    So frustrated! I'm new with the whole SDK and Linux stuff, but am getting the hang of it.

    I have a seismograph app on my Palm Pre, and had some pretty good recordings the other day. You have the option of exporting the data, but only in XML format. Thus, I end up with about 3,300 readings that I have to change into a graph, and crunching that much data into a letter size sheet is just not accurate, a normal reading would be feet long, or atleast in my case it is.

    I figure that if I can find the darn program on my phone, I can pull the files and then figure out how to get them to "play" as it does on the phone. I've rooted my phone and dug around, but there is just so much on there I don't know what is what. I did find a thread that gave the location of apps, and I really am hoping that this app stores its data in the same folder, but the file is restricted. I've tried all Linux codes I can find on the net to access it, but it just won't let me!

    I'm not trying to steal the app or anything illegal, I just want to get the files it recorded in the proper format on my laptop.

    Please, can someone tell me how to access the app directory?

    I have a feeling once I do get access to it, and trust me I will be searching until someone replies (so hurry please, this is driving me crazy!), that more questions will come up, so keep your eye out.

    Thank you so much for your support!

  2. #2  
    Do you have SSH installed on your Pre? It would allow you to browse the filesystem of your device to find the files. The app directory for 3rd Party Apps is /media/cryptofs/apps/usr/palm/applications but i don't think the app would store the data in the app folder. I'm not sure of what directory apps save data in by default.
  3. spdqbr's Avatar
    78 Posts
    Global Posts
    80 Global Posts
    If it stores more than 1 MB of data, then I believe the only solution using the current PDK is to store it in a database file on the usb partition.

    Try mounting your phone in USB mode and then looking for a directory called .app-storage . There should be one sub folder per application using that storage method. If it's not there, then check out the folder Veritas mentioned for a .db file. If it's not there either, then... I dunno. I'll poke around if the app is free.
  4.    #4  
    Yup, that's where I tried to go, but was stopped at "cryptofs" and told it was restricted, or something along those lines.

    I'm not sure what you mean by asking if I have SSH installed on my phone. I followed the directions from this website:

    palmpre-hacks. com

    I'm able to root my phone, is there some program that I'm missing that needs to be on my phone? The only thing I did to my phone was enable developer mode, and then per the instructions I turned it off before running the Linux program on my laptop.

    I even tried the chmod command, but that wouldn't allow access to the cryptofs folder either.

    Even if I can't find the files, I can transfer the program to my computer (it was free so I think it's all legal), and figure out how it works, either using the emulator or some other option...

    You say that you don't know where the apps store their data, no idea at all? I think even if I did find the data it is going to be in XML format anyway, I just need to know how the app converts it into a seismograph.


  5. #5  
    For SSH it allows you to get a view of the whole filesystem ( i assume you're using QuickInstall right now? ) like a regular drive but the setup is a bit intensive. If you're up for it, it turns out to be very useful
  6.    #6  
    I am 99% sure I am using SSH. The website's title is "How to Root Your Palm Pre"...

    I had to install VirtualBox, Palm SDK, Java 6, and a few other programs.

    Skipping a few steps, I had to type in novacom -t open tty:// to the cmd, install a bunch of files, and then set up a username and pass. Now I use putty to root into my phone and Linux commands. Would that be SSH?

    As far as the other post. I set my phone to USB drive, I quickly found out that there are too many folders for me to dig through, so I did a search on the drive for any type of folder containing the phrase "app", then I did a search for any files in .db format and in xml format (which is what the app saves the data in). Nothing came up.

    Starting to see my frustration?

  7.    #7  
    Well I certainly didn't go through all that, but when I use putty I use my phone's IP address to connect, but the SSH box is checked.

    All of the novacom screenshots look identical to what I did, so perhaps I found an easier way? I'm not sure.

  8. #8  
    If you use the terminal app (not working now, use Terminus if you like), it's the same as if you use novaterm. It just opens a shell window inside your Pre, and you can access the filesystem this way.

    The "problem" accessing your Pre using usb mode is that you only would have access to /media/internal, but what you're looking for is in / and /media/cryptofs

    It's safer and easier downloading the WebosDoctor for your carrier and version, opening the .jar file (open it under winzip, or rename it as .zip). Inside it there is a directory resources, and inside you can find webos.tar. Inside webos.tar you can find the nova-cust-image-castle.rootfs.tar.gz file, this contains the entire filesystem that gets flashed to the Pre.

    Inside the .tar.gz file you can find everything.

    But, if you really want to access and fiddle with your Pre, login with novaterm, and you will find apps in /media/cryptofs/app and /usr

    In Linux, you could find a file using:

    find / -print | grep file.ext

    This would find the file "file.ext" from the / (root) directory

    Good luck
    Just remember: If I helped you, press the thanks button!

    Owner of: Pre Sprint, Pre Telcel, Pre Plus AT&T, Pre 2 Unlocked, Pixi Plus AT&T, and 2 TouchPads (my Pre3 was stolen so it won't appear again here).
    Needs: Veer (anyone?)
    Apps: Subnet Calculator, FreeCam, PhotoFun, NuttyPad (work in progress)
    HomeBrew: meta-doctor and Messaging Plugins collaborator
    Twitter: @cesarneg
  9. #9  
    Try downloading WinSCP to login, instead of using PuTTY. You'll get a view instead of command line.

    Do you know the name of the app? If you give me that ( & like spdqbr said, if it's free ) i can download & take a look to try & find where the app stores data.
  10.    #10  
    The program is free, and is in the app catalog under the name of "seismograph" under the categories productivity and tools. I'll try your suggestion first, then go with the whole SSH thing if I must.



Tags for this Thread

Posting Permissions