Results 1 to 9 of 9
  1.    #1  
    Been playing around with Ares. Did the Flickr Seach tutorial and even managed to create the most basic possible app from scratch (not a programmer). (just launches a web page)
    I can get the new app to launch and install on the emulator.
    My question is how do you set up the device (Pre) to where Ares will install and run the app on the device?
    I read that the device takes priority over the emulator, but I can't find where it actually says how to do this.
    Do you have to have the emulator running?
    I'm assuming you have to plug in via USB and have the device in Developer Mode.
    Can someone explain the proper steps?
  2. #2  
    Yep your exactly right. Put the phone in developer mode, plug it into the computer, and when you hit the run button in ares (the green arrow) it'll install and run the program right on your device.
  3.    #3  
    In Dev Mode,
    I opened Ares,
    plugged in Pre via USB and have tried both "USB Drive" and "Just Charge",
    Still doesn't seem to recognize anything plugged in.
    Hitting the launch command didn't do anything.
    Does the emulator have to be running?
    What order do you have to do things?
    I know before when I had the emulator running, along the bottom it said that USB was disabled and I couldn't see how to enable it...

    Thanks again
  4. #4  
    I just tried it and it work. Had it in charge only mode. Just make sure that any of the files for Flicker are open. I have been doing it the long way. I have been packaging it, then put in develop mode, set to charge only, then dragging and dropping the file into preware. Thanks for the quicker step Alex.
  5.    #5  
    Alright, I got it to work a few times in "Just Charge" mode like you said. Not sure if Ares is flakey, or if it's me, but it doesn't seem to launch every time I try. I would orange-tap to delete off the Pre and try to launch/install again.
    How do you delete an app off the emulator by the way?
  6. #6  
    Quote Originally Posted by jkb2618 View Post
    How do you delete an app off the emulator by the way?
    Alt key and tap on the icon
    Sprint Palm Pre - WebOS 2.1 > Sprint HTC Arrive
  7.    #7  
    Quote Originally Posted by TIWizard View Post
    Alt key and tap on the icon
    FYI - The reason my "app" wouldn't launch consistently was a simple matter of having a Caps letter in the ID section of appinfo.json....
    Taking some trial and error, but it's interesting to learn.
  8. #8  
    a capital letter was causing it to fail only sometimes? I'll file this bug and we'll tak a look. Ares uses the same code as the downloadable sdk so it might be an issue with both.
  9.    #9  
    jumpingmatt - I'm pretty certain the only bug in the process was me. The issue of not launching consistently was a poor choice of wording on my part, and I didn't explain that this was during deleting and start over with a new app different times. I'm sure Ares did just as it is supposed to....

Posting Permissions