Results 1 to 8 of 8
  1.    #1  
    I've installed the webos sdk (along with all of the dependencies) on Ubuntu 9.10. Novacomd is listening in one console window but when I launch palm-emulator in another all I get is a small window offering two choices ("Palm SDK (320x400)" and "Palm SDK (320x480)") and a button labeled "Start Emulator." No matter which of the two choice I select, nothing happens when I click on the button. No error messages in either console window. Not a promising start to the evaluation of the SDKs which I'll use to determine whether to go with the Palm Pre Plus or the Droid. Any clues on what might be happening? I tried this with both 3.0 and 3.1 versions of virtualbox, but no luck with either.
  2. #2  
    i had the same trouble and the solution is trivial - you have to double click on one of these 2 emulator options hope this will help

  3.    #3  
    Quote Originally Posted by dragupl View Post
    i had the same trouble and the solution is trivial - you have to double click on one of these 2 emulator options hope this will help

  4. #4  
    I've noticed that too. Seems to be a bug in GTK, since it affects a number of button widgets in GTK-based applications.
    You can also hit Tab to put the focus on the button and then hit Enter. (Not needed in this case since a double-click works, but might come in handy in other situations.)
  5. #5  
    Or click one then click on the "Start Emulator" button. Either way, I agree that it's a little annoying at first.
    MoBill - Use your account to bill your customers with your webOS device!!
    MoJack - Track your lost or stolen webOS device from anywhere!
    Time to get VIRAL
  6. #6  
    If someone still tries to get it working with Virtual Box 3.1.x you have seen that it's not yet supported by Palm (you get an error message that this version of Virtual Box is not supported).

    The command line tool parameters to manage the VMs has changed in Virtual Box 3.1.x!
    That's the reason it's not working right now. Beside that there were some errors in the parameter handling 3.0.x didn't check but 3.1.x does.

    As I wasn't happy about the situation I modified the Palm SDK 1.4.0 Build 420 to support Virtual Box 3.1.x and 3.0.x!
    It wasn't very hard but it took still some time (3 evenings) after work to get it done.

    Go to this post to find the location where to get my modified version (sorry you need to remove the spaces from the URL):
    http: // forums . precentral . net/web-os-development/217886-do-not-upgrade-virtualbox-3-1-yet.html#post2315434
  7. spdqbr's Avatar
    78 Posts
    Global Posts
    80 Global Posts
    This may not be the source of your problem, but there is a issue which can happen with Ubuntu 64 bit + GDK + Compiz which makes some buttons not register clicks. Happened to me for both the launch window of the emulator and some buttons in Eclipse. You can still issue clicks using tab + spacebar, but I found it generally annoying.

    A simple fix:
    Start the emulator and/or eclipse from a terminal session, but first issue the command:
    export GDK_NATIVE_WINDOWS=true
    Or you could simply add that line to your .bashrc, as I have done, and it fixes the problem even if you launch from a shortcut.
  8. mhous33's Avatar
    99 Posts
    Global Posts
    108 Global Posts
    I can't get palm-emulator 1.4.1 working in Ubuntu either; it gets as far as launching and resizing the emulator window to 320x400, then freezes. I'd be happy to get the 1.4.0 emulator working, but haven't been able to find it, and the official page has only the latest version afaikafaikafaik.

    I've tried Ubuntu 9.04 & 9.10, both with VirtualBox 3.0.10 & 3.1.6. Here is the list of commands I've been using to set it up:

    /*added the following line to /etc/apt/sources.list*/
    deb jaunty non-free
    deb karmic non-free

    sudo apt-get install dkms /*protects VirtualBox from kernel update)*/

    wget -q -O- | sudo apt-key add -

    sudo apt-get update

    sudo apt-get install sun-java6-jre

    sudo apt-get install virtualbox-3.1 /*and virtualbox-3.0*/

    /*download novacom and sdk*/

    sudo dpkg -i palm-sdk_1.4.1-svn274946-sdk1436-pho427_i386.deb

    sudo dpkg -i palm-novacom_1.0.55_i386.deb


    Any ideas or suggestions? TIA

Posting Permissions