Page 2 of 6 FirstFirst 123456 LastLast
Results 21 to 40 of 114
  1. #21  
    Quote Originally Posted by Tag234 View Post
    the error ive been getting is apparently related to amd64 and ansi problems... so you may actually be able to compile it on a different machine. Im not sure how to specify the SDL directory of gnuboy like you could on doom however... this may become a problem if ./configure doesn't find the SDL install.
    Hopefully I will be able to compile it. I'll see how it goes.

    Well, as I was typing the above, my other laptop decided to stop working. It doesn't want to boot back up right now. It's kinda old and I think the hard drive is failing. Gotta give it a few minutes then it should boot; This isn't the first time the thing temporarily died on me
  2. #22  
    I'm just going to go through the setup again on my main laptop and see what happens. Hopefully my other laptop will decide it wants to boot up soon lol
  3. #23  
    Quote Originally Posted by Garrett92C View Post
    I'm just going to go through the setup again on my main laptop and see what happens. Hopefully my other laptop will decide it wants to boot up soon lol
    HAs there Been any luck on this?

    Donate Via Paypal to Email Adress:
    Twitter: @fritos1406
  4. #24  
    Quote Originally Posted by fritos1406 View Post
    HAs there Been any luck on this?
    I fell asleep for a bit. I ended up drinking beer instead of coffee last night lol. I'm reinstalling Ubuntu on my other laptop as we speak, so I should be able to start working on it again very shortly.
  5. #25  
    Ok, I was going through the Doom setup page to get familiar with the process and ran into an issue... I could run ./configure --with-sdl-prefix=/usr/local
    fine, but when I tried to run "make" I got an error. It can't find SDL 1.0.

    I've tried searching around but could find any help. I'm still kinda new to Linux. How to I install SDL 1.0 on my ubuntu 9.1 laptop?
  6.    #26  
    are you in your scratchbox root? If everything was done correctly, you should be ./configuring and makeing after you run the command to start scratchbox, which should mean you dont need SDL installed on your machine at all (when setting up scratchbox, it downloaded webos doctor in order to create a virtual pre environment)
  7. #27  
    I think I was in the scratchbox root... In the OP, I followed the first link and everything on that page worked fine and flawlessly. It wasn't until I tried using 'make' that I got the error.. I'll keep playing around with it I guess.
  8. #28  
    Ok, fixed the issue. Now I'm trying to fumble my way through the Palm SDK install lol.

    Wow. Palm's instructions for installing the SDK on Ubuntu are ridiculously incorrect. I'm making good progress tho.
    Last edited by Garrett92C; 01/09/2010 at 05:50 PM.
  9. #29  
    I'm going to temporarily forget about Palm SDK lol.

    Where did you get the source for gnuboy?

    I found it. I'm gonna compile and see what I get

    <edit 2> nevermind, I dont think I have the sdl version.. You have a link to the sdl gnuboy source?
    Last edited by Garrett92C; 01/09/2010 at 06:35 PM.
  10.    #30  
    gnuboy-1.0.3 is the source for sdlgnuboy, the ./configure just has to detect SDL in order to build it
  11. #31  
    This is what I'm getting:

    <arrett@chompy2 gnuboy-1.0.3 $ ./configure --with-sdl-prefix=/usr/local
    checking for gcc... gcc
    checking for C compiler default output... a.out
    checking whether the C compiler works... yes
    checking whether we are cross compiling... no
    checking for executable suffix...
    checking for object suffix... o
    checking whether we are using the GNU C compiler... yes
    checking whether gcc accepts -g... yes
    checking how to run the C preprocessor... gcc -E
    checking for a BSD compatible install... /usr/bin/install -c
    checking whether byte ordering is bigendian... no
    checking for usleep... yes
    checking for sys/soundcard.h... yes
    checking for linux/joystick.h... yes
    checking for linux/fb.h... yes
    checking for vga_init in -lvga... no
    checking for sdl-config... yes
    checking for SDL_Init in -lSDL... no
    checking for X... no
    enabling selected compiler warnings
    producing heavily optimized code
    no optimized asm core available for `uname -m`
    configure: creating ./config.status
    config.status: creating Makefile
    config.status: creating sys/nix/config.h
    config.status: sys/nix/config.h is unchanged
    [SB2 mapping-armv7 armv7] garrett@chompy2 gnuboy-1.0.3 $
  12.    #32  
    yep looks right, give it a make, does it hang at all? I successfully compiled sdlgnuboy with joystick disabled... but if you type make right now and it works then thats it
  13. #33  

    [SB2 mapping-armv7 armv7] garrett@chompy2 gnuboy-1.0.3 $ make
    gcc -ansi -pedantic -Wall -Wno-implicit -Wno-long-long -O3 -fstrength-reduce -fthread-jumps -fcse-follow-jumps -fcse-skip-blocks -frerun-cse-after-loop -fexpensive-optimizations -fforce-mem -fforce-addr -fomit-frame-pointer -I. -I/usr/local/include -I./sys/nix -DHAVE_CONFIG_H -DIS_LITTLE_ENDIAN -DIS_LINUX -c sys/linux/joy.c -o sys/linux/joy.o
    cc1: warning: -f[no-]force-mem is nop and option will be removed in 4.3
    In file included from sys/linux/joy.c:6:
    /usr/include/linux/joystick.h:131: error: expected specifier-qualifier-list before '__s64'
    make: *** [sys/linux/joy.o] Error 1
    [SB2 mapping-armv7 armv7] garrett@chompy2 gnuboy-1.0.3 $
  14.    #34  
    hmmm semi success, the sdlgnuboy i compiled runs on the normal device but right before startup it gives me a curious error:

    SDL: can't set video mode: SDL_HWSURFACE and/or SDL_DOUBLEBUF not supported

    Signal 11

    However, what it DOES do is minimize my Terminal app back into card view, making me think that it at least tried to start and that i should have progress if i can figure my way past these errors.
  15. #35  
    At least we are making progress lol.. How do you disable the joystick?

    Oh, and where is the finished file after I 'Make'?
  16. #36  
    I wish I could help in someway, but I know nothing about the inner workings of this stuff.

    It looks like you guys are really close, thanks for the effort!
  17.    #37  
    sdlgnuboy file will be in the folder after make completes successfully, to bypass joystick, i had to edit the config file manually :-\ there should be a ./configure --disable-joystick option but i couldnt get it to work... Im not sure how to solve my issue, i think it may be within the code for gnuboy somewhere, and if i change the video mode to fullscreen or something of that sort, it will work.
  18. #38  
    Yea, I'm not getting any new files after 'make'. I'm still getting the joystick error, so I don't know what to do...
  19. #39  
    I know that one of u can get it on success..sorry i know im no help

    Donate Via Paypal to Email Adress:
    Twitter: @fritos1406
  20.    #40  
    hmm i think im close, i have a compilation that runs, opens a new card and creates an OUTLINE of what looks like a correct gameboy screen with some colors but then the box that it outlines is black.... I dont really know how to describe it but i suspect something within the sdl code of gnuboy... immm gonna keep messin with it and hopefully we will have a working version soon.

    I do have a feeling it works though because with 2 different roms, each time i run the program it has the same sequence of colors for that outline, as if its running the games but... somehow not displaying them in the correct way
Page 2 of 6 FirstFirst 123456 LastLast

Posting Permissions