Results 1 to 8 of 8
  1.    #1  
    Since updating to webOS 1.3.5 on my Pre and sdk 1.3.5 on my desktop (Debian testing, VirtualBox 3.0.10), I'm unable to get any programs to recognize that novacomd is running.

    For example, when I start palm-emulator, I get the "Novacom Not Responding" dialog. I can click "Ignore" in that dialog and the emulator will start, and the terminal from which I started novacomd (via '/opt/Palm/novacom/novacomd&') shows the messages "novacom_go_online" and "novacom_register_device:193: dev '<long hexadecimal string>' via tcp type emulator".
    Once the emulator is up, I can run novaterm and get a root prompt on the emulator, just like normal. But trying to install my ipk via palm-install (after going back to a shell prompt on my desktop) shows the message "palm-install: Network is unreachable".

    Similarly, if I run WebOS Quick Install and try to connect to the emulator, I get the "ERROR: No device detected" message. And if I try running the PrewareInstaller, it complains "Unable to connect to Novacom. Check driver is running."

    The results are the same whether I try to go through my Pre or through the emulator. So far I've tried purging and re-installing Novacom, rebooting my desktop, and doing a partial erase and a number of re-starts on my phone. Googling has turned up two other cases like this (one in this forum for someone using Windows 7, and one in the WebOS Internals chat log for an unspecified platform), neither of which has gotten anywhere. Meanwhile, I can't get to any of the excellent homebrew apps, and my own development efforts are frozen.

    Any ideas on how to get past this problem?
  2. #2  
    Same problem :/
  3. #3  
    Oh boy, I'm in a 'club'
    from the thread "how to get novacom into acutal pre" I found instructions to run novacom from the terminal, so I ran the command:

    sudo launchctl load -w /Library/LaunchDaemons/com.palm.novacomd
    com.palm.novacomd: Already loaded

    Which reports novacom already loaded. Yet my phone in DevMode, USB charge only, and WEBOSQI still doesn't see my phone. The Reload Novacom button does not work for me either. Stuck with a standard pre, and I miss my patches!!!!!!!
    Back to square one.
  4. Honis's Avatar
    508 Posts
    Global Posts
    511 Global Posts
    I'm also experiencing this problem. I'm using WebOS

    My problem had the same symptoms but different issue. My Novacom was not running (stupid me didn't check before posting).
    I'm running Windows XP SP2.
    Fixed it by going to Start > Run > services.msc
    Locate Palm Novacom in list.
    Right click Novacom and select properties.
    Set the option in the Startup Type drop menu select Manual (auto may be fine too).
    Click Apply.
    Click Start.
    Wait for it to start.
    Try reconnecting to the Pre (Pixi).
    Last edited by Honis; 01/08/2010 at 12:16 AM.
  5.    #5  
    Apparently my Linux distro recently updated the networking libraries, and part of the change was to force IPv6 binding. (At least that's what I can gather--it's all over my head, frankly.)
    The system-wide fix, gleaned from a post on this site, is to run this command as root:
    echo 0 > /proc/sys/net/ipv6/bindv6only
    There's also a Java-only fix in the original post on that site, but it seems to me that all the programs that have had a problem lately have been Java-related anyway.
  6. #6  
    What does that mean for Win Xp/ sp2? Can we get around this glitch for the new upgrade?
  7. #7  
    I continue to get an error message: Error Downlaoding Package Feed. ERROR: Invalid feed url. Please advise. I miss my tweeks!
    x0x0, iPrinces
  8. #8  
    i ran webOS doctor earlier today now my pre when in developer mode is not recognized by my pc. I hope someone comes up with a fix to these issues soon!

Posting Permissions