Results 1 to 3 of 3
  1. tribi's Avatar
    4 Posts
    Global Posts
    6 Global Posts
    hi i've been trying to bootie my pre i found an info on webos-internal about last resort for the pre but it needs to be done on a linux i have tried every thing but the thing is i dont know anything about linux i installed sun virtual box & mandriva here is the info they have please hejp me. thank you

    Typically, any damage to the operating system on the Palm Pre can be recovered by booting into recovery mode.

    One situation which cannot be recovered so easily is the extremely unlikely event of corruption of the installed bootloader (bootie) stored on the Pre's flash disk.

    If bootie on the flash disk has been damaged or corrupted in such a way that booting into recovery mode is not possible, the Pre is still not "bricked" as the OMAP3430 processor in the Pre provides for a mechanism to boot code from its USB interface.

    First, ensure that the Linux SDK and novacom packages are installed, as you will need to run webOS Doctor as the final step in this process. Second, ensure that you have a copy of the webOS doctor jar ready.

    Download: omap3_usb.tar.bz2

    Compile on Linux system with "make". Optionally install with "sudo cp omap3_usbload /usr/local/bin"

    Now extract the bootie binary from a WebOS Doctor image:

    mkdir doctor; cd doctor; unzip ../webosdoctorp100eww-wro2-1.1.3.jar; cd resources
    mkdir webOS; cd webOS; tar xvf ../webOS.tar; mkdir nova-cust-image-castle.rootfs; cd nova-cust-image-castle.rootfs
    tar xvzf ../nova-cust-image-castle.rootfs.tar.gz ./boot/boot.bin; cd boot
    Booting bootie over USB:

    Ensure USB is unplugged from the Pre, and remove the Pre's battery.

    On your Linux system, run:

    sudo omap3_usbload boot.binThis should return:

    TI OMAP3 USB boot ROM tool, version 0.1
    and a series of dots while it looks for an OMAP3 to send boot code to.

    Now, plug the pre into USB.

    If all works as it should, the usbload program should return:

    found device!
    download ok
    And your Pre will now show a USB logo. (this is bootie's "Recovery mode")

    Put the battery back in without unplugging the USB.

    Since you are now in USB recovery mode, you should be able to run the webOS doctor on the host Linux box. Remember that the SDK novacom package must be installed for the webOS Doctor to work in Linux.

    One way to do this is to launch the doctor from the command line like:

    sudo java -jar webosdoctorp100eww-wro2-1.1.3.jarAnd follow the usual steps to recover your pre's operating system from here
  2. #2  

    Hopefully you will get more responses in this forum
    aka Gfunkmagic

    Current device: Palm Pre
    Device graveyard: Palm Vx, Cassiopeia E100, LG Phenom HPC, Palm M515, Treo 300, Treo 600, Treo 650, Treo 700p, Axim X50v, Treo 800w

    Please don't PM me about my avatar. For more info go here.

    Restore your Pre to factory settings using webos doctor and follow these instructions
  3. #3  
    i need some help with this. i get as far downloading the omap file i dont know what Compile on Linux system with "make". Optionally install with "sudo cp omap3_usbload /usr/local/bin" means however. i was able to do the whole second set and terminal is the boot folder. now i have no idea what to do. i have tried everything so many times to get a dr. to run. everytime it stops at 4% and just boots the phone which is stuck at a screen requiring a download before starting and it is not downloading anything after hours of doing nothing.
    please help!

Posting Permissions