Results 1 to 3 of 3
  1. spdqbr's Avatar
    78 Posts
    Global Posts
    80 Global Posts
    Hey guys, I'm a java developer and it would be really pretty sweet to run custom java apps on the pre. I highly doubt anything like swing UI's would be possible, but I'm just poking around for the moment trying to see what's possible.

    Since the pre seems to have some sort of java 1.5 jre already installed, I've been trying to leverage that for some simple command line stuff. I've already hit a brick wall. Here's where I've got to so far:

    spdqbr@castle:~$ echo $LD_LIBRARY_PATH
    spdqbr@castle:~$ ls -l
    -rwx------    1 spdqbr   spdqbr        477 Nov  8 23:41 Test.class*
    drwxr-sr-x    3 spdqbr   spdqbr       4.0k Sep 17 20:49 usr/
    spdqbr@castle:~$ /usr/lib/jvm/java-1.5-palm/bin/java Test
    Command line arguments:  /usr/lib/jvm/java-1.5-palm/bin/java Test
    @@@@ ClassLibrary initialize begins...
    Error: gObjectClass is null (bad bootclasspath?)
    Cannot execute Test
    Test.class is a simple "Hello world" compiled with jdk 1.5 . Setting LD_LIBRARY_PATH is essential to get this far.

    Just executing the java command on its own generates the help dump that anyone whose used command line java before would recognize. I've tried various settings for the bootclasspath so far and none of them have worked.

    This is more of an academic exercise at the moment than anything else, but who knows what could come of it... anyone have any ideas on how to get further?
    Last edited by spdqbr; 11/09/2009 at 01:55 AM.
  2. #2  
    Go to Main Page - WebOS Internals

    all the details for this were worked out months ago.

    Join the conversation at on IRC in #webos-internals

    the source for all the various webos-internals java apps and services is available at
  3. spdqbr's Avatar
    78 Posts
    Global Posts
    80 Global Posts
    I don't see much information there on running actual compiled java... am I just looking in the wrong spot?

Posting Permissions