Results 1 to 4 of 4
  1.    #1  
    Hey guys,

    I've got a great idea for an app and some experience in programming. So, I decided to try my hand at writing an app for webOS. I started on, got everything installed (after a little research and tweaking) and got to work on the HelloWorld tutorial. I followed everything through to the letter, installed it to the emulator, and got the default message:
    This text verifies your application is running.

    To create a fully functional Palm application create a scene and remove this text from index.html. See the documentation on Palm Applications for more information on creating applications and scenes.
    So, I removed the text from the body and tried again. This time the card came up blank.

    Well, I played around with that for a while before I decided it was time to take another approach. So, I picked up O'REILLY's Palm webOS by Mitch Allen. I used Eclipse with the palm plugin to work my way through the News Application tutorial he starts on page 33. When I finished, I ran it on the emulator. Once again, I got a header but the rest of the card was blank grey. I figured it might be the emulator, so I installed it on my pre with the same result.

    I figured it might be a problem with Eclipse since I'd used that for both of the tutorials. So, I went back through the news application tutorial EXACLY as written, even copying and pasting the code. I edited everything in wordpad, used the cmd window, etc. Still, when I ran it in the emulator, I just got a blank screen for a card.

    I've attached a zip file with the folder with the news application in it. I'd upload the helloworld one, but I screwed around with that one a lot trying to get it to work, so I'm not sure about it anymore.

    Could someone please take a look at these files and tell me what I'm doing wrong? It's a very very very simple program (actually a first step in a larger program) with very little code and only one scene, so it shouldn't take much time.

    Thank you in advance for your help.

    Windows 7 x64
    WebOS 1.2.1 on my phone
    VirtualBox 3.0.4 r50677
    Palm Emulator (
    Eclipse SDK Version: 3.4.2 Build id: M20090211-1700
    I installed the following plugins for Eclipse:
    Palm Mojo SDK Tools (Core)
    Palm Mojo SDK Tools (UI)
    Palm Mojo SDK Tools (Aptana Support) 0.9.3.qualifier
    Attached Files Attached Files
  2. #2  
    If you are thrown back to the content of index.html, it usually means that you have a javascript error in the stage or scene setup method. You may want to try connecting with Putty to the emulator to port 5522 on localhost, log in as root with no password. And then check the app log by running "log" replace the previous id with the News app id.
  3.    #3  
    Thanks for getting back to me. I ran putty and got the following error:
    [QUOTE]2009-10-08T05:09:15.521459Z [2632] qemux86 user.err LunaSysMgr: {LunaSysMgrJS} Error: Error: require Failed: The scene assistant 'StoryViewAssistant' is not defined. Did you remember to include it in index.html?, line undefined, file undefined, file:///var/usr/palm/applications/{/QUOTE]

    There wasn't anything in either tutorial that said I needed to reference the scene assistant in the index.html file. Am I missing something?

    BTW, thanks a lot for showing me this trick with putty. I'm sure it will come in handy when it comes to debugging my app once I get to work.
  4. #4  
    Hello Zathrath,

    because I'm also new to WebOS development I took a longer time to look behind your problems to learn for myself.

    Your project looks good and it seems to be all OK, but...

    At first, there is a wrong include of the Mojo SDK in index.html, maybe an old variant.

    Furthermore the emulator pointed to a problem in storyView-assistent.jsjsjs:
    qemux86 user.err LunaSysMgr: {LunaSysMgrJS} Uncaught SyntaxError: Unexpected token ILLEGAL, file:///var/usr/palm/applications/$17$
    The cause are CRLF-chars (0D0A) after each line in the multiline string constant. But the string constant has to be in one line, so you have to put the whole text in one line or end every line with a backslash before CRLF
    first line \
    second line
    Hope that Helps,
    Attached Files Attached Files

Posting Permissions